17:03:50 <jamoluhrsen> #startmeeting integration
17:03:50 <odl_meetbot> Meeting started Thu Feb 23 17:03:50 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:50 <odl_meetbot> The meeting name has been set to 'integration'
17:04:03 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=7728
17:05:35 <jamoluhrsen> #action vrpolak to increase priority of bug 7728. maybe a blocker
17:06:07 <jamoluhrsen> #action jamoluhrsen to respond to own email about this cluster bringup issues
17:06:22 <jamoluhrsen> #topic release
17:07:15 <jamoluhrsen> #info no new info on release stuff.
17:07:36 <jamoluhrsen> #info karaf 4 upgrades and inactive projects are major items from release team
17:08:45 <jamoluhrsen> #info LACP was removed from autorel and distribution, but they have done the work to be put back.
17:09:16 <jamoluhrsen> #info ball is in LACP's court for now
17:11:15 <jamoluhrsen> #topic distribution
17:11:42 <jamoluhrsen> #info karaf 4 patch is prepared and ready for review
17:11:49 <vrpolak> #link https://git.opendaylight.org/gerrit/51762
17:12:08 <jamoluhrsen> #topic packaging
17:12:34 <jamoluhrsen> #info autorelease is now creating rpm builds now
17:13:05 <jamoluhrsen> #info pak/tutorial directory has the 1-click cluster tool merged
17:13:21 <jamoluhrsen> #info docker containers for openstack being brought in to packaging.
17:13:42 <jamoluhrsen> #info openstack kola patches in progress
17:14:06 <jamoluhrsen> #info odl interns working on deb deployments + puppet-opendaylight. nearly done
17:15:25 <jamoluhrsen> #info opnfv plugfest report out, good info regarding ODL
17:15:32 <jamoluhrsen> #topic builder
17:15:59 <dfarrell07> #link https://www.opnfv.org/wp-content/uploads/2017/02/OPNFV_Plugfest_II_Report_FINAL.pdf OPNFV plugfest report, good PR for ODL CI/CD
17:16:15 <jamoluhrsen> #info jjbuilder node is not used any more. builder jobs all now run on the same java builders as other projects.
17:18:48 <jamoluhrsen> #info openstack plugin was broken but new release seems ok, and our custom workaround for retry is now upstream
17:19:08 <jamoluhrsen> #info heat stack retry is now merged
17:20:01 <jamoluhrsen> #info ssh key copy is now more resilient because we now *wait* for connectivity on the spun up vms before cloning the releng/builder repo.
17:20:40 <jamoluhrsen> #info because of the above two points, the hope is that all further RED dots are hopefully problems in ODL things (test, jjb, odl)
17:21:47 <jamoluhrsen> #info please please report any red dot aborts that are infra related from now on
17:22:57 <jamoluhrsen> #info maybe some logstash work coming where we can send data from our jobs to help collect stats (like infra failures, etc) to help us have a better idea.  the beginnings of an ODL "top"
17:24:47 <jamoluhrsen> #info autorelease will hopefully start sending auto-emails when it fails. some patches are in the works
17:25:00 <jamoluhrsen> #info we also need projects to give better <name> fields in their poms
17:27:07 <jamoluhrsen> #link https://logs.opendaylight.org/releng/jenkins092/distribution-merge-carbon/566/archives/distribution_differences.txt.gz  <-- shows diffs between created distro and last posted to nexus
17:29:20 <jamoluhrsen> #info we can demo the distcompare tool to TWS
17:29:39 <jamoluhrsen> #topic misc
17:30:21 <jamoluhrsen> #info lots of discussions happening to make the networky projects of LF be more collaborative
17:30:43 <jamoluhrsen> #info several cross-project/tsc/board meetings happened last week at the open source leadership summit
17:31:13 <jamoluhrsen> #info as it pertains to us, some ideas were to try a POC to make OPNFV the cloud for ODL infra
17:34:23 <jamoluhrsen> #info one main concern is who/how is this supported. currently we *pay* RackSpace and we can expect them to help resolve issues. If we use OPNFV, it's opensource and we don't know who/how it would be supported... yet
17:39:17 <jamoluhrsen> #info not just internal ODL is asking for a sanity CSIT job. even others (e.g. OPNFV) wants to see this 100% always passing sanity job.
17:40:01 <jamoluhrsen> #info having unstable CSIT does not help others get an idea of the quality of some distro.
17:41:02 <jamoluhrsen> #action jamoluhrsen to create trello card(s) for the steps needed to get to this sanity job
17:43:17 <jamoluhrsen> #info maybe we can use a sanity -gate- job. projects can use those for their gating and it can be for our sanity job
17:45:02 <jamoluhrsen> #info another new idea is to create a smaller distribution. for example, an opnfv autorelease job that only creates a distro with projects that opnfv needs
17:46:30 <zxiiro> dfarrell07: Can you keep abelur in the loop with the smaller distribution work? I think it would be useful for him to learn about how the distribution is created.
17:47:39 <jamoluhrsen> #info there was an idea that opnfv apex was going to be able to give ODL snapshots to deploy in our RackSpace cloud, but that idea is probably dead. RackSpace cloud wont let us use non-rackspace images
17:48:45 <jamoluhrsen> #info there are containers that we could deploy that use devstack. but we wonder if something like apex could create containers with their triple0 deployment
17:49:15 <jamoluhrsen> #info LuisGomez_ brings up the idea that downstream projects gate on upstream CSIT jobs.
17:49:42 <jamoluhrsen> #info can we define a process that makes this more of a requirement.
17:50:24 <jamoluhrsen> #info first step is just to provide the jobs and gerrit keywords for projects to use if they want.
17:51:56 <jamoluhrsen> #info maybe we provide the highly reliable (still nonexistent) sanity job as the gate
17:52:58 <jamoluhrsen> #info LuisGomez_ notes that we need a naming convention
17:56:53 <jamoluhrsen> #endmeeting