17:01:15 <jamoluhrsen> #startmeeting integration
17:01:15 <odl_meetbot> Meeting started Thu Mar  2 17:01:15 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:15 <odl_meetbot> The meeting name has been set to 'integration'
17:04:51 <jamoluhrsen> #topic packaging
17:05:35 <jamoluhrsen> #info new deb changes merged this week, making deb packaging easier
17:06:12 <jamoluhrsen> #info autorelease job now triggering rpm jobs, but they are now broken.
17:07:01 <jamoluhrsen> #action dfarrell07 to disable the rpm jobs, using disable in the jjb patch
17:07:39 <jamoluhrsen> #info trello re-org for packaging always happening .  kudos to dfarrell07 for that
17:07:46 <jamoluhrsen> #topic release
17:08:21 <jamoluhrsen> #info boron SR3 is in 3 weeks. cutoff in 2.5 weeks
17:08:22 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule   <--- Boron SR3 is in three weeks on 3/23/2017, with cutoff in 2.5 weeks.
17:08:46 <jamoluhrsen> #action jamoluhrsen to poke in to distribution-test job for Boron to see if it's not totally broken
17:09:04 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/184/
17:09:07 <jamoluhrsen> #info feb 26th was last successful boron autorelease
17:09:30 <jamoluhrsen> #action zxiiro abelur to check if autorelease needs extra help/debug?
17:09:33 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- M5 Offset 0 and M4 Offset 2 is due today.
17:09:43 <jamoluhrsen> #info Carbon Mx statuses are due today
17:10:03 <jamoluhrsen> #info M5 report is expecting projects to link in karaf4 upgrade patch
17:10:13 <anipbu> #info At this point, all projects should be in Autorelease.  TSC reserves right to remove projects by RC0 if they do not build successfully in autorelease.
17:11:13 <jamoluhrsen> #info techincally all projects should be included in autorelease now. federation is the last project, but looks like it should be good.
17:11:28 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:karaf4   <--- Karaf 4 moving on target.  Status is GREEN light.  "Kernal" projects done.  Protocol projects pending.  App projects patches are being submited at the moment.
17:11:50 <anipbu> #info Huge thanks to Stephen Kitt
17:12:01 <jamoluhrsen> #info karaf4 upgrade is on-target, status green. all kernel projects mostly done, protocol on the way and app patches in progress
17:12:08 <jamoluhrsen> skitt, ^^^
17:12:31 <skitt> anipbu, thanks ;-)
17:12:35 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend   <--- no successfully in month
17:13:12 <jamoluhrsen> #info anipbu raises red flags about autorelease failing
17:13:28 <anipbu> #link https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707   <--- Catagorizing autorelease failures
17:17:07 <odp-gerritbot> A change was merged to integration/distribution: add federation feature to distribution  https://git.opendaylight.org/gerrit/52621
17:17:10 <jamoluhrsen> #info one autorelease failure (e.g. dlux) was failing because of an external problem (like some server is down) that is an expensive failure when autorel is an 8h job
17:17:39 <jamoluhrsen> #info Luis points out we can ask projects to remove these unstable tests if they happen frequently
17:18:48 <jamoluhrsen> #info will bring this autorelease red flag to the TSC
17:19:09 <anipbu> #link https://lists.opendaylight.org/pipermail/dev/2017-March/003371.html   <--- MD-SAL Binding Generator	API Change Waiver
17:19:11 <jamoluhrsen> #info we are now at API freeze. projects must submit api change waiver request going forward
17:20:53 <odp-gerritbot> Vratko Polák proposed a change to integration/distribution: Karaf4 features and distribution  https://git.opendaylight.org/gerrit/51762
17:21:15 <jamoluhrsen> #info openflow java change coming (perf related change) with a weather request. not an API change
17:21:57 <jamoluhrsen> #action anipbu will investigate the openflowplugin weather item and report back some risk analysis next week.
17:22:52 <jamoluhrsen> #topic distribution
17:23:11 <jamoluhrsen> #info aaa project is removing aaa-auth feature
17:23:23 <jamoluhrsen> #info lacp project added back to distribution, and -ui feature added
17:23:35 <jamoluhrsen> #info federation is coming to distribution soon
17:23:58 <jamoluhrsen> #info karaf 4 patch is ready to merge after next verify (did a rebase)
17:24:17 <jamoluhrsen> #info releng issues y'day with distribution-merge, but fixed
17:24:43 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/52560/ <--- patch to fix distribution-merge
17:26:16 <jamoluhrsen> #topic builder
17:26:21 <jamoluhrsen> #topic builder
17:26:21 <zxiiro> #link https://trello.com/b/wH8qcNSO/odl-releng releng/builder Trello board
17:26:21 <zxiiro> #link https://git.opendaylight.org/gerrit/#/q/topic:improve-linting Improve Linting
17:27:39 <vrpolak> I still do not get the yesterday's merge failures. Example: https://logs.opendaylight.org/releng/jenkins092/distribution-merge-carbon/714/console.log.gz
17:27:41 <jamoluhrsen> #info auto release notify script is working and sending emails.
17:27:55 <zxiiro> #link https://trello.com/c/EGYoCYXX autorelease notify email script
17:28:53 <jamoluhrsen> #info auto release email will not be able to be specific until projects update their <name> fields in all of their poms
17:29:45 <jamoluhrsen> vrpolak, I'll look again and sync up with you after this mtg
17:30:38 <jamoluhrsen> #info anipbu suggests we might want to wait for karaf4 merged, but zxiiro thinks the merge conflicts would be minimal
17:32:05 <jamoluhrsen> #info jamoluhrsen points out that infra felt ok last week and early this week.
17:32:13 <jamoluhrsen> #topic misc
17:33:24 <jamoluhrsen> #info releng builder had some issue recently that broke the 1node-verify csit job, but fixed recently
17:34:40 <jamoluhrsen> #action jamoluhrsen to reply to bier project
17:35:06 <jamoluhrsen> #link https://trello.com/c/bLIRcSbV/461-create-sanity-test-for-projects-relevant-to-opnfv <--- trello card for sanity csit job
17:35:31 <jamoluhrsen> #info Luis can work to get an OFP suite for this sanity job.
17:39:24 <jamoluhrsen> #action LuisGomez will drive this sanity test work
17:41:12 <anipbu> +1 AWESOME!!!
17:43:17 <jamoluhrsen> #info one idea we've had in the past was to submit system test plans in robot code, and it could be the new way for projects to submit their test plans
17:43:45 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/51397/ <-- patch with an example of robot style test plan
17:45:36 <jamoluhrsen> #info seems like an agreement that we should require this kind of test plan for nitrogen and forward
17:45:49 <jamoluhrsen> #info we need a wiki to help start listing our nitrogen requirements
17:46:39 <jamoluhrsen> #action jamoluhrsen to start nitrogen planning/requirements wiki
17:54:10 <jamoluhrsen> #info we scrubbed the Doing column in Trello
17:54:13 <jamoluhrsen> #endmeeting