17:03:09 <jamoluhrsen> #startmeeting integration
17:03:09 <odl_meetbot> Meeting started Thu Mar  9 17:03:09 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:09 <odl_meetbot> The meeting name has been set to 'integration'
17:05:01 <jamoluhrsen> #topic distribution
17:05:21 <jamoluhrsen> #info M2 and most of M3 status are sent now.
17:06:11 <jamoluhrsen> #info tsdr project is working on getting feature back to features-test, but verify job is failing
17:06:55 <jamoluhrsen> #info also strange error came in distro check in a yangtools patch...
17:08:39 <jamoluhrsen> #info karaf4 changes have a risk to other projects that might break other projects. maybe monday we will merge
17:10:51 <jamoluhrsen> #topic release
17:11:17 <anipbu> https://lists.opendaylight.org/pipermail/release/2017-March/009409.html
17:11:49 <jamoluhrsen> #link  https://lists.opendaylight.org/pipermail/release/2017-March/009409.html   <-- mdsal api change waiver  may have a bigger impact to several projects.
17:11:58 <zxiiro> huh i can't hear an but i can hear jamo
17:12:04 * zxiiro restarts webex
17:12:43 <jamoluhrsen> #info depending projects snmp snbi tsdr capwap (tcp l2switch with abandoned patches) need to merge patches or will need to be removed from release
17:13:27 <jamoluhrsen> #info projects will get a notice, then 2 weeks to click +2/submit, then removal from distribution and autorelease.
17:14:15 <jamoluhrsen> #info Boron release in 2 weeks, cutoff in 1.5 weeks. autorelease is failing again.
17:14:47 <jamoluhrsen> #info time to start logging blocking bugs for autorelease failures
17:15:01 <anipbu> https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/198/
17:15:56 <anipbu> https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046
17:16:13 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046  <-- tracking sheet for autorelease failures
17:16:34 <jamoluhrsen> #topic packaging
17:17:03 <jamoluhrsen> #info work is done so that rpm builds are coming from autorelease builds  w00t!
17:17:44 <jamoluhrsen> #info still trouble publishing rpms to koji (sp?)
17:18:09 <jamoluhrsen> zxiiro, can you hear others now?
17:18:30 <zxiiro> jamoluhrsen: yes
17:20:32 <jamoluhrsen> #info regarding smaller distro (opnfv-distro) dfarrell07 wonders how to test the work
17:24:45 <jamoluhrsen> #info new packaging repos are in place for puppet and ansible, but no permissions to push yet?
17:27:08 <jamoluhrsen> #info int/pak has readthedocs pages now.
17:27:44 <jamoluhrsen> #info lots of linting coming in from everywhere, and coming to int/pak soon
17:28:29 <jamoluhrsen> #topic builder
17:28:45 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/51325/ This is ready to be merged to RelEng/Builder imho, if someone else wants to look
17:28:52 <jamoluhrsen> #info lftools coming along.
17:28:52 <zxiiro> #link https://lf-releng-tools.readthedocs.io/en/latest/ lftools
17:29:10 <zxiiro> #link https://gerrit.linuxfoundation.org/infra/#/admin/projects/releng/releng-tools lftools git
17:30:22 <jamoluhrsen> #info common tools will be moving from project repos to lftools (e.g. autorel version bumping)
17:31:23 <jamoluhrsen> #info there may be a lf-jjb repo coming that we can submodule in to our specific projects jjb repos
17:32:01 <jamoluhrsen> #info shellcheck linting came in, but some breakages came because of it. (e.g. CSIT all failed because ssh key copy broke)
17:32:44 <jamoluhrsen> #info new ubuntu mininet images in the sandbox now. needs to be tested
17:33:53 <jamoluhrsen> #action LuisGomez will be validating the new ubuntu image in sandbox.
17:33:54 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/netvirt/netvirt-csit-hwvtep-openstack.yaml#L64 example of changing image type for csit
17:35:03 <zxiiro> #link http://docs.opendaylight.org/en/latest/submodules/releng/builder/docs/jenkins.html#build-minions available-images
17:37:36 <jamoluhrsen> #info our jenkins queue is large. autorelease beryllium is one hog.
17:37:59 <jamoluhrsen> #action zxiiro to turn beryllium autorelease down from once a day to once a week.
17:38:25 <odp-gerritbot> Abbas P Pareedkunju proposed a change to integration/test: To verify 52152 on the non-l2gw testcases  https://git.opendaylight.org/gerrit/52856
17:41:21 <jamoluhrsen> #action jamoluhrsen to bring it up with netvirt that their jobs are major jenkins users. can we be nicer?
17:43:01 <jamoluhrsen> #info vrpolak suggests that if our @daily CSIT job could possibly check if the autorelease trigger has recently run?
17:45:43 <jamoluhrsen> #info one idea could be to stick a shell script at the top of our @daily distribution-test job that will forcefully abort if it found that autorelease has already triggered
17:46:26 <jamoluhrsen> #action LuisGomez to send an email about strategy for triggering csit
17:48:54 <jamoluhrsen> #info autorelease notify script improvements coming.  maybe dont need <name> in pom.xml s
17:48:59 <jamoluhrsen> #topic misc
17:49:53 <jamoluhrsen> #infa mgkwill still planning to have auto-cist gerrit send emails to real people
17:52:33 <jamoluhrsen> #action jamoluhrsen to send email to release to ask them to update the system test report
17:54:24 <vrpolak> https://wiki.opendaylight.org/view/Integration/Distribution/Carbon_Feature_Tests
17:54:29 <vrpolak> https://wiki.opendaylight.org/view/Integration/Distribution/Carbon_Test_Report
17:55:36 <zxiiro> #info https://git.opendaylight.org/gerrit/53097 Patch to make Beryllium autorelease only build once a week
17:58:48 <gvrangan> jamoluhrsen: One quick question
17:58:59 <gvrangan> Is  OVS version causing problems in mitaka jobs?
18:02:54 <jamoluhrsen> #endmeeting