16:03:52 <jamoluhrsen> #startmeeting integration
16:03:52 <odl_meetbot> Meeting started Thu Mar 16 16:03:52 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:52 <odl_meetbot> The meeting name has been set to 'integration'
16:05:04 <jamoluhrsen> #topic distribution
16:05:23 <jamoluhrsen> #info karaf4 distro is being built but no restconf yet
16:05:51 <jamoluhrsen> #info distribution verify jobs are not good enough, we've realized
16:06:24 <jamoluhrsen> #info vrpolak has ideas for a better verify job, but nothing quite working yet.
16:06:49 <jamoluhrsen> #info verify job hopefully ready by monday 3/20
16:06:55 <jamoluhrsen> #info ttp renamed top level feature
16:08:14 <jamoluhrsen> #info LuisGomez points out that when other projects start converting to karaf4 we will then have two distro-check jobs per project
16:09:53 <jamoluhrsen> #info concern around delivering karaf4 in carbon with things not working yet
16:11:01 <jamoluhrsen> #info vrpolak thinks it's probably 50/50 that we deliver karaf4 in carbon
16:12:04 <jamoluhrsen> #topic release
16:12:34 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule   <--- Boron SR3 Cutoff this Sunday at 3/19/2017 23:59 UTC with a release on 3/23/2017
16:12:42 <anipbu> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Eight blocker bugs in openflowplugin,
16:12:42 <anipbu> odlparent, netvirt
16:12:42 <jamoluhrsen> #info boron SR3 cutoff is in 3 days. release one week after
16:13:05 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/boron <--- 46 patches pending for stable/boron
16:13:13 <anipbu> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR2=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-12-15 <--- 46 patches modifying yang files without API Freeze Waiver between Boron SR2 and Boron SR3
16:15:04 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/   <--- Boron Autorelease Build Failure.  Last successful on Sunday 3/12/2017.  ***RED FLAG***
16:15:39 <anipbu> #info FAILURE! - in org.opendaylight.controller.sal.restconf.impl.nn.to.xml.test.NnToXmlTest
16:15:40 <anipbu> nnAsYangUnionToXmlTest(org.opendaylight.controller.sal.restconf.impl.nn.to.xml.test.NnToXmlTest)
16:18:23 <anipbu> https://git.opendaylight.org/gerrit/#/c/53411/
16:19:21 <anipbu> #info M4 Status Missing aaa, snmp, capwap, cardinal, eman, int/dis, next, of-config, opflex, packetcable, ttp, snbi, natapp, didm, sdninterfaceapp
16:19:43 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-March/009409.html   <--- MD-SAL Binding Generator API Change Impacted Projects ahve merged Patches
16:19:50 <anipbu> #info https://git.opendaylight.org/gerrit/#/q/topic:binding-gen-v1-refactoring-package-naming    <--- No Projects Removed
16:20:17 <anipbu> #link https://lists.opendaylight.org/pipermail/release/2017-March/009499.html  <-- SFC MAC Chaining Merged
16:20:40 <anipbu> https://lists.opendaylight.org/pipermail/release/2017-March/009587.html   <-- NetVirt Intent to seek functionality freeze waiver
16:20:51 <anipbu> #link https://git.opendaylight.org/gerrit/#/q/topic:karaf4   <--- Insuffcient patches submitted for App projects for Karaf 4.
16:21:56 <jamoluhrsen> #topic builder
16:22:13 <zxiiro> #link https://lists.opendaylight.org/pipermail/release/2017-March/009566.html Certificates Update for Chrome 57
16:23:59 <jamoluhrsen> #info there is a beryllium failure that may be infra related, but issue is it can't find files...  low priority but will get investigated
16:24:51 <vrpolak> #link https://wiki.opendaylight.org/view/BestPractices/Commit_Messages
16:24:56 <jamoluhrsen> #info releng/builder is now doing verify on commit messages
16:25:35 <vrpolak> #info coala rules: https://github.com/coala/bear-docs/blob/master/docs/GitCommitBear.rst
16:25:40 <jamoluhrsen> #action zxiiro to send email reminder about commit message bear validation
16:27:37 <jamoluhrsen> #agree to enable git commit bear to int/test and int/pak
16:28:58 <jamoluhrsen> #info one idea is to find a way to get the "best practices" for commit messages shown when the bear fails.
16:29:53 <jamoluhrsen> #action jamoluhrsen dfarrell07 to enable gitcommitbear in int/test int/pak
16:30:26 <jamoluhrsen> #topic packaging
16:30:57 <jamoluhrsen> #info still work going on for the mini opnfv release
16:31:22 <jamoluhrsen> #info puppet module work to enable/configure repo file
16:32:31 <jamoluhrsen> #topic misc
16:35:10 <anipbu> #link https://www.linuxfoundation.org/announcements/linux-foundation-announces-merger-of-open-source-ecomp-and-open-o%C2%A0to-form-new-open   <--- ONAP Announced.  ECOMP uses ODL.
16:37:22 <jamoluhrsen> #info ONS is in 3 weeks. reminder about docfest starting Sunday through Monday midday
16:39:09 <jamoluhrsen> #info karaf4 troubles on integration list, maybe vrpolak knows
16:39:30 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-March/009272.html <-- email about karaf4 troubles
16:40:28 <jamoluhrsen> #info talk about shorter release ideas (6 months) possibly syncing up with OPNFV
16:40:53 <jamoluhrsen> #info talk about peer documentation review. current proposal would be to put integragtion team in group with FAAS, bier, packetcable
16:41:00 <jamoluhrsen> #endmeeting