16:04:26 <jamoluhrsen> #startmeeting integration
16:04:26 <odl_meetbot> Meeting started Thu Mar 30 16:04:26 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:26 <odl_meetbot> The meeting name has been set to 'integration'
16:04:53 <jamoluhrsen> #topic distribution
16:05:25 <jamoluhrsen> #info karaf4 progress is blocked because restconf just does not work.
16:05:44 <jamoluhrsen> #info one problem is that SFT might not be failing in karaf4 when it should
16:05:55 <jamoluhrsen> #info other problem is that netconf devs are too busy to take a look
16:06:20 <vrpolak> # link https://git.opendaylight.org/gerrit/54031
16:06:30 <vrpolak> #link https://git.opendaylight.org/gerrit/53986
16:06:33 <jamoluhrsen> #action LuisGomez to look at distribution patches 54031 and 53986
16:07:05 <jamoluhrsen> #topic builder
16:07:17 <LuisGomez> patches are merged already
16:08:36 <jamoluhrsen> #info still getting complaints about sandbox queue being too large.
16:09:00 <jamoluhrsen> #action jamoluhrsen to look at jenkins job rename script in releng/builder to see if we can quickly get a script to auto-disable jobs
16:09:13 <jamoluhrsen> #info there is a python rest lib for jenkins we can look at too.
16:10:04 <jamoluhrsen> #info we cannot add any more robot jobs to the sandbox. it was recently reduced from 6 to 5 because we are at our limits
16:10:29 <jamoluhrsen> #topic packaging
16:10:52 <jamoluhrsen> #info tons of linting work done for int/pak repo.
16:11:47 <jamoluhrsen> #info puppet-opendaylight was broken and fixed recently thanks to the auto-test job
16:12:30 <jamoluhrsen> #info opnfv subset distro is still making back burner progress
16:12:55 <jamoluhrsen> #topic release
16:13:15 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731  <--- boron sr3 status tracker
16:14:07 <jamoluhrsen> #info vrpolak has updated his key projects for sr3. jamoluhrsen will do his after tsc today.
16:21:03 <jamoluhrsen> #topic misc
16:22:14 <jamoluhrsen> #info jamoluhrsen asks if we want to move to carbon? answer is either when we release carbon or when we cut stable/carbon?
16:22:40 <jamoluhrsen> #info vrpolak thinks we should wait until we get carbon release
16:23:45 <jamoluhrsen> #info zxiiro points out that once we cut stable/carbon we will now have Be, Bo, C, and master branches active and will make a lot more jobs.
16:24:23 <jamoluhrsen> #info suggestion that we wait to cut stable/carbon? still a lot of work coming in, bug fixes, etc.
16:25:45 <jamoluhrsen> #agree to wait to change verify job to carbon.
16:27:46 <jamoluhrsen> #info question about moving VMs w/ ovs from 2.3 to 2.5? LuisGomez says it's done... Only OVS 2.x is now 2.5.
16:28:19 <jamoluhrsen> #info currently we only have very old 2.0 and now 2.5
16:28:43 <jamoluhrsen> #info LuisGomez reports the sanity job is finally stable
16:29:25 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/Sanity-Jobs/  <--- sanity job tab in jenkins
16:30:19 <jamoluhrsen> #info sanity job is still just triggering as part of distribution-test
16:30:45 <jamoluhrsen> #info plan is to create a distribution-test-sanity which will only include these sanity jobs.
16:31:43 <jamoluhrsen> #info jamoluhrsen wants to have some automation/alarms around the sanity job having any failures. it should NEVER fail unless something is broken.
16:33:29 <jamoluhrsen> #info vrpolak has an idea to create a script that will automatically remove projects from both autorelease and distribution and creates the gerrit patches.
16:33:50 <jamoluhrsen> #info the script to do this auto-remove might not be trivial
16:34:10 <jamoluhrsen> #info even with the script, we need a process (from TSC) in order to figure out when we can use this automation to remove projects
16:34:50 <jamoluhrsen> #info vrpolak points out the process is just around who/how/when the gerrit patches are +2/merge, but the script can be run at any time to create the patches
16:35:23 <jamoluhrsen> #info sounds like a good hackfest project
16:39:38 <jamoluhrsen> #info looking for docfest ideas.  wiki cleanup (move stuff to readthedocs, delete/deprecate old junk), search and destroy stale/wrong cluster docs, remove wiki duplication, test coding guidelines page to readthedocs, integration requirements for the release,
16:40:14 <jamoluhrsen> #info auto document robot test suites (like we already do for test libs)
16:46:07 <jamoluhrsen> #info conversation around https://git.opendaylight.org/gerrit/#/c/53130 with new weekly job type being created.
16:52:25 <jamoluhrsen> #info new paradigm to run our distribution-test job daily on snapshot, *only* if autorelease had failed. if autorel had passed, it will run distribution-test and no need to also run it with a daily trigger
16:52:50 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/54068/ <--- patch to run distro-test only if autorelease has failed.
16:54:25 <jamoluhrsen> #info just to be clear, it's possible that we will not run very much on SNAPSHOT distributions if autorelease is very healthy
16:55:01 <jamoluhrsen> #info we may want to add the ability to run SNAPSHOT periodically in case autorelease is only what triggers distribution-test
17:00:21 <jamoluhrsen> #endmeeting