16:03:36 <jamoluhrsen> #startmeeting integration
16:03:36 <odl_meetbot> Meeting started Thu Apr 13 16:03:36 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:36 <odl_meetbot> The meeting name has been set to 'integration'
16:04:19 <jamoluhrsen> #topic distribution
16:05:32 <jamoluhrsen> #info nitrogen branch cut happened, but there was a period when branches weren't fully locked so some troubles came in
16:05:44 <odp-gerritbot> Peter Gubka proposed a change to integration/test: listener isolation testplan  https://git.opendaylight.org/gerrit/54586
16:06:03 <zxiiro> jamoluhrsen: omw
16:06:53 <jamoluhrsen> #info netvirt had a bad patch in nitrogen which conflicts wiht carbon artifacts so sometimes netvirt carbon wont build
16:07:19 <jamoluhrsen> #info but eman also has a bad features file in nitrogen so no nitrogen will build
16:08:50 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/54860/3 https://git.opendaylight.org/gerrit/#/c/54923/   <--- EMAN blocking Carbon-RC0
16:09:17 * dfarrell07 agrees with using ban-hammer
16:09:23 <jamoluhrsen> #info anipbu points out that we can remove eman because they are preventing us from building carbon and RC0 is here
16:09:39 <jamoluhrsen> #info actually, we just realized that the eman patches have JUST NOW been merged.
16:09:47 <jamoluhrsen> vrpolak, can you pass the ball
16:10:22 <jamoluhrsen> #info capwap project is officially dropped out of Carbon SR.
16:10:53 <jamoluhrsen> #info vrpolak has the patch(es) to remove capwap from distribution features
16:11:12 <jamoluhrsen> #action zxiiro will remove capwap from autorelease
16:12:01 <jamoluhrsen> #info karaf4 csit jobs are in progress still, and being debugged.
16:12:36 <jamoluhrsen> #info zxiiro asks if we should remove capwap from nitrogen too?
16:12:42 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=8208
16:13:00 <jamoluhrsen> #action zxiiro to remove capwap from autorelease nitrogen
16:13:16 <jamoluhrsen> #action LuisGomez to remove capwap from int/dist for nitrogren branh
16:14:21 <jamoluhrsen> #topic packaging
16:14:40 <jamoluhrsen> #info more iterations on packaging automation
16:15:08 <jamoluhrsen> #info some strange issue around our ubuntu hosts
16:15:38 <jamoluhrsen> #info boron sr3 packages are released
16:17:37 <jamoluhrsen> #info new puppet and ansible repos are passed IPR so we can now move them from github to our ODL repos
16:18:02 <jamoluhrsen> #info we are going to use the method to keep the history on these repo migrations
16:19:19 <jamoluhrsen> #info mgkwill and dfarrell07 gave a packaging related talk at ONS
16:20:02 <jamoluhrsen> #topic builder
16:20:13 <zxiiro> #link https://git.opendaylight.org/gerrit/#/q/topic:RELENG-11
16:21:53 <jamoluhrsen> #info artifacts will now go to nexus instead of hanging off of jenkins
16:23:23 <jamoluhrsen> #info before we merge these patches to store artifacts on nexus, we need to know that patch-test works
16:24:44 <jamoluhrsen> #info we should get these patches merged later today.
16:26:33 <jamoluhrsen> #info currently the link to the nexus artifact for the distribution will be in the console log. we can look in to making it a gerrit comment
16:26:38 <jamoluhrsen> #topic release
16:26:50 <anipbu> #link https://git.opendaylight.org/gerrit/#/c/54860/3 https://git.opendaylight.org/gerrit/#/c/54923/   <--- EMAN blocking Carbon-RC0.  They have merge their patches.
16:26:57 <anipbu> #link https://lists.opendaylight.org/pipermail/capwap-dev/2017-April/000193.html   <--- CAPWAP officially dropped out of Carbon-RC0
16:27:06 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896   <--- Karaf 4 Migration 78% complete: 8 patches pending, 3 without patches
16:27:06 <anipbu> #info All projects have been notified of Karaf 4 (see column I)
16:27:49 <jamoluhrsen> #info anipbu suggests it's time to remove the projects still left with pending (or no) karaf4 patches
16:29:11 <odp-gerritbot> Peter Gubka proposed a change to integration/test: listener isolation testplan  https://git.opendaylight.org/gerrit/54586
16:29:28 <jamoluhrsen> #info we can bring this up on the TSC today and get agreement to remove these 8 projects, and we can take those steps today
16:30:04 <jamoluhrsen> #info correction, not 8 projects, it's 11.
16:30:53 <jamoluhrsen> #info vrpolak notes that only 2 features are actually in karaf4 distribution
16:32:52 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511   <--- 13 Carbon Blocker Bugs.
16:33:04 <anipbu> #info All projects have been notified of carbon blocker bugs.  See column D.
16:33:19 <anipbu> #info abelur: zxiiro: Need releng to submit patch for labeling Carbon-RC0.
16:33:42 <anipbu> #link https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review   <--- Release Documentation Due Next Week
16:34:14 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- RC0 Today.  RC1 4/20/2017.  Branches are locked on RC1 next week.
16:36:30 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#M3:_Functionality_Freeze
16:37:50 <jamoluhrsen> #topic misc
16:38:14 <jamoluhrsen> #info LuisGomez did send the M4 and M5 reports for integration/distribution. thanks
16:38:51 <jamoluhrsen> #info zxiiro was surprised that the distribution-check job is not skipping tests
16:39:22 <jamoluhrsen> #info the assumption was that the distribution-check doesn't need to run the tests, because it's being run by the other verify job
16:39:54 <jamoluhrsen> #info vrpolak points out that the tests being run in the distro-check job are different tests
16:40:48 <jamoluhrsen> #info zxiiro notes that distribution-check is now taking aprox 40m, but maybe some of that time is coming because we are also building karaf4 at the same time
16:41:56 <jamoluhrsen> praveen_, can you mute?
16:44:44 <jamoluhrsen> #info DDF coming. add your topics and sign up.
16:44:49 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum <--- ddf wiki
16:46:51 <jamoluhrsen> #info jamoluhrsen on PTO from now until the 24th, zxiiro starts PTO on the 24th, anipbu will be gone from now until 5/2.
16:48:26 <jamoluhrsen> #topic LuisGomez in talks with other groups (e.g. OPNFV) for test strategy/collab
16:48:30 <jamoluhrsen> #undo
16:48:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1903f10>
16:48:39 <odp-gerritbot> Peter Gubka proposed a change to integration/test: listener isolation testplan  https://git.opendaylight.org/gerrit/54586
16:48:43 <jamoluhrsen> #info  LuisGomez in talks with other groups (e.g. OPNFV) for test strategy/collab
16:49:58 <jamoluhrsen> #info one idea would be for all of ODL openstack related jobs to run solely in OPNFV
16:50:34 <jamoluhrsen> #info OPNFV is able to stand up openstack test environments in a few minutes as opposed to our current 20-30 minutes
16:54:29 <jamoluhrsen> #info LuisGomez will ask some people from the infra/collab group to show up to the ddf and we could have a session around this
16:55:28 <jamoluhrsen> #endmeeting