16:00:31 <jamoluhrsen> #startmeeting integration
16:00:31 <odl_meetbot> Meeting started Thu Apr 27 16:00:31 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:31 <odl_meetbot> The meeting name has been set to 'integration'
16:01:20 <dfarrell07> #link https://zoom.us/j/770709266 Using Zoom today FYI
16:06:25 <jamoluhrsen> #topic distribution
16:06:50 <jamoluhrsen> #info all projects not helping with karaf4 have now been removed
16:07:25 <jamoluhrsen> #info features started getting added, but distro check was taking too long, so we have now removed those features (was taking over 2 hours)
16:08:44 <jamoluhrsen> #info aaa project had some changes that added issues that affected other projects, but now that features are removed the distro-check job works.
16:10:56 <jamoluhrsen> #action tykeal to add distribution4-check to priority
16:12:03 <jamoluhrsen> #info snmp4sdn is now back in distribution after dist4-check job passeds
16:12:50 <jamoluhrsen> #info bug 7900 (feature repos too big, takes too long) fix is merged, but behavior is now changed and each feature is tested in isolation which might report new failures
16:13:23 <jamoluhrsen> #info projects might start seeing failures in their verify job because of bugfix for 7900
16:15:29 <jamoluhrsen> #info nitrogen csit is only karaf4, so no reason to run autorelease because no features are there to be tested
16:16:10 <jamoluhrsen> #info nitro patch-test will use karaf3, so if dev in gerrit runs patch test it will be ok.
16:17:33 <jamoluhrsen> #info we can revisit when to enable nitro autorel when we start to see features in karaf4 distro?
16:18:51 <jamoluhrsen> #topic release
16:19:13 <jamoluhrsen> #info jamoluhrsen thinks top priority should be to release carbon
16:21:54 <jamoluhrsen> #info if we have to fix bugs to release carbon. if we *must* ship karaf4 in carbon, then we have to realize it's hard to fix bugs while trying to bring in karaf4
16:24:20 <jamoluhrsen> #info LuisGomez points out that we are seeing some inconsistent pass/fail on same patches for project verifications, so it's hard to be fully confident that things are going to be ok.
16:25:39 <jamoluhrsen> #info not until we are settled with distro-check and jenkins queue is flushed to know if our recent fixes are stable or not. So, maybe by tomorrow we can know some better timeline with where we are going with karaf4 and carbon release
16:28:30 <jamoluhrsen> #info vrpolak suggests that the first bucket of features to add to karaf4 should be netconf as they have shown similar inconsistent issues that we saw with aaa. so if netconf is stable, we have a little confidence
16:30:49 <jamoluhrsen> #info autorelease is always breaking. colindixon wants to run it twice, once with no tests to produce actual stuff, then again with tests so we can all cheer for the new random test that is going to fail
16:31:50 <jamoluhrsen> #info are these tests really only failing in autorelease, or are they just unstable tests in the projects themselves
16:32:23 <odp-gerritbot> A change was merged to integration/test: TC for network,subnet and port update usecase  https://git.opendaylight.org/gerrit/53795
16:33:16 <jamoluhrsen> #info UT probably has way better coverage compared to CSIT, so we need to care about those failures, but how/why are these damn things popping up every single time we run autorelease but not in the project builds
16:33:55 <odp-gerritbot> Joshua proposed a change to integration/test: Add logging of operational port status  https://git.opendaylight.org/gerrit/56067
16:33:57 <jamoluhrsen> #topic builder
16:34:33 <jamoluhrsen> #info mandatory maint this saturday. things like jenkins security update
16:35:55 <jamoluhrsen> #info all long running jobs will be cancelled for this maint window, and wont be restarted (except autorelease)
16:37:01 <jamoluhrsen> #info jamoluhrsen thinks it sucks for LF guys to have to stop jenkins, wait, clear stale nodes, restart jenkins.... seems to happen multiple times a week.
16:37:54 <jamoluhrsen> #info we are moving from RackSpace to vexhost. RackSpace contract is up and we are moving on.
16:39:49 <jamoluhrsen> #info still wont have ssh access in vexhost, but we will be able to use apex images in vexhost.
16:40:32 <jamoluhrsen> #info the move happen before the end of the year.
16:43:28 <jamoluhrsen> #info csit can use the 172 net on a subnet interface (e.g. eth0:1) and should be fine. but those addresses cannot exit the localhost because the openstack networking will be blocking EVERYTHING but the localhost ip
16:46:54 <jamoluhrsen> #action jamoluhrsen to check the other CSIT that is spinning up a VM, grabbing an ip and then using that ip on a subinterface. (tykeal thinks that should not work)
16:47:15 <jamoluhrsen> #action vrpolak to send email on integration-dev with a link to that job.
16:47:40 <jamoluhrsen> #topic packaging
16:48:03 <jamoluhrsen> #info puppet opendaylight jobs are now online
16:48:36 <jamoluhrsen> #info verify job for puppet sanity is now working
16:48:46 <vrpolak> #link https://git.opendaylight.org/gerrit/49334  <-- suite taking IP address from other VM.
16:49:44 <jamoluhrsen> #info vpp patch came in for puppet-opendaylight
16:50:18 <jamoluhrsen> #info ansible-opendaylight import having trouble (git troubles)
16:50:31 <jamoluhrsen> #info probably will wait for zxiiro-away to help with that.
16:51:07 <vrpolak> #link https://logs.opendaylight.org/releng/jenkins092/sxp-csit-3node-periodic-routing-only-carbon/14/archives/log.html.gz  <-- one successful run in production.
16:51:09 <jamoluhrsen> #info puppet-opendaylight import was fine and we were able to keep history
16:51:15 <jamoluhrsen> thanks vrpolak
16:52:03 <jamoluhrsen> #info dfarrell07 wants a packaging tab in jenkins
16:52:17 <jamoluhrsen> #action dfarrell07 to send helpdesk ticket with regex for said packaging tab
16:53:44 <jamoluhrsen> #topic misc
16:56:42 <jamoluhrsen> #info gvrangan can figure out best way forward to move openstack jobs to only use openstack cli (assuming gbp and vtn remove mitaka jobs)
16:57:32 <jamoluhrsen> #info vrpolak brings up how an isolated member should behave. currently it responds with 401 on every query.
16:59:58 <jamoluhrsen> #endmeeting