16:01:01 <jamoluhrsen> #startmeeting integration
16:01:01 <odl_meetbot> Meeting started Thu May 11 16:01:01 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:01 <odl_meetbot> The meeting name has been set to 'integration'
16:05:00 <jamoluhrsen> #topic distribution
16:05:33 <jamoluhrsen> #info carbon will release with karaf3, no distribution problems that we know of.
16:05:52 <jamoluhrsen> #info LuisGomez asks if we should remove the karaf4 distro-check in carbon?
16:06:55 <jamoluhrsen> #info we need to remove the karaf4 features from distro as well, and move all this work to master.
16:09:19 <jamoluhrsen> #info vrpolak thinks the low risk way is to just keep karaf4 features with the karaf4 sft in distribution and not spend cycles worrying about it.
16:10:57 <jamoluhrsen> #info iotdm project was still not in carbon distribution, so we may need to wait for them
16:11:19 <jamoluhrsen> #info correction, iotdm not in autorelease
16:12:30 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2017-May/010803.html <--- iotdm wondering why they are not in autorelease
16:12:58 <jamoluhrsen> #info vrpolak wants all of these automated (adding/removing projects from distro and autorel)
16:14:51 <jamoluhrsen> #topic release
16:15:39 <jamoluhrsen> #info RC0 probably coming by monday, is best guess.
16:15:55 <jamoluhrsen> #info CSIT analysis will be a big task when RCs are coming
16:18:36 <jamoluhrsen> #info there is a sense that something is broken in openflowplugin that might need to be a blocker bug
16:19:35 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-May/007157.html <--- chatter about trouble in openflowplugin
16:20:11 <jamoluhrsen> #topic packaging
16:21:08 <jamoluhrsen> #info packing changes on master have broken something on boron distros, which is a good example of why we are moving to branches in packaging
16:21:39 <jamoluhrsen> #info carbon deb packaging making progress
16:22:32 <jamoluhrsen> #info opnfv is using our daily carbon packages and no major reports of trouble there
16:22:55 <jamoluhrsen> #topic misc
16:23:50 <jamoluhrsen> #info cancel weekly S3P/cluster call on Friday, and we'll report anything related to that on the CPERF call for S3P.  And we'll use this integration meeting for any cluster updates
16:24:02 <jamoluhrsen> #topic clustering
16:24:32 <jamoluhrsen> #info small improvement last week, but still a large class of suites still failing.
16:26:40 <jamoluhrsen> #info carbon is using a new cluster backend from boron (akka tell vs ask) and bugs are being opened
16:27:27 <jamoluhrsen> #info hard to tell that this new back-end is better... yet. failures are different, but the assumption is that it will end up better.
16:27:55 <jamoluhrsen> #info bottom line is that we'll be releasing clustering again that is not fully stable.
16:28:02 <jamoluhrsen> #info maybe in a carbon SR it will be?
16:30:33 <jamoluhrsen> #info LuisGomez reports OFP cluster CSIT has regressions from boron, so maybe we assume it's from the new cluster back-end.
16:31:05 <jamoluhrsen> #info new back-end is not used by default
16:36:49 <jamoluhrsen> https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-openstack-newton-nodl-v2-gate-stateful-nitrogen/
16:37:08 <jamoluhrsen> #topic misc
16:37:18 <jamoluhrsen> #info gate jobs are now waiting in line too long
16:38:24 <jamoluhrsen> #action jamoluhrsen to send an email to check if -gate- jobs are still having priority?
16:41:00 <jamoluhrsen> #info some backup restore csit work is in progress
16:41:23 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/55165/  <--- backup/restore CSIT patch
16:42:12 <jamoluhrsen> #info gvrangan wonders if it's possible to add a new node to a live cluster
16:43:09 <jamoluhrsen> #info vratko thinks it's possible with some restrictions, but only theoretically. never tried it.
16:43:38 <jamoluhrsen> #info even if it's possible, it's not trivial and not documented.
16:45:25 <jamoluhrsen> #endmeeting