16:02:33 <jamoluhrsen> #startmeeting integration
16:02:33 <odl_meetbot> Meeting started Thu May 25 16:02:33 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:33 <odl_meetbot> The meeting name has been set to 'integration'
16:04:54 <jamoluhrsen> #topic release
16:05:10 <jamoluhrsen> #info good news! Carbon is ready to release
16:05:12 <anipbu> https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-25-14.59.html
16:05:40 <jamoluhrsen> #link https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-25-14.59.html  <-- release tracking sheet
16:06:18 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan
16:06:37 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan nitrogen release plan
16:07:14 <jamoluhrsen> #info boron SR, carbon SR and nitro milestones all hitting in the same 6 weeks this summer
16:08:00 <jamoluhrsen> #info karaf4 will likely be the major deliverable
16:08:58 <jamoluhrsen> #info we are close to removing all projects and getting karaf4 working from the ground up to start the nitrogen release
16:09:12 <jamoluhrsen> #info we have problems getting clustering working with karaf4 at this point.
16:09:36 <jamoluhrsen> #info the cluster issue in karaf4 should not block us from adding other projects
16:12:33 <jamoluhrsen> #info we need a way for each project to tweak if their CSIT is using karaf3 or karaf4
16:14:51 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:15:10 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <-- nitrogen karaf4 migration tracker
16:21:38 <jamoluhrsen> #info CSIT jobs that we track for a release should not be marked IGNORE if the failures are valid and will be worked on going forward.
16:22:12 <jamoluhrsen> #info the problem is that the release team will use IGNORE from previous releases to automatically mark IGNORE in future releases
16:23:46 <jamoluhrsen> #topic builder
16:24:38 <jamoluhrsen> #info centos images are unable to make new builds. they cannot connect to jenkins. abelur working on a fix
16:25:25 <jamoluhrsen> #info carbon is releasing, new set of scripts to try version bumping and hoping it will take only a few hours vs 12+ hours
16:27:23 <jamoluhrsen> #info one idea is we can run the version bumping stuff now, and then only merge the patches when TSC approves the release
16:29:08 <jamoluhrsen> #info abelur is working on a job that will go find old/stale nodes in our cloud which might help our issues where we have to pause jenkins and delete old nodes
16:31:15 <jamoluhrsen> #topic packaging
16:31:31 <jamoluhrsen> #info ansible opendaylight imports pushed to new repo
16:31:59 <jamoluhrsen> #info dfarrell07 recruiting help from others to help with the ansible stuff
16:32:41 <jamoluhrsen> #info carbon .deb should be there after release
16:33:43 <jamoluhrsen> #info questions around how to host packaging things on nexus (e.g., yum repos)
16:34:03 <jamoluhrsen> #action dfarrell07 to forward Akshita's email about nexus hosting to help-desk
16:34:24 <jamoluhrsen> #info odl summer interns starting in the next week or so. two for packaging
16:35:15 <zxiiro> Do we know if the interns will be at the DDF next week?
16:35:40 <jamoluhrsen> dfarrell07, ^^^
16:36:03 <jamoluhrsen> #info packaging knows that opnfv has not reported any major issues with carbon... so w00t! there.
16:37:33 <jamoluhrsen> #topic distribution
16:38:35 <jamoluhrsen> #info carbon changes to get distro to karaf4 was migrated to nitrogen
16:38:45 <jamoluhrsen> #topic misc
16:39:17 <jamoluhrsen> #info coala issues have all been fixed. they need to stick to the same version
16:40:10 <jamoluhrsen> #topic clustering
16:40:47 <odp-gerritbot> A change was merged to integration/distribution: Remove UNIMgr b/c of compilation failures  https://git.opendaylight.org/gerrit/57703
16:44:33 <jamoluhrsen> #info in high perf (lots of chatter) situations, it seems we can get cluster mgmt connections to *think* they are isolated. seems like an akka limitation
16:55:00 <jamoluhrsen> #info we'll skip next week's integration call due to DDF
16:55:26 <jamoluhrsen> #endmeeting