16:02:09 <jamoluhrsen> #startmeeting integration
16:02:09 <odl_meetbot> Meeting started Thu Jun  8 16:02:09 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:09 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:09 <odl_meetbot> The meeting name has been set to 'integration'
16:05:58 <jamoluhrsen> #topic release
16:06:18 <jamoluhrsen> #info boron SR4 looks healthy and we should probably release on time/schedule next week.
16:07:04 <jamoluhrsen> #info we asked projects to blacklist their CSIT results which will help the process more efficient. this is voluntary
16:07:19 <jamoluhrsen> #info carbon is still waiting on 3 projects to merge their release notes
16:07:40 <jamoluhrsen> #info nitrogen M0 status due now
16:08:24 <jamoluhrsen> #info nitrogen project proposal approval is coming. P4Plugin and Bier_APP so far
16:08:45 <jamoluhrsen> #info it's going to be hard to get these projects released in nitrogen with the struggle to get to karaf4
16:09:12 <jamoluhrsen> #info zxiiro suggests we just deny nitrogen and ask them to be in oxygen only.
16:09:21 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf
16:09:46 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:10:12 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf <-- wiki tracker for karaf4 progess
16:10:27 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <-- google sheet for tracking karaf4
16:11:27 <jamoluhrsen> #info initial goal is to push for this k4 migration by end of june
16:12:55 <jamoluhrsen> #info bug 8627 needs to be worked on by integration team.
16:13:14 <jamoluhrsen> #action vrpolak to update bug 8627 to give details on *why* we need to stop using featuresBoot
16:14:34 <odp-gerritbot> Len proposed a change to integration/test: Add second connection from switch controller  https://git.opendaylight.org/gerrit/58376
16:15:17 <jamoluhrsen> #info bug 8625 to remove all offset 0 projects from int/dist needs to be removed
16:15:29 <jamoluhrsen> #action vrpolak to update bug 8625 with status
16:16:15 <jamoluhrsen> #topic packaging
16:16:56 <jamoluhrsen> #info nitrogen rpms are being built now, which doesn't mean much because it wont work, but the logic is there which is great
16:17:14 <jamoluhrsen> #info still need carbon containers and vagrant base boxes
16:17:39 <jamoluhrsen> #info planning to combine rpm and deb logic to help keep the deb builder alive
16:18:18 <jamoluhrsen> #info hoping to move the vagrant-opendaylight from dfarrell07's github to the int/pak repo tutorials dir
16:22:04 <jamoluhrsen> #info puppet module fixes recently
16:23:01 <jamoluhrsen> #topic builder
16:23:18 <gvrangan> dfarrell07: Thanks for sharing the links to the rpm, very helpfule we tested carbon from rpm
16:23:41 <jamoluhrsen> #info shiplogs macro is now using the lfinfra tools from the global-jjb repo
16:23:43 <dfarrell07> gvrangan: cool, glad to help :)
16:24:24 <dfarrell07> #link https://review.openstack.org/#/c/468340/ OpenStack blueprint for ODL integration into ansible-opendaylight
16:25:04 <jamoluhrsen> #info still the simple way is just to create an archives/ folder in the $workspace and they'll get logged
16:25:45 <jamoluhrsen> #info all centos images are now updated... finally... seems there was some issue in selinux that was not compatible with the rackspace base image which was updated in recent months
16:26:41 <jamoluhrsen> #info venv workaround has been getting put in place, but feels kind of hacky
16:27:06 <jamoluhrsen> #action jamoluhrsen to send email about csit job he found with venv job that failed because the name was too long
16:27:35 <jamoluhrsen> #info non-kernel projects are removed from autorelease
16:28:40 <jamoluhrsen> #info int/dist is also not part of autorelease. autorelease is currently passing, so we can now put int/dist back maybe
16:33:18 <anipbu> https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001036.html
16:34:53 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001036.html  <--- odl parent plans for nitrogen
16:38:30 <jamoluhrsen> #info we need to figure out if/how we want to keep doing a karaf3 distribution for nitrogen so projects can keep running CSIT...
16:39:02 <jamoluhrsen> #action jamoluhrsen to send email asking what we really want to do about this.
16:39:59 <jamoluhrsen> #info zxiiro is heads down working on the generic release job so odlparent can release outside of autorelease
16:40:48 <jamoluhrsen> #info latest shellcheck version is now there in latest minion images so hopefully local tox results will match releng tox results
16:41:40 <jamoluhrsen> #info lfinfra projects have their own CI jobs. these projects are for building common tools that are used across lf projects (opnfv, odl, etc)
16:42:28 <jamoluhrsen> #info still no docs around these projects yet (still bootstrapping)
16:44:23 <odp-gerritbot> Bharathkumarav proposed a change to integration/test: bgp_vpn_cli  https://git.opendaylight.org/gerrit/58537
16:46:33 <jamoluhrsen> #topic distribution
16:47:59 <jamoluhrsen> #action jamoluhrsen to send email about bug 8627 because using featuresBoot with automated tools is kind of the easy/normal way to go about it.
16:48:50 <jamoluhrsen> #info nothing merged yet, but patches are in place to move forward with k4
16:49:14 <jamoluhrsen> #topic misc
16:52:01 <jamoluhrsen> #info we are still running boron jobs nightly, but since carbon is out so maybe next week we can move boron to run weekly like we were doing with Be (will bring it up next week)
16:54:23 <jamoluhrsen> #info gvrangan is working the ocata openstack job, and found some problems locally.
16:55:40 <jamoluhrsen> #endmeeting