16:00:02 <jamoluhrsen> #startmeeting integration
16:00:02 <odl_meetbot> Meeting started Thu Jun 15 16:00:02 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:02 <odl_meetbot> The meeting name has been set to 'integration'
16:04:27 <jamoluhrsen> #topic release
16:04:51 <jamoluhrsen> #info boron sr4 will be delayed by a day or two because of a blocker in netvirt
16:04:58 <jamoluhrsen> #info netvirt fix coming tomorrow
16:05:47 <jamoluhrsen> #info carbon SR1 in 3 weeks
16:06:16 <jamoluhrsen> #info 7/2 is the cut-off for carbon sr1
16:06:46 <jamoluhrsen> #info nitrogen will have a painful next two weeks.
16:07:12 <jamoluhrsen> #info all projects are moving to odlparent 1.9.0
16:07:54 <jamoluhrsen> #info infrautils is back now
16:08:17 <jamoluhrsen> #info next week we want to move projects to odlparent 2.0.0
16:09:02 <jamoluhrsen> #info in summary we have two weeks of trouble in nitrogen while we have two weeks to get carbon sr1 done
16:09:10 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Reduce the numer of ssh - WIP  https://git.opendaylight.org/gerrit/58993
16:10:46 <zxiiro> major canadian holiday too
16:10:53 <zxiiro> Canada 150! woo
16:11:05 <jamoluhrsen> Go Canada!
16:11:32 <jamoluhrsen> #info vrpolak asks if we can get SFT back in autorel?
16:12:29 <jamoluhrsen> #info should we remove karaf4 from Carbon so we can run SFT in carbon? is it worth the effort to get projects to do this?
16:12:48 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Reduce the numer of ssh - WIP  https://git.opendaylight.org/gerrit/58993
16:16:41 <jamoluhrsen> #action vrpolak to put a patch to enable SFT in autorel for carbon. we can discuss if we want to merge it on the patch
16:17:24 <jamoluhrsen> #action zxiiro to check in odlparent on how to flip the switch to not run SFT on k4 in autorel carbon
16:18:47 <jamoluhrsen> #info the plan is to just remove the k4 SFT in carbon, then try this in sandbox and if all is well, we will restore it.
16:19:06 <jamoluhrsen> #topic distribution
16:20:02 <jamoluhrsen> #info all karaf3 is now removed from integration/distribution for nitrogen
16:20:39 <jamoluhrsen> #info most nitro csit should not be failing because projects haven't been added to int/dist for k4 yet
16:23:11 <jamoluhrsen> #info if projects want to run CSIT on their own local k4 distribution they can hard code the bundle url in to their jjb
16:24:00 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/58987/ <--- patch to hard code bundle-url to test local k4 distribution
16:26:41 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=8571  <-- Bug causing no configure_cluster.sh in Karaf 4 builds.
16:26:46 <jamoluhrsen> #info odlparent bug where k4 distribution doesn't have our extra scripts (e.g. configure cluster, set persistence)
16:29:22 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:37:00 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Reduce the numer of ssh - WIP  https://git.opendaylight.org/gerrit/58993
16:37:02 <jamoluhrsen> #info it seems that featuresBoot has problems and things work better when installing features from the karaf shell
16:37:41 <jamoluhrsen> #info the integration group wants to file blocking bugs for these situations where featuresBoot does not work and continue with the assumption that both should work.
16:38:08 <jamoluhrsen> #action jamoluhrsen to file blocking bug on netvirt featuresBOot issue
16:39:33 <jamoluhrsen> #topic builder
16:40:19 <jamoluhrsen> #info we now have a maven release job to help release odlparent
16:41:00 <jamoluhrsen> #info ODL sites had cert issues recently, which caused problems that is now temporarily worked around. Andy will give a permanent solution soon
16:41:58 <jamoluhrsen> #info RackSpace had some outage over the weekend, but seems to have been resolved. there was some broken battery and broke the jenkins production server
16:43:11 <jamoluhrsen> #info vrpolak saw that some longevity jobs failed after 24h (prematurely) so wondering if this could have been the new script to kill stale nodes
16:43:47 <anipbu> zxiiro: are we planning on adding integration/distribution back to autorelease (now that it has removed nonoffset0 projects)
16:44:42 <jamoluhrsen> #info we need to reduce longevity job times to something like 23 hours. the zombie killer script is only granular by days
16:44:51 <zxiiro> anipbu: yes, was waiting for the go ahead from integration
16:45:00 <jamoluhrsen> #action jamoluhrsen to search for longevity timers in int/test to warn projects
16:45:41 <anipbu> LuisGomez: vrpolak: I believe we have go ahead for adding integration/distribution back to autorelease (now that it has removed nonoffset0 projects)?  Please let us know.
16:45:49 <zxiiro> #link https://jenkins.opendaylight.org/releng/job/controller-csit-3node-periodic-benchmark-only-boron/323/ Controller job hung
16:46:00 <jamoluhrsen> #topic packaging
16:46:28 <jamoluhrsen> #info nexus repo getting setup for int/pak so we can push artifacts to nexus
16:47:35 <vrpolak> +1 >adding integration/distribution back to autorelease
16:48:13 <jamoluhrsen> #info major docs update in int/pak that we need to review and merge: https://git.opendaylight.org/gerrit/58670
16:48:20 <zxiiro> it's in my to review queue
16:49:51 <jamoluhrsen> #info dfarrell07 giving multiple talks at OPFNV Summit on behalf of ODL. -- kudos!
16:51:40 <jamoluhrsen> #topic misc
16:52:17 <jamoluhrsen> #info some Ericcson folks emailed about S3P. jamoluhrsen will loop in mattw4
16:52:50 <odp-gerritbot> Faseela K proposed a change to integration/test: Fix issues with genius script plans  https://git.opendaylight.org/gerrit/59039
16:53:16 <jamoluhrsen> #info LuisGomez thinks we may have some good intern resources this summer to help us with some of our "good ideas". e.g. vrpolak's banhammer script
16:53:59 <jamoluhrsen> #info LuisGomez wants to give a dashboard demo next week
16:57:00 <jamoluhrsen> #info mattw4 working on a scale framework with devstack and docker containers. things are stabilizing now and we can consider using these in upstream jobs
16:58:14 <jamoluhrsen> #info each devstack container is consuming ~3G of memory
16:59:49 <jamoluhrsen> #info mattw4 asking for input/test cases if anyone has it. dfarrell07 points out that afredette has a scale/perf related test doc.
17:00:19 <jamoluhrsen> #endmeeting