16:01:16 <jamoluhrsen> #startmeeting integration
16:01:16 <odl_meetbot> Meeting started Thu Jul  6 16:01:16 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <odl_meetbot> The meeting name has been set to 'integration'
16:04:24 <jamoluhrsen> zxiiro, LuisGomez, anipbu, I can't go off mute...
16:04:30 <jamoluhrsen> let me reconnect
16:06:14 <jamoluhrsen> #topic release
16:06:38 <jamoluhrsen> #info ofp has a new critical bug https://bugs.opendaylight.org/show_bug.cgi?id=8805 not sure if it's a regression
16:07:49 <jamoluhrsen> #action LuisGomez  to check bug 8805 is there in the Carbon release
16:08:04 <jamoluhrsen> #info anipbu notes that Carbon SR1 is delayed at the moment
16:09:09 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/SR1/Status <--- CSIT results for latest SR1 candidate
16:09:56 <jamoluhrsen> #undo
16:09:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2e3b9d0>
16:10:06 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=363467887 <--- CSIT results for latest SR1
16:11:39 <jamoluhrsen> #info for Nitro, odl parent 2.0.2 is releasing soon.
16:12:10 <jamoluhrsen> #action jamoluhrsen to figure out how to get some CSIT run against this new odlparent 2.0.2
16:12:32 <jamoluhrsen> #info not *all* projects need to migrate to 2.0.2, so we could end up with a mix of projects on 2.0.0 and 2.0.2 in nitro
16:12:34 <skitt> #link test patch for netvirt: https://git.opendaylight.org/gerrit/60007
16:12:44 <jamoluhrsen> #info all kernel projects have completed k4 migration
16:13:08 <jamoluhrsen> #info we are 1 week behind schedule in the k4 migration, which is better than anipbu had hoped for :)
16:13:25 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933
16:13:37 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956
16:13:39 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <--- k4 issue tracker
16:14:10 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 <-- k4 project status
16:15:33 <jamoluhrsen> #info nitro k4 blocker bug filed by LuisGomez (8803)
16:17:25 <jamoluhrsen> #info featuresBoot seems to be working ok now
16:17:59 <jamoluhrsen> #action jamoluhrsen to remove 8627 from blocker list
16:19:08 <jamoluhrsen> #topic builder
16:20:39 <jamoluhrsen> #info when/how should we be updating our releng/builder submodules. for example: https://git.opendaylight.org/gerrit/59952
16:23:41 <jamoluhrsen> #info work done last week to make our maven site deploy much faster (~5 min faster)
16:23:58 <jamoluhrsen> #info autorelease has a verify job now, to help gate autorel patches
16:26:21 <jamoluhrsen> #action zxiiro or jamoluhrsen to add dist-test script parser howto to some wiki
16:26:31 <jamoluhrsen> #topic distribution
16:27:10 <jamoluhrsen> #info nitro has aprox 1/2 projects already merged to get in to int/dist
16:28:04 <jamoluhrsen> #info projects with legit -1 on int/dist patches are reacting slowly. We may need to find a way to light a fire
16:29:20 <jamoluhrsen> #info anipbu says that projects were supposed to be in int/dist last week, so we are way behind.
16:29:42 <jamoluhrsen> #info we can make a cutoff like M5 that projects would not be allowed in nitro if they are not in int/dist
16:33:34 <zxiiro> anipbu: sorry I think the only way I can do RM is if I stop doing RE
16:40:24 <jamoluhrsen> #topic clustering
16:40:45 <jamoluhrsen> #info in general cluster csit is better recently.
16:41:03 <jamoluhrsen> #info possibly hitting 3rd party bugs (e.g. akka)
16:41:35 <jamoluhrsen> #info still some sporadic/infrequent bugs showing up (timing issues) which are hard to fix
16:42:19 <jamoluhrsen> #info we have several 3node longevity jobs (maybe 7 of them) and aprox half pass and half fail
16:43:30 <jamoluhrsen> #info besides akka and infrequent bugs, we have other open known bugs being worked
16:44:14 <jamoluhrsen> #topic S3P
16:45:00 <jamoluhrsen> #info int/pak/openstack repo will get the new openstack containers
16:45:16 <vrpolak> #link https://git.opendaylight.org/gerrit/#/c/56454/109/docs/cluster/carbon_sr1.rst  <-- current controller cluster test report draft
16:46:30 <jamoluhrsen> #info the plan will be to merge the container first (as it can be used immediately) then other patches for all the side work (ansible, etc)
16:46:46 <jamoluhrsen> #info there is a POC to make the compute container work against an external ODL
16:47:25 <jamoluhrsen> #info latest test was 90 compute containers with 2 instances per compute, but at this point the openstack container was consuming way too many resources
16:48:17 <jamoluhrsen> #info in that same scale test, the java process (so, ODL) was the top consumer. seems like an issue to figure out.
16:50:04 <jamoluhrsen> mattw4, LuisGomez switch scale job in ofp.  https://logs.opendaylight.org/releng/jenkins092/openflowplugin-csit-1node-periodic-sw-scalability-daily-only-carbon/335/heapmemory_1.png
16:51:14 <jamoluhrsen> #info LuisGomez mentions that yourkit could be used to profile ODL in these scale tests. CaseyODL is working to get our licenses back for yourkit
16:53:53 <jamoluhrsen> #topic misc
16:54:11 <zxiiro> mattw4: https://hub.docker.com/u/opendaylight/dashboard/
16:54:18 <zxiiro> mattw4: if you give me your id i can add you to the team
16:54:43 <mattw4> #info https://github.com/matt-welch/docker-devstack
16:55:13 <mattw4> #link https://github.com/matt-welch/docker-devstack
16:55:30 <mattw4> #link https://github.com/intel-odl/socets
16:55:52 <mattw4> #info ^^ ansible deployment tools for S3P docker containers
16:57:30 <jamoluhrsen> #endmeeting