16:01:05 <jamoluhrsen> #startmeeting integration
16:01:05 <odl_meetbot> Meeting started Thu Aug 10 16:01:05 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:05 <odl_meetbot> The meeting name has been set to 'integration'
16:03:38 <jamoluhrsen> #topic packaging
16:04:19 <jamoluhrsen> #info tons of maintenance stuff working down the trello cards in the packaging world (packer job cleanup, puppet ansible... )
16:04:43 <jamoluhrsen> #info packaging now supports fedora 26
16:05:58 <jamoluhrsen> #info big queue of patches for rpm/deb logic nearing completion... maybe 2/3rds done
16:06:51 <jamoluhrsen> #topic builder
16:07:11 <jamoluhrsen> #info abelur is renaming scripts, removing the "include-raw" prefix
16:07:41 <jamoluhrsen> #info opflex has jobs to archive to log server, but now we are reworkings jobs to push to nexus repository
16:08:09 <jamoluhrsen> #info license header scanner tool from lftools.
16:09:14 <jamoluhrsen> #info the idea is that eventually we can run this license header tool in our tox/verify jobs (so projects don't override license header checks)
16:11:08 <jamoluhrsen> #info obviously int/test and/or int/pak will fail these license header checks. this will force us to do this better
16:11:47 <jamoluhrsen> #topic distribution
16:12:28 <jamoluhrsen> #info odlparent has multiple versions releases this week. so, int/dist is on 2.0.4 now
16:13:12 <jamoluhrsen> #info but, 2.0.5 is on the way and will allow jenkins job to specify an intended heap space
16:15:03 <jamoluhrsen> #info the heap is so large though, so we can't upload to log server.
16:15:57 <jamoluhrsen> #topic release
16:16:16 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule   <--- Carbon SR2 on 8/17/2017
16:16:28 <anipbu> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend   <--- We have not had a successful build of Carbon since July 27
16:16:34 <jamoluhrsen> #info carbon planned release SR2 next week, so cutoff this Sunday
16:16:46 <jamoluhrsen> #info last autorelease worked 7/27
16:17:08 <jamoluhrsen> #info last issues were related with unimgr and nic
16:17:51 <jamoluhrsen> #info if autorelease is not building, we cant get any RC candidates
16:18:22 <jamoluhrsen> #action jamoluhrsen to look at carbon dist-test job
16:19:30 <jamoluhrsen> #info for nitrogen, offset 1 M5 was this past monday, but not all projects have met the milestone
16:19:49 <vrpolak> #link https://git.opendaylight.org/gerrit/61328  <-- allows .hprof file generation at specified path.
16:20:06 <jamoluhrsen> #action klou__ to keep the nitro status spreadsheet updated
16:20:24 <jamoluhrsen> #info offset 2 is in 4 days (monday, 8/14) when RC0 will come
16:20:50 <vrpolak> #link https://git.opendaylight.org/gerrit/61506  <-- fix allowing Jenkins to configure how much heap space is to be used for SingleFeatureTest
16:20:58 <jamoluhrsen> #info nitro autorelease is still failing (latest failure is on Alto with a patch pending merge)
16:21:11 <jamoluhrsen> #info we probably need all patches to merge their odlparent 2.0.4
16:22:29 <jamoluhrsen> #info one idea from dfarrell07 is we can modify the autorelease job to use an unmerged patch in the build so we don't have to wait on projects to merge a patch that we *know* needs to be merged to fix things
16:25:30 <jamoluhrsen> #info the last successful nitro autorel was 7/24 and that's when projects started adding themselves back in to distribution.
16:27:13 <anipbu> https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956
16:27:20 <jamoluhrsen> #action vrpolak to look at int/dist patches for projects trying to get back in to distribution
16:28:17 <jamoluhrsen> #info anipbu reports that only 29 projects are in int/dist and 14 waiting to be brought pack and we don't know how many have given patches yet
16:28:24 <anipbu> https://git.opendaylight.org/gerrit/#/q/project:integration/distribution+status:open
16:29:08 <jamoluhrsen> #info so we have 1/3rd of our projects NOT back in distribution and the goal was to have this done by Monday (in four days)
16:31:34 <jamoluhrsen> #info seems we need more committers on int/dist. Luis is on PTO now, vrpolak is also doing 1-day PTO tomorrow and edwarnicke is not usually around for this. so we are stuck with zero active committers at a critical time
16:33:36 <jamoluhrsen> #info some good news....  all projects (except tsdr) have been successfully migrated to karaf4.
16:34:14 <odp-gerritbot> A change was merged to integration/distribution: Add ALTO to Karaf 4 distribution  https://git.opendaylight.org/gerrit/61089
16:34:16 <jamoluhrsen> #info tsdr is a leaf project and if they are not migrated by monday, they will be dropped from nitrogen.
16:34:43 <odp-gerritbot> A change was merged to integration/distribution: Add of-config to distribution  https://git.opendaylight.org/gerrit/61093
16:35:11 <odp-gerritbot> A change was merged to integration/distribution: Revert "Remove unimgr from nitrogen distribution"  https://git.opendaylight.org/gerrit/61292
16:35:14 <jamoluhrsen> #topic S3P
16:35:57 <mattw4> #link 		○ https://git.opendaylight.org/gerrit/gitweb?p=integration/packaging.git;a=tree;f=ansible;h=932ae9e180475eb7b0add1c084e34df572db2e1c;hb=HEAD
16:35:58 <odp-gerritbot> A change was merged to integration/distribution: Add usc to distribution  https://git.opendaylight.org/gerrit/61390
16:36:22 <odp-gerritbot> A change was merged to integration/distribution: Add nemo karaf4 to distribution  https://git.opendaylight.org/gerrit/61391
16:36:35 <jamoluhrsen> #info mattw4 worried about a submodule in the int/pak repo pointing to dfarrell07's github.
16:36:56 <dfarrell07> mattw4: https://git.opendaylight.org/gerrit/gitweb?p=integration/packaging/ansible-opendaylight.git;a=tree
16:37:48 <jamoluhrsen> #info testplan for S3P going to google docs soon, we hope
16:38:34 <jamoluhrsen> #info openstack python sdk test expert needed.
16:39:37 <mattw4> #link https://github.com/matt-welch/docker-devstack/tree/master/service/build/openstack
16:40:47 <jamoluhrsen> #info testing is ongoing, no new/better numbers from last week. probably hitting scale limitations in openstack
16:41:00 <vrpolak> #info Nitrogen distribution update: Most open patches are merged now, except Bier and Groupbasedpolicy which seem to need more heap space for odl-integration-all SFT. I expect rapid merges may cause distribution-merge and {project}-distribution-check to start failing on heap space. Odlparent 2.0.5 would fix that.
16:42:34 <jamoluhrsen> #info mattw4 saved off an 11G heap dump from ODL.  how do we deal with that?
16:42:46 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=8941  <-- Memory leak Bug with fix ready (both for Carbon and Nitrogen).
16:46:02 <jamoluhrsen> #action jamoluhrsen to document how to find the distribution created by the distribution-check job
16:47:11 <jamoluhrsen> #action jamoluhrsen to email mattw4 the csit tutorial
16:47:48 <jamoluhrsen> #topic clustering
16:48:30 <jamoluhrsen> #info test results are worse this week... possibly a regression or occurrence of infrequent bug in longevity test
16:48:56 <jamoluhrsen> #info documentation not done yet, but coming.
16:52:04 <jamoluhrsen> #info carbon SR2 might have two bugs able to be fixed, but they are not blockers so unless they come soon they wont make it
16:52:19 <jamoluhrsen> #topic misc
16:53:35 <jamoluhrsen> #info anipbu corrects that nitrogen currently has 3 non-leaf projects (GBP, SNMP, <someone else>) that haven't been put back in to int/dist
16:53:48 <jamoluhrsen> #info two leaf projects not in int/dist.... so FIVE total, not 14
16:54:49 <jamoluhrsen> #info but since 3 are non-leaf we MUST get them in. GBP should be find. FAAS is blocked by resources. SNMP has always had troubles but they have new committers we trust can get this working
16:55:07 <jamoluhrsen> #info anipbu suggests that we find whoever is dependent on FAAS to remove their dependency
16:55:33 <odp-gerritbot> Bharathkumarav proposed a change to integration/test: Added one TC for ECMP  https://git.opendaylight.org/gerrit/59382
16:56:25 <jamoluhrsen> #info gvrangan almost has the devstack pike job almost working. auth_strategy needed a change and we had to run the "discover" command earlier in the job.
16:56:49 <anipbu> zxiiro: vrpolak: does yangtools needs to be added to distribution?
16:58:26 <jamoluhrsen> #info anipbu asks if yangtools should be in int/dist?  vrpolak notes they don't have user facing features, but they do have top-level features. they are just used as a lib, so no need to make their features visible in distribution
17:01:33 <jamoluhrsen> #endmeeting