16:05:52 <jamoluhrsen> #startmeeting integration
16:05:52 <odl_meetbot> Meeting started Thu Aug 24 16:05:52 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:05:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:52 <odl_meetbot> The meeting name has been set to 'integration'
16:06:14 <jamoluhrsen> #topic release
16:06:31 <jamoluhrsen> #info carbon sr2 still has blocker bugs.
16:08:39 <jamoluhrsen> #info the cluster issue in carbon sr2 that sam and robert are working on is not in the blocker list
16:11:38 <jamoluhrsen> #info only two blockers left for SR2 and maybe another week delay for that.
16:11:51 <jamoluhrsen> https://bugs.opendaylight.org/show_bug.cgi?id=9038
16:13:29 <jamoluhrsen> #action LuisGomez to check on bug 9038 as it's an SR2 blocker
16:14:19 <jamoluhrsen> #info dfarrell07 suggests we could make vorburger's OOM bug (is there one) a blocker on SR2?
16:15:29 <jamoluhrsen> #action jamoluhrsen to follow up with sam on why the cluster issue is not a blocker bug?
16:16:30 <jamoluhrsen> #info nitrogen finally has a good autorelease two days ago and it's RC1 (skipping RC0)
16:17:06 <klou> #link https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=129813418 - nitrogen RC1 CSIT status
16:18:01 <jamoluhrsen> #info LuisGomez has merged a patch that will remove several projects from the distribution-test
16:18:21 <jamoluhrsen> #info need projects to update the tracking spreadsheet
16:18:35 <jamoluhrsen> #info 5 blocker bugs, 2 with progress
16:19:01 <jamoluhrsen> #info vorburger's OOM bug? can it be a blocker in nitro too? maybe it is already.
16:19:22 <jamoluhrsen> #topic distribution
16:19:50 <dfarrell07> vorburger: can you give us the bug for the OOM issue you're working on fixing?
16:20:00 <jamoluhrsen> #info M5 report is in progress, wiki page updates
16:20:10 <dfarrell07> vorburger: If I'm right and it happens in Nitrogen we should mark it as a blocker
16:20:15 <jamoluhrsen> #info we need this patch merged https://git.opendaylight.org/gerrit/#/c/62207/
16:20:39 <zxiiro> merged
16:21:02 <jamoluhrsen> #info new bugs coming from distro side for nitrogen. they will be blocker bugs
16:21:30 <dfarrell07> vorburger: I think it's this one? https://bugs.opendaylight.org/show_bug.cgi?id=9034
16:21:32 <jamoluhrsen> #info need bug 9028's fix merged to nitrogen
16:22:11 <dfarrell07> #link https://bugs.opendaylight.org/show_bug.cgi?id=9034 OOM in Carbon (at least) that, if not a blocker, is a big deal
16:22:22 <jamoluhrsen> #info bug 9044 is a blocker
16:22:32 <dfarrell07> #link https://bugs.opendaylight.org/show_bug.cgi?id=9034 If this applies to Nitrogen it should be a blocker
16:24:15 <jamoluhrsen> #action jamoluhrsen, dfarrell07, vorburger to figure out if 9034 is a nitro blocker
16:24:41 <jamoluhrsen> #info vrpolak enjoying PTO all next week
16:25:00 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-nitrogen/129/ nitrogen csit 10 hrs run time
16:26:13 <jamoluhrsen> #info zxiiro wondering if we can just run -all- or -only- and not both?
16:29:12 <jamoluhrsen> #info jamoluhrsen suggests that we all sit around a table at DDF to find ways to clean up how much/often we do distribution-test
16:32:21 <jamoluhrsen> #info actually it might pretty easy "right now" to start getting rid of -only- jobs that also have -all-
16:32:39 <jamoluhrsen> #action jamoluhrsen to put a patch for this now, and we can merge if there is agreement.
16:33:39 <vrpolak> +1 to merge first, think later. :)
16:34:05 <jamoluhrsen> #action LuisGomez to add this topic to DDF on the wiki
16:34:33 <vorburger> dfarrell07: jamoluhrsen: sorry I'm only seeing you guys raising mre here right now -- reading up...
16:36:25 <vorburger> dfarrell07: I've no idea about the OOM situation in nitrogen actually, the only thing I do know is the Carbon, from our internal tests. We could "assume" the same problems still be there in Nitrogen as well though, but that's an assumption
16:36:38 <dfarrell07> #startvote Are you going to DDF? -1,0,+1
16:36:38 <odl_meetbot> Only the meeting chair may start a vote.
16:36:42 <dfarrell07> jamoluhrsen: chair me
16:36:50 <LuisGomez> #vote +1
16:36:53 <zxiiro> #vote +1
16:36:54 <vrpolak> #vote +1
16:36:54 <jamoluhrsen> #startvote Are you going to DDF? -1,0,+1
16:36:54 <odl_meetbot> Begin voting on: Are you going to DDF? Valid vote options are -1, 0, +1.
16:36:54 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
16:36:58 <mattw4> #vote +1
16:37:00 <dfarrell07> #vote +1
16:37:01 <jamoluhrsen> #vote +1
16:37:05 <jamoluhrsen> vote again please
16:37:05 <zxiiro> #vote +1
16:37:08 <LuisGomez> #vote +1
16:37:09 <vorburger> jamoluhrsen: dfarrell07: The two related issues are bug 9034 and bug 9038
16:37:18 <vrpolak> (rounded up currently +0.91)
16:37:22 <vorburger> #vote +1
16:37:23 <klou> #vote 0
16:37:25 <dfarrell07> vorburger: and they happen in nitrogen?
16:37:38 <jamoluhrsen> #endvote
16:37:38 <odl_meetbot> Voted on "Are you going to DDF?" Results are
16:37:38 <odl_meetbot> 0 (1): klou
16:37:38 <odl_meetbot> +1 (6): vorburger, LuisGomez, dfarrell07, jamoluhrsen, zxiiro, mattw4
16:37:40 <vorburger> dfarrell07: I've no idea about the OOM situation in nitrogen actually, the only thing I do know is the Carbon, from our internal tests. We could "assume" the same problems still be there in Nitrogen as well though, but that's an assumption
16:38:04 <dfarrell07> vorburger: okay, cool
16:38:04 <jamoluhrsen> vorburger, we just need the bugs to be listed as blocker (if they are) for the relevant releases (nitro, carbon SR2)
16:38:16 <gvrangan> I cannot join this time :-(
16:38:40 <jamoluhrsen> #topic packaging
16:39:10 <vorburger> jamoluhrsen: dfarrell07: full disclosure, I'm actually NOT "working on" Bug 9038, but hoping someone from openflowplugin will come up with something. I am in parallel investigating if there are others.
16:39:13 <jamoluhrsen> #info actual packaging stuff happening in the packaging project (refactor, cleanup, fixes, improvements)
16:39:50 <jamoluhrsen> #info still need to get k4 vs k3 packaging to work.
16:40:12 <jamoluhrsen> #info opnfv seems to want to skip from carbon to oxygen and not use nitrogen
16:40:23 <jamoluhrsen> #info more clustering puppet tricks coming in.
16:42:46 <jamoluhrsen> #topic builder
16:42:56 <zxiiro> #link https://lists.opendaylight.org/pipermail/dev/2017-August/004038.html global-jjb v0.7.0 available
16:42:56 <zxiiro> #info Maven Verify job now available
16:43:39 <dfarrell07> #info dfarrell07 would love reviews for https://git.opendaylight.org/gerrit/#/c/61879/ and https://git.opendaylight.org/gerrit/#/c/62158/ if his wonderful packaging committers have some cycles ;)
16:43:51 <jamoluhrsen> #topic clustering
16:45:30 <jamoluhrsen> #info carbon has netconf clustering job failures every ~6 karaf restarts, but this never happens in the sandbox.
16:47:21 <jamoluhrsen> #info bug 8858 now has a fix for carbon, but sandbox job failed and maybe some memory issues, so still investigating
16:48:35 <jamoluhrsen> #topic S3P
16:48:42 <mattw4> #link  https://git.opendaylight.org/gerrit/#/c/62012/ Ansible role to setup hosts for scale testing
16:49:02 <jamoluhrsen> #info ansible role to setup hosts for scale setups has a patch. needs reviewers
16:49:23 <jamoluhrsen> #info next layer is getting this running on CSIT systems.
16:50:28 <jamoluhrsen> #info mattw4 is now officially our ansible expert
16:51:22 <jamoluhrsen> #topic misc
16:51:56 <gvrangan> Link for review: https://wiki.opendaylight.org/view/Dynamically_Adding_Nodes_to_an_Existing_Cluster
16:52:05 <jamoluhrsen> #info gvrangan updated pike jjb patch to help get us closer to making that work.
16:52:27 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Dynamically_Adding_Nodes_to_an_Existing_Cluster  <-- adding nodes to an existing cluster
16:53:05 <jamoluhrsen> #info vrpolak knows that certain aspects of clustering will not work on new nodes that are added to an existing cluster
16:53:42 <jamoluhrsen> #info we need cluster experts to review gvrangan's wiki
16:55:20 <jamoluhrsen> #endmeeting