16:05:10 <jamoluhrsen> #startmeeting integration
16:05:10 <odl_meetbot> Meeting started Thu Aug 31 16:05:10 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:05:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:10 <odl_meetbot> The meeting name has been set to 'integration'
16:05:40 <jamoluhrsen> #topic release
16:06:35 <jamoluhrsen> #info carbon SR2 still has 6 blocker bugs. more delays there.
16:06:57 <jamoluhrsen> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511
16:07:37 <jamoluhrsen> #action jamoluhrsen to check if 9063 and 9064 are really blockers
16:08:26 <jamoluhrsen> #info nitro has rc2 build and we need projects to update csit results
16:08:45 <jamoluhrsen> #info nitro also has 6 blocker bugs
16:09:24 <jamoluhrsen> #info nitro will be delayed some number of weeks as well.
16:10:48 <dfarrell07> https://git.opendaylight.org/gerrit/#/c/62489/
16:10:56 <jamoluhrsen> action zxiiro to merge patch to fix 9060, patch 62489
16:11:11 <jamoluhrsen> #topic packaging
16:11:48 <jamoluhrsen> #info still working (based on pressure from opnfv) on all the different rpm logic
16:12:48 <jamoluhrsen> #info releng builder now able to use tarballs and zips
16:13:15 <jamoluhrsen> #info packaging UT is increasing as well
16:13:46 <jamoluhrsen> #info nitro rpms are pushing to right repo now.
16:14:35 <jamoluhrsen> #info opnfv folks helping with our ansible stuff (e.g. sfc changes)
16:15:30 <dfarrell07> https://git.opendaylight.org/gerrit/#/c/61879/
16:17:04 <jamoluhrsen> #info dfarrell07 asks when we will enable oxy autorelease, but we can't handle all the jobs so we have to wait until we release carbon and/or nitro and/or the -only- jobs are removed
16:17:46 <jamoluhrsen> #action zxiiro to merge the patch to remove -only- jobs on Tuesday 9/5
16:17:56 <jamoluhrsen> #topic builder
16:18:07 <zxiiro> #link https://git.opendaylight.org/gerrit/61991 Group IDs added to Heat Orchestration Templates
16:18:41 <jamoluhrsen> #info groupid is now there in our VM names, which ensures all CSIT VMs have unique hostnames
16:18:59 <zxiiro> #link https://jira.linuxfoundation.org/browse/RELENG-243 sonar job migrated to global jjb
16:19:49 <jamoluhrsen> #info mvn sonar job now migrated to global-jjb, which means all the standard mvn jobs are now migrated. But, only two projects are using global-jjb currently. in coming months we'll migrate more projects over
16:20:58 <zxiiro> #link https://gerrit.linuxfoundation.org/infra/6245 WIP: Job to lock/unlock branches for a project
16:22:35 <jamoluhrsen> #info global-jjb has a job that will lock or unlock branches. type lockbranch or unlockbranch in a gerrit patch and it will create a new patch to lock/unlock accordingly. the patch still needs to be merged
16:22:47 <zxiiro> #link https://git.opendaylight.org/gerrit/62454 Generate csit job list automatically for distribution-test job
16:23:12 <zxiiro> #link https://jenkins.opendaylight.org/releng/job/integration-distribution-test-carbon/244/
16:25:03 <zxiiro> #link https://github.com/zxiiro/license-header-checker golang based license checker
16:26:28 <jamoluhrsen> #topic distribution
16:26:42 <jamoluhrsen> #info LuisGomez and Vratko are not here today, so no info.
16:27:22 <jamoluhrsen> #topic S3P
16:28:21 <jamoluhrsen> #info no updates really, just more ansible work.
16:28:25 <jamoluhrsen> #topic misc
16:28:57 <dfarrell07> https://jenkins.opendaylight.org/releng/job/ansible-verify-tox-master/24/console\
16:29:10 <dfarrell07> SpaceConsistencyBear
16:29:39 <zxiiro> #link https://docs.google.com/presentation/d/1NOZYpnfsk1IgvZysHRwfPgz130LviumRCpGBw1X14NY/edit?usp=sharing Jenkins Job Builder presentation
16:31:48 <zxiiro> #link https://github.com/lfit/releng-global-jjb/blob/master/jjb/lf-macros.yaml#L6-L14 inject variables into a shell script
16:41:56 <jamoluhrsen> #endmeeting