16:01:53 <jamoluhrsen> #startmeeting integration
16:01:53 <odl_meetbot> Meeting started Thu Sep 28 16:01:53 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:53 <odl_meetbot> The meeting name has been set to 'integration'
16:03:46 <jamoluhrsen> #topic release
16:04:21 <jamoluhrsen> #info nitrogen is released this week, so now focus is carbon SR2 and nitro SR1
16:04:53 <jamoluhrsen> #info carbon autorelease finally worked now that we pulled out next project
16:06:55 <jamoluhrsen> #action seems the problem with next is npm (i.e., node) related. but it seems that next is not responding yet and we've reached out to dlux to see if they can help.
16:07:52 <jamoluhrsen> #info since next is it's own separate download we could continue to release carbon SR2 and let others download the previous version
16:08:25 <jamoluhrsen> #info also it should be noted that next is not going to be in nitrogen as well.
16:09:31 <jamoluhrsen> #action zxiiro to draft email to TSC with options for dealing with next
16:09:40 <jamoluhrsen> #info two blocker bugs for carbon sr2
16:10:10 <jamoluhrsen> #info there may be more than just two bugs... need to update spreadsheet
16:10:11 <klou> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 - carbon blocker bugs
16:10:23 <jamoluhrsen> #action jamoluhrsen to do a blocker bug query and update spreadsheet
16:12:49 <jamoluhrsen> #info oxygen still has 5 projects that haven't sent their feedback to be in the release (mdsal, snmp, cardinal, eman, ttp)
16:13:48 <jamoluhrsen> #action vrpolak to remind rovarga to send official email about mdsal being in release
16:13:59 <jamoluhrsen> #action jamoluhrsen to track down snmp folks to see if they want to be in oxy
16:14:31 <jamoluhrsen> #action LuisGomez to double check with colin about ttp
16:15:41 <jamoluhrsen> #info the oxy participation deadline was 3 weeks ago.
16:16:52 <jamoluhrsen> #info the oxygen release plan needs official approval from TSC
16:17:08 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan   <--- oxy release plan
16:19:35 <jamoluhrsen> #info it's probably too late to require projects to untangle their bundle/feature dependencies in oxygen, but maybe we can get a non-voting job working in the oxy timeframe and then make it a requirement in Flourine
16:21:54 <jamoluhrsen> #info we need to get back to vetting projects csit and giving feedback from int/test.
16:24:38 <jamoluhrsen> #action jamoluhrsen to send the email to tell projects that if they have gone two releases marking their CSIT jobs as IGNORE, we will remove their jobs
16:25:30 <jamoluhrsen> #topic distribution
16:25:49 <jamoluhrsen> #info no movement in the distribution code base.
16:26:29 <jamoluhrsen> #info int/dist needs to create a release plan for oxy and the plan wont advertise that we will NOT have a stable distribution
16:27:55 <jamoluhrsen> #topic clustering
16:28:27 <jamoluhrsen> #info bug 9145 has a patch in place for oxy and seems to make the OFP scenario much more stable, but there is still one other corner case that probably needs fixing.
16:30:21 <jamoluhrsen> #info bug 9145 fix is only on oxy for now, but we have that bug as a blocker in carbon
16:34:00 <jamoluhrsen> #topic builder
16:34:09 <zxiiro> #link https://gerrit.linuxfoundation.org/infra/6419 Deploy Sandbox job directly in Gerrit Comment
16:36:14 <jamoluhrsen> #info the idea is you push a releng/builder patch to gerrit and then you can use a gerrit keyword to push jobs to the sandbox meaning people don't have to have JJB installed locally
16:36:30 <zxiiro> #info jjb-deploy JOB_NAME
16:37:48 <jamoluhrsen> #info we need a quick how-to/docs on how to use this
16:38:15 <jamoluhrsen> #info there is hope that we can get a global-docs project so we can post these kinds of cross-project info to one place
16:39:19 <jamoluhrsen> #info new java doc deployment job strategy coming.
16:39:35 <jamoluhrsen> #info goal is to have a single location for all java docs
16:39:58 <jamoluhrsen> #topic S3P
16:40:34 <jamoluhrsen> #info s3p sandbox jobs starting to happen.
16:41:43 <jamoluhrsen> #topic misc
16:42:34 <jamoluhrsen> #info mdsal is waiting for oxy release plan to be fully approved before sending their intent to participate
16:44:31 <jamoluhrsen> #action jamoluhrsen to reply on that release plan thread to see if we want to vote via email or wait until next TSC.
16:45:46 <jamoluhrsen> #info we still need to figure out the -all- vs -only- csit jobs, but maybe it's a good topic to figure out at the DDF in two weeks.
16:47:46 <vrpolak> #link https://bugs.opendaylight.org/show_bug.cgi?id=9165  <-- Log when SCC is ready.
16:48:25 <vrpolak> No #endmeeting?
16:58:38 <vrpolak> #info SCC -> CSS == Config SubSystem
17:20:48 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Reduce ssh to the openstack nodes  https://git.opendaylight.org/gerrit/62154
18:22:10 <odp-gerritbot> Andrej Kilvády proposed a change to integration/test: Add multiple devices with 1 resctconf call  https://git.opendaylight.org/gerrit/63412
19:00:15 <odp-gerritbot> Sam Hague proposed a change to integration/test: add option to run single tempest test  https://git.opendaylight.org/gerrit/63798
20:32:00 <mattw4> I'd appreciate it if anyone could check on this link and let me know if they can view it
20:32:10 <mattw4> S3P test plan: #link I'd appreciate it
20:32:24 <mattw4> #link https://docs.google.com/spreadsheets/d/1Mk7TxCj2ZqBGG0EK6Cg153j8Ors2eQck3OOuaKprfm0
20:54:12 <odp-gerritbot> Sam Hague proposed a change to integration/test: add option to run single tempest test  https://git.opendaylight.org/gerrit/63798
21:12:28 <odp-gerritbot> Sam Hague proposed a change to integration/test: common tempest in DevstackUtils  https://git.opendaylight.org/gerrit/63804
21:29:21 <odp-gerritbot> Sam Hague proposed a change to integration/test: add option to run single tempest test  https://git.opendaylight.org/gerrit/63798
22:41:35 <jamoluhrsen> #endmeeting