16:02:15 <jamoluhrsen> #startmeeting integration
16:02:15 <odl_meetbot> Meeting started Thu Oct  5 16:02:15 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:15 <odl_meetbot> The meeting name has been set to 'integration'
16:04:17 <jamoluhrsen> #topic builder
16:05:01 <jamoluhrsen> #info the sandbox deploy job is ready with just adding a gerrit comment to a releng/builder patch
16:05:40 <zxiiro> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-October/010317.html JJB Sandbox Deployment job
16:05:46 <jamoluhrsen> #info the gerrit keyword would be "jjb-deploy <job name>"   and wildcards can be used to deploy multiple jobs
16:06:06 <jamoluhrsen> #topic packaging
16:06:50 <jamoluhrsen> #info testing work happening in packaging...
16:07:24 <jamoluhrsen> #info work to get our packaging process building in a mock environment
16:07:46 <jamoluhrsen> #info deb logic still broken, but making slow progress towards a fix
16:08:16 <jamoluhrsen> #info the opnfv folks do want to use the .deb package
16:08:37 <jamoluhrsen> #topic distribution
16:09:23 <jamoluhrsen> #info autorel builds are failing on nitro and oxy, but fix is in mdsal and needs to be fixed.
16:12:00 <jamoluhrsen> #info odlparent 2.0.5 with karaf 4.0.10 behaves better with heap space usage, but still some problems with OOM (e.g., gbp hits this)
16:12:21 <jamoluhrsen> #info patch in progress so we can archive a compressed heap dump to store in nexus for devs to debug with
16:14:09 <jamoluhrsen> #info we need a better process (maybe weather report) when version bumps are expected to be done
16:14:46 <jamoluhrsen> #info boron jobs are gone, but with it we lost our csit-1node-library job since it was still using boron
16:17:38 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/63939/ <<--- small refactor happening in int/dist which is moving certain projects
16:17:47 <jamoluhrsen> #topic release
16:18:41 <jamoluhrsen> #info carbon SR2 still waiting on 9145 to be cherry picked to carbon
16:19:39 <jamoluhrsen> #info LuisGomez thinks the patch is ok.
16:19:58 <jamoluhrsen> #action LuisGomez to update the bug with his thoughts on the patch
16:21:25 <jamoluhrsen> #info LuisGomez knows of a regression in carbon related to the cbench CSIT and has a fix in nitrogen but it needs a patch in carbon
16:26:03 <jamoluhrsen> #info carbon autorelease is only running weekly now so we need to manually trigger it when we are close to an SR
16:27:57 <jamoluhrsen> #info nitrogen SR1 is supposed to be in 2 days, but that is so soon due to the nitrogen delay. when should we release? we'll ask the TSC.
16:28:54 <jamoluhrsen> #info version bump patches still needed as we are still failing autorelease
16:29:30 <jamoluhrsen> #info oxygen release plan should be approved today, but still waiting for mdsal M0 status
16:30:01 <jamoluhrsen> #info cardinal and ttp are the only other projects that haven't responded and we expect them to drop out of oxygen
16:32:11 <jamoluhrsen> #info the -all- jobs were not actually installing all features for karaf4. that was fixed only this past week. keep your eyes open for anything odd
16:32:20 <jamoluhrsen> #undo
16:32:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x15af8d0>
16:32:24 <jamoluhrsen> #topic misc
16:32:26 <jamoluhrsen> #info the -all- jobs were not actually installing all features for karaf4. that was fixed only this past week. keep your eyes open for anything odd
16:32:56 <jamoluhrsen> #info jamoluhrsen notes that all of our project test requirements as they are stated on the wiki are really not adhered to.
16:33:31 <jamoluhrsen> #info we need to revisit what we expect from projects so we can reasonably hold them to it.
16:35:10 <vrpolak> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#Nitrogen_Project_Integration_and_Test_Requirements
16:35:38 <jamoluhrsen> #info we can sit for an hour or so at the DDF next week to discuss this more in depth
16:36:29 <jamoluhrsen> #info decanter is not working in karaf4 distributions
16:37:27 <jamoluhrsen> #action jamoluhrsen to file a bug against int/dist that decanter does not work in our karaf4 distros (so nitrogen and beyond)
16:40:12 <jamoluhrsen> #link https://imgur.com/a/KqZIM <--- project dependencies graph
16:41:42 <jamoluhrsen> #info the claim was that offset1 projects were depending on offset2 but we don't really see it.
16:43:10 <jamoluhrsen> #link https://logs.opendaylight.org/releng/jenkins092/autorelease-release-nitrogen/221/dependencies.log.gz <--- autorel dependency log
16:43:52 <jamoluhrsen> #action jamoluhrsen to look in to removing federation from the netvirt pom files
16:46:01 <jamoluhrsen> #endmeeting