16:02:00 <jamoluhrsen> #startmeeting integration
16:02:00 <odl_meetbot> Meeting started Thu Oct 26 16:02:00 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:00 <odl_meetbot> The meeting name has been set to 'integration'
16:04:31 <jamoluhrsen> #topic release
16:04:56 <jamoluhrsen> #info autorel problem is solved by rolling back the builder vm image
16:07:32 <jamoluhrsen> #info one blocking bug left (openflow 930) and should be done this week.
16:07:52 <jamoluhrsen> #info nitro sr1 candidate should be out shortly after fix for openflow 930
16:08:11 <jamoluhrsen> #info likely we can vote next thursday for nitro sr1 release.
16:09:27 <jamoluhrsen> #info controller bug 9163 (BZ) (from tencent) was downgraded from blocker
16:17:31 <jamoluhrsen> #info carbon sr3 is coming in 2 weeks
16:17:54 <jamoluhrsen> #info but, since sr2 only came out 10 days ago, maybe it's worth postponing or skipping
16:18:51 <jamoluhrsen> #info oxygen is collecting m1 milestone readouts from projects (half are in)
16:19:07 <zxiiro> #link m1 milestone readouts  http://docs.opendaylight.org/en/latest/release-process/milestone-readouts.html#m1-final-release-plan
16:19:45 <anipbu> https://docs.google.com/spreadsheets/d/1eZUHn6iCDUiwvYpqnH3vnaOTWPlYwh4l1wRF-DUqM3M/edit#gid=2147345344
16:20:59 <jamoluhrsen> #info anipbu brings up idea that we might not want to keep update the tracking spreadsheet
16:22:47 <klou> #link http://docs.opendaylight.org/en/latest/release-process/milestone-readouts.html <- milestone readout
16:24:02 <jamoluhrsen> #info klou argues that we are requiring the data that would populate the tracking spreadsheet via .rst gerrits for milestone repors
16:24:40 <jamoluhrsen> #info vrpolak points out that if we have a required structure/format for the .rst reports we can add automation to generate the matrix we would get from the spreadsheet
16:28:34 <jamoluhrsen> japan!
16:29:01 <zxiiro> :)
16:31:08 <jamoluhrsen> #topic packaging
16:31:37 <jamoluhrsen> #info downstream asking for an enhancement to make packaging more generic.
16:33:44 <jamoluhrsen> #topic distribution
16:35:32 <jamoluhrsen> #info distro-check has been unstable this week (OOM problem and two incompatible netconf features)
16:36:54 <jamoluhrsen> #info vratko's patch with 1node vs 3node compatible feature lists may be a good fix
16:38:02 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/64410/ <-- master branch for 1node vs 3node compatible features
16:38:10 <odp-gerritbot> A change was merged to integration/distribution: Bug 9307: Split features to avoid incompatiblities  https://git.opendaylight.org/gerrit/64410
16:39:18 <jamoluhrsen> #info LuisGomez does not think we need to do all these workarounds for 1node vs 3node incompatible features, but vrpolak points out that this could happen with other features down the road so adding more features later will be easier
16:42:04 <zxiiro> dfarrell07: klou: anipbu: we can probably use something like this https://stackoverflow.com/questions/16072086/including-dynamic-content-in-documentation-generated-by-python-Sphinx in an RST file to have it generate itself via python or shell script.
16:42:55 <zxiiro> so I think the design can be to create a overview.rst page and then run code to parse the m0 / 1 / 2 / 3 / 4 pages and output out in the format we want
16:43:27 <zxiiro> We can probably have a very basic example at first and iterate to add the rest of the columns.
16:47:57 <klou> Good point zxiiro!  Anipbu: Do you have a basic example and the key pieces info we want to show?
16:48:51 <jamoluhrsen> #info bug 9189 (features pulling bundles when they shouldn't) is being worked on, and vrpolak has some changes 63331 63348 that are ready
16:49:03 <jamoluhrsen> #action jamoluhrsen to look at 63331 and 63348
16:49:16 <jamoluhrsen> #topic clustering
16:49:41 <anipbu> klou: in Carbon we also tracked milestone in a spreadsheet as well.  See this link as proof: https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1295224960
16:50:46 <jamoluhrsen> #info bug 8999 (netconf-454) has a workaround, but it's not good enough yet. Possibly the bug won't get fixed, and might need some changes from upstream.
16:53:09 <jamoluhrsen> #info prefix base shard registration still not working in isolation scenario
16:53:21 <klou> anipbu: ok - I'm unaware of a different spreadsheet.  Looks like in this spreadsheet, only M4 and M5 have more meaningful columns.
16:54:51 <jamoluhrsen> #topic builder
16:55:27 <jamoluhrsen> #info our rackspace stack timeout is now 15m, with 2 retries (30m total). was 10m with 3 retries
16:56:34 <jamoluhrsen> #info rackspace has not gotten back to us on why things are slower, but we are moving to a new provider in Jan.
16:57:52 <jamoluhrsen> #topic misc
16:58:04 <jamoluhrsen> #info vrpolak on pto all next week
16:58:23 <jamoluhrsen> #info zxiiro is gone 11/10 - 11/26
16:58:46 <jamoluhrsen> #endmeeting