17:06:07 <jamoluhrsen> #startmeeting integration
17:06:07 <odl_meetbot> Meeting started Thu Nov  9 17:06:07 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:06:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:07 <odl_meetbot> The meeting name has been set to 'integration'
17:06:25 <jamoluhrsen> #action jamoluhrsen to send email that DST is probably messing up some schedules and we missed some attendees
17:06:39 <jamoluhrsen> #info packaging
17:06:43 <jamoluhrsen> #undo
17:06:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1512b90>
17:06:46 <jamoluhrsen> #topic packaging
17:07:06 <jamoluhrsen> #info few patches to cleanup things for downstream things like tripleo
17:07:28 <jamoluhrsen> #info tripleo wants to do a good health check so there is a patch investigating that now
17:09:21 <jamoluhrsen> #info doc improvements happening and some small interest from different places
17:11:02 <jamoluhrsen> #topic release
17:11:29 <jamoluhrsen> #info nitro sr1 has no more blocker bugs. waiting on next release candidate build
17:12:04 <jamoluhrsen> #info carbon will have discussion in TSC on where SR3 should land. no replies to the email that klou sent to tsc mailing list
17:12:37 <jamoluhrsen> #info final support for carbon is supposed to be in Feb, so that should probably be when SR4 lands, so when do we fit in SR3
17:12:52 <jamoluhrsen> #info still missing M1 status from projects while M2 is already starting to become due
17:13:25 <jamoluhrsen> #topic distribution
17:13:46 <jamoluhrsen> #info p4plugin made it in to the oxygen distribution
17:20:23 <odp-gerritbot> Dipankar Jain proposed a change to integration/packaging: Move versioning docs wiki to RTD  https://git.opendaylight.org/gerrit/65056
17:24:55 <jamoluhrsen> #info the TWS meeting this week discussed a new release/distribution discussion on whether we can do a new release model where we only release a "core" platform that includes projects that meet specific (probably strict) requirements and not worrying about getting ALL the projects faking that they are meeting requirements
17:25:23 <jamoluhrsen> #action dfarrell07 to try to get a small working group to meet tomorrow to hash out some basic ideas of what we can do. tomorrow might work (11/10)
17:27:38 <jamoluhrsen> #topic builder
17:28:17 <zxiiro> #link https://git.opendaylight.org/gerrit/65322
17:29:12 <dfarrell07> #link http://docs.opendaylight.org/en/latest/submodules/integration/packaging/docs/distribution-job-builds.html#custom-distributions Int/Pack has good existing multi-patch docs here, could add zxiiro's new keyword
17:29:43 <zxiiro> multipatch-build:
17:30:06 <jamoluhrsen> #info we can now trigger a multipatch job using a gerrit comment. the patch that the comment ends up on only matters by it's branch. so the patches it builds only comes from the actual comment in gerrit
17:35:07 <jamoluhrsen> #info we now have a 4g RAM robot builder that may help us get past the OOM issue with robot parsing it's large output.xml file, but the problem is we only have a queue of 5 of these larger 4G robot VMs
17:36:58 <odp-gerritbot> Dipankar Jain proposed a change to integration/packaging: Move versioning docs wiki to RTD  https://git.opendaylight.org/gerrit/65056
17:41:13 <odp-gerritbot> Dipankar Jain proposed a change to integration/packaging: Move versioning docs wiki to RTD  https://git.opendaylight.org/gerrit/65056
17:43:25 <jamoluhrsen> #action jamoluhrsen to look at reducing the polling numbers in WUKS to reduce a few iterations of logs
17:45:02 <jamoluhrsen> #action zxiiro jamoluhrsen to change all robot vms to 4G and only 15 in parallel and see if our queue backs up
17:46:35 <jamoluhrsen> #topic misc
17:47:24 <jamoluhrsen> #endmeeting