17:02:24 <jamoluhrsen> #startmeeting integration
17:02:24 <odl_meetbot> Meeting started Thu Jan 11 17:02:24 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:24 <odl_meetbot> The meeting name has been set to 'integration'
17:04:55 <jamoluhrsen> #topic builder
17:05:02 <zxiiro> #info migrated packer to common-packer + ansible
17:05:03 <zxiiro> #info need to migrate the remaining packer jobs to ansible
17:05:03 <zxiiro> #link Packer Ansible provisioner https://jenkins.opendaylight.org/releng/view/packer/job/builder-packer-merge-centos-builder/5/console
17:06:00 <jamoluhrsen> #info all LF projects should be using this new packer ansible work, so all CI systems should be the same.
17:07:32 <jamoluhrsen> #info seems the quagga build stuff is taking the longest
17:09:31 <jamoluhrsen> #info we still need to figure out which packer images we still need to keep and which to remove. We've already removed the generic mininet image, but do we need to keep mininet2.x and 2.y? can we just use 2.8?
17:09:44 <jamoluhrsen> #info we have a lot of devstack images. which do we need?
17:10:41 <jamoluhrsen> #action venkat to get rid of the newton devstack image
17:10:50 <jamoluhrsen> #action jamoluhrsen to get rid of the generic devstack image
17:12:00 <jamoluhrsen> zxiiro, LuisGomez gbp looks like it's installing some custom OVS:  https://github.com/opendaylight/releng-builder/blob/master/packer/provision/gbp.sh#L47-L50
17:14:51 <jamoluhrsen> #info there are new system flavors that should match more like what we had in RS.
17:16:20 <jamoluhrsen> #info the flavor v2-standard-# is the same as the performance nodes.
17:16:51 <jamoluhrsen> #info the flavor v2-highcpu-# is probably what we want to use going forward, but jamoluhrsen found troubles using them in the netvirt CSIT jobs
17:20:37 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: Pcep HA  https://git.opendaylight.org/gerrit/66941
17:21:18 <jamoluhrsen> #info jamoluhrsen sees that netvirt devtstack is failing with network issues using the new highcpu flavors
17:23:51 <jamoluhrsen> #topic release
17:24:37 <jamoluhrsen> #info carbon SR3 still waiting on blocker bug in netvirt
17:24:56 <jamoluhrsen> #info nitrogen next release SR2 is in Feb
17:25:20 <jamoluhrsen> #info oxygen in M4 now, but still need m2 and m3 status from a lot of different projects.
17:25:54 <jamoluhrsen> #topic distribution
17:26:38 <jamoluhrsen> #info yangtools and odlparent migration happening, so we might have to remove projects from distribution to make this work.
17:27:24 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: BMP HA test  https://git.opendaylight.org/gerrit/65471
17:31:07 <jamoluhrsen> #topic packaging
17:31:27 <jamoluhrsen> #info still fixing things that broke over the holiday break.
17:31:37 <jamoluhrsen> #info lots more puppet work coming in.
17:33:05 <jamoluhrsen> #info dfarrell07 still seeing some *maybe* network issue in a packaging job related to some ssl/container/etc
17:33:28 <jamoluhrsen> #info zxiiro wonders if this packaging problem might be related to an SFC CSIT issue that we see
17:34:29 <jamoluhrsen> #info hopefully we can get some better support for .deb packaging work this year, but dfarrell07 can't honestly spend enough good time on it. If we can't get help, we might want to stop *trying* to support it.
17:38:35 <jamoluhrsen> #endmeeting