17:04:18 <jamoluhrsen> #startmeeting integration
17:04:18 <odl_meetbot> Meeting started Thu Jan 18 17:04:18 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:18 <odl_meetbot> The meeting name has been set to 'integration'
17:04:46 <jamoluhrsen> #topic release
17:05:02 <jamoluhrsen> #info waiting on netvirt to report status of carbon SR3 to see if we can release
17:06:31 <klou_> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/523/  <- Latest Carbon Build
17:07:04 <jamoluhrsen> #info idea is to make sure netvirt csit is ok with the SR3 candidate and if so, we can go vet the rest of csit
17:07:55 <klou_> #link CSIT triggered by 523: https://jenkins.opendaylight.org/releng/view/autorelease/job/integration-distribution-test-carbon/
17:08:09 <dfarrell07> #link http://cbs.centos.org/repos/nfv7-opendaylight-6-testing/x86_64/os/Packages/opendaylight-6.3.0-0.1.20180117rel2079.el7.noarch.rpm RPM of Carbon SR3 RC
17:09:11 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-carbon/314/  <--- distribution-test job from this SR3 candidate
17:10:21 <jamoluhrsen> #info oxygen still chasing down m3/m4 status. m2 still pending the dlux folks. hoping robert can jostle them
17:10:49 <jamoluhrsen> #info still working through version bumps of yangtools and odlparent
17:12:37 <jamoluhrsen> #info we now have to re-patch all the projects of yangtools 2.0.1 now.
17:13:34 <jamoluhrsen> #info the version bump for yangtools will fix the topology api that was broken
17:15:23 <jamoluhrsen> #info LuisGomez advocates that we use some super privileges to have all projects bumped and merged asap. otherwise this could take us another week.
17:20:36 <jamoluhrsen> #info oxygen code freeze is now-ish (offset 2 is this week). probably we should ask for an extension
17:20:48 <jamoluhrsen> #info RC0 is 2/7, and maybe we can meet that.
17:21:32 <jamoluhrsen> #info nitrogen SR is planned for 2/7
17:22:24 <jamoluhrsen> #info autorelease is failing since the 9th. we are going to need people to look at that somehow, if we want to meet the SR2 date
17:23:22 <jamoluhrsen> #info distribution
17:23:26 <jamoluhrsen> #undo
17:23:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2a46690>
17:23:31 <jamoluhrsen> #topic distribution
17:24:12 <jamoluhrsen> #info LuisGomez has fixed the multipatch job. It was working for some things, but was not working when version bump patches were involved.
17:27:09 <jamoluhrsen> #info the fix for multipatch was done by building projects in order
17:27:25 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/c/67275 <-- multipatch job fix patch
17:31:32 <zxiiro> yeah validate is still fialing https://jenkins.opendaylight.org/releng/view/Validate-Jobs/
17:31:37 <jamoluhrsen> #info oxygen distribution was finally building with previous yangtools bump, but now that we have to bump again we might start breaking again
17:32:40 <jamoluhrsen> #info no news for distribution on carbon or nitrogen
17:33:31 <jamoluhrsen> #topic packaging
17:33:53 <jamoluhrsen> #info major test improvements this week, and some ansible stuff
17:35:58 <dfarrell07> #link https://jira.opendaylight.org/browse/INTPAK-104
17:36:30 <jamoluhrsen> #topic builder
17:37:05 <jamoluhrsen> #info Andy finished CLM migration to vexxhost, and we are not essentially fully out of rackspace
17:37:45 <jamoluhrsen> #info new vm/flavors are now available, and LuisGomez saw the tests working with them
17:38:54 <jamoluhrsen> #info main idea is that these new flavors are going to save us money
17:42:35 <jamoluhrsen> #info lots of moving stuff in packer ansible world, maybe will move to ansible galaxy
17:44:53 <jamoluhrsen> #info there is a test for ansible roles called molecule that should be very useful for verify jobs
17:46:25 <odp-gerritbot> Luis Gomez proposed a change to integration/test: Change Karaf prompt to root  https://git.opendaylight.org/gerrit/67225
17:46:50 <jamoluhrsen> #info for projects that need new software and don't know ansible, they can give us a shell script and one of us support folks can create a patch in ansible. This is just to be helpful and get them working faster, but eventually we need to ask projects to give ansible patches
17:47:07 <zxiiro> #link rough POC of managing clouds configuration in Jenkins https://gerrit.linuxfoundation.org/infra/8429
17:49:04 <jamoluhrsen> LuisGomez, question for you https://stackoverflow.com/questions/48292472/opendaylight-how-to-get-a-row-from-ovsdb-table/48293977?noredirect=1#comment83588074_48293977
17:49:51 <jamoluhrsen> #topic misc
17:51:30 <jamoluhrsen> #action dfarrell07 to send email to the integration group about how to subscribe to stack exchange opendaylight questions
17:54:37 <jamoluhrsen> #endmeeting