17:05:06 <jamoluhrsen> #startmeeting integration
17:05:06 <odl_meetbot> Meeting started Thu Jan 25 17:05:06 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:06 <odl_meetbot> The meeting name has been set to 'integration'
17:05:21 <jamoluhrsen> #topic builder
17:06:07 <jamoluhrsen> #info inbound work to give a {prefix} option for CSIT jobs, which will make it a little easier to create unique jobs in the sandbox
17:06:47 <zxiiro> #link https://git.opendaylight.org/gerrit/#/q/topic:prefix
17:07:34 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-defaults.yaml#L6
17:08:22 <odp-gerritbot> Stephen Kitt proposed a change to integration/distribution: WIP: Use profiles  https://git.opendaylight.org/gerrit/67583
17:08:29 <jamoluhrsen> #info there is a unit test in releng/builder verify jobs that will catch anyone accidentally pushing a non empty prefix
17:10:10 <jamoluhrsen> #info new paradigm for docs coming, where each project will keep and publish their own docs
17:10:49 <jamoluhrsen> #info docs.opendaylight.org will still be able to link to these sub project docs
17:11:12 <zxiiro> #link Example subproject https://lf-releng-docs.readthedocs.io/projects/lftools/en/latest/
17:13:01 <jamoluhrsen> #info we still need to figure out if we can use the highcpu VMs for CSIT jobs
17:17:26 <jamoluhrsen> #topic release
17:17:41 <jamoluhrsen> #info carbon SR3 still blocked on netvirt
17:19:10 <jamoluhrsen> #action jamoluhrsen to make sure there is a jira issue for the carbon sr3 blocker
17:20:44 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007942.html <-- email thread about carbon SR3 blocker issue(s)
17:23:28 <jamoluhrsen> #action LuisGomez to show jamoluhrsen the patch to change idle timeout
17:25:08 <LuisGomez> jamoluhrsen, this is the patch to remove switch echos: https://git.opendaylight.org/gerrit/#/c/63186/
17:28:20 <jamoluhrsen> #info nitrogen does not have a good autorelease since jan 9th. we need to figure it out in aprox 2 weeks.
17:28:46 <jamoluhrsen> #action zxiiro abelur klou_ to send some message(s) about nitrogen autorelease
17:29:23 <jamoluhrsen> #info seems nitrogen is failing in random places for nitrogen
17:29:53 <jamoluhrsen> #info zxiiro thinks we can build twice a day and try to track each failure by type/project/etc
17:31:35 <jamoluhrsen> #info Oxygen is still unstable, and the AAA gson patch was merged so we need to check other projects to see where anything might be broken.
17:33:54 <jamoluhrsen> #action LuisGomez to check that the distribution job is ok or not after the AAA gson patch came in
17:34:41 <jamoluhrsen> #info still chasing m2/m3 status for Oxygen
17:35:38 <jamoluhrsen> #info seems that we are still missing quite a few projects to finish their odlparent/yangtools version bump migration
17:36:50 <jamoluhrsen> #topic packaging
17:37:04 <jamoluhrsen> #info just test improvements
17:37:56 <jamoluhrsen> #info eventually we can start adding phased testing for packages
17:38:30 <jamoluhrsen> #topic distribution
17:39:05 <jamoluhrsen> #undo
17:39:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x293d990>
17:39:09 <odp-gerritbot> Jaime Caamaño Ruiz proposed a change to integration/test: Check service function types are present  https://git.opendaylight.org/gerrit/67544
17:39:27 <jamoluhrsen> #topic misc
17:39:35 <jamoluhrsen> #action LuisGomez to look at this OFP email: https://lists.opendaylight.org/pipermail/openflowplugin-dev/2018-January/007923.html
17:40:20 <odp-gerritbot> Jaime Caamaño Ruiz proposed a change to integration/test: Check service function types are present  https://git.opendaylight.org/gerrit/67544
17:42:53 <jamoluhrsen> #info we should consider another integration specific meetup some time this year.
17:43:51 <jamoluhrsen> #endmeeting