#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:35 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:06:20)
    1. still some projects not yet added in Oxygen (8 projects) (jamoluhrsen, 17:07:21)
    2. the carbon distribution was not building for a while, but it worked now today, so all branches seem to be good now (jamoluhrsen, 17:08:16)
    3. seems that lots of the recent infra related problems with building has been overcome with larger VMs (more CPU and RAM) (jamoluhrsen, 17:09:59)

  2. builder (jamoluhrsen, 17:13:23)
    1. some complaints coming that we shouldn't be changing VMs (sizes, etc) underneath them. (jamoluhrsen, 17:13:47)
    2. Nexus disk ran out of inodes and caused downtime twice on Saturday and again on Monday (zxiiro, 17:14:24)
    3. We will be performing maintenance on Monday to move to an XFS partition with 4x the amount of inodes (zxiiro, 17:14:24)
    4. We will be putting logs on a separate partition moving forward so that inode breaks in that directory does not affect the rest of the Nexus server in the future. (zxiiro, 17:14:24)
    5. another idea is to tarball older logs to save on inodes (zxiiro, 17:14:24)
    6. Related to this we've been notified by Sonatype about a Cross Site Scripting vulnerability CVE which could allow code execution so expecting to update Nexus as well. (zxiiro, 17:14:24)
    7. Confirmed that Vexxhost Disk I/O is slow because disk is backed by a networked Ceph cluster and not local volume storage like we had in Rackspace (zxiiro, 17:17:11)
    8. Vexxhost cloud Network I/O slow Monday morning due to Hardware upgrades, Vexxhost heard our concerns that their cloud is noticiably slower than our previous provider and are looking into installing faster CPUs and faster Disks in the cluster. #info Unfortunately because the volume storage is backed by Ceph when new disks were added the cluster sync took up a lot of network I/O causing all of our (zxiiro, 17:17:11)
    9. CSIT jobs on Monday to run on very slow network links. (jamoluhrsen, 17:17:29)
    10. vexxhost still has more migration/swapping to do so we need to find a sane time and warn everyone (jamoluhrsen, 17:20:47)
    11. dfarrell07 suggests that doing the upgrades/migrations could be when we are all at ONS. (jamoluhrsen, 17:21:28)
    12. Wednesday we discovered a bug in our orphaned nodes cleanup script where a race condition where if a new Node was created but not yet connected to Jenkins could be issued a delete command causing the job to immediately fail as soon as it starts. This explains the seemingly random disappearence of servers. (zxiiro, 17:22:44)
    13. Orphaned script is now disabled and a better solution that will take into account creation time will be added in a future update. (zxiiro, 17:22:44)
    14. Changed default flavor to give projects more CPU (but less RAM) https://git.opendaylight.org/gerrit/67871 (zxiiro, 17:26:27)
    15. All Validate Autorelease accidently broken on Friday and releng was not aware until Tuesday. This should never have been possible in the first place as this job should not be overridable. we've hardcoded it since (zxiiro, 17:26:27)
    16. Some project merge jobs needed to be adjusted (and maybe more, please let us know) (zxiiro, 17:26:27)

  3. release (jamoluhrsen, 17:28:44)
    1. carbon SR3 is looking better. need signoff on the failures (jamoluhrsen, 17:29:15)
    2. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633 <-- csit failures for SR3 (jamoluhrsen, 17:29:59)
    3. ACTION: LuisGomez jamoluhrsen to check as many jobs as possible (jamoluhrsen, 17:30:11)
    4. we did already vote from the TSC that if we get all CSIT signoffs for SR3 we can release (jamoluhrsen, 17:30:51)
    5. no good nitro autorelease for a week (probably infra related) but we want to freeze nitro this week and release next week (jamoluhrsen, 17:31:30)
    6. nitrogen is top priority for us (jamoluhrsen, 17:31:43)
    7. oxygen is still struggling with 8 projects not in the distribution yet. 3 don't even have a yangtools version bump patch that's passing (jamoluhrsen, 17:32:38)
    8. eman, snmp4sdn and vtn are the projects that don't have a passing yangtools version bump (jamoluhrsen, 17:33:33)
    9. https://git.opendaylight.org/gerrit/#/c/66633/ <- version bump patch for vtn (klou, 17:34:19)
    10. gbp faas jsonrpm nic unimgr are the projects that have done yangtools bump (via tom) but not in distro. nic and unimgr don't have any activity to do that yet (jamoluhrsen, 17:37:22)
    11. still projects missing m2,m3,m4 statuses.... (jamoluhrsen, 17:37:58)

  4. packaging (jamoluhrsen, 17:38:14)
    1. still lots of activity around test coverage (jamoluhrsen, 17:38:44)
    2. found a legit ssh bug in odlparent because of these newly added tests (jamoluhrsen, 17:39:04)
    3. new puppet fixes/features coming in (jamoluhrsen, 17:39:42)
    4. some concern about the current email discussion about .cfg vs .xml files for odl configurations (jamoluhrsen, 17:40:03)
    5. the .deb pipeline was stale for a while and we requested some help and some people have stepped up. (jamoluhrsen, 17:40:41)
    6. the #1 problem with .deb packaging is that the current pipeline doesn't work at all. (jamoluhrsen, 17:43:39)
    7. once the deb pipeline works, we want to turn on CI/CD for it (jamoluhrsen, 17:43:54)
    8. we have some test jobs that we use against the rpm packaging that we should easily be able to covert over the deb side (jamoluhrsen, 17:44:22)
    9. http://docs.opendaylight.org/en/latest/submodules/releng/builder/docs/jenkins.html#jenkins-sandbox (zxiiro, 17:47:06)

  5. misc (jamoluhrsen, 17:58:08)
    1. venkat wonders how we can test an image locally after we have given builder changes (jamoluhrsen, 17:58:49)
    2. zxiiro says we cannot do that easily (jamoluhrsen, 17:58:56)
    3. https://github.com/opendaylight/releng-builder/blob/master/packer/vars/cloud-env.json.example (zxiiro, 18:00:41)
    4. zxiiro says if we have a local openstack cloud we should be able to replicate these images with some basic steps (see link above) (jamoluhrsen, 18:00:50)
    5. https://github.com/opendaylight/releng-builder/tree/master/packer (zxiiro, 18:01:44)


Meeting ended at 18:04:34 UTC (full logs).

Action items

  1. LuisGomez jamoluhrsen to check as many jobs as possible


Action items, by person

  1. jamoluhrsen
    1. LuisGomez jamoluhrsen to check as many jobs as possible


People present (lines said)

  1. jamoluhrsen (45)
  2. zxiiro (16)
  3. odl_meetbot (4)
  4. shague (2)
  5. mardim (1)
  6. klou (1)
  7. dfarrell07 (1)


Generated by MeetBot 0.1.4.