17:01:29 <jamoluhrsen> #startmeeting integration
17:01:29 <odl_meetbot> Meeting started Thu Feb 15 17:01:29 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:29 <odl_meetbot> The meeting name has been set to 'integration'
17:03:34 <jamoluhrsen> #topic packaging
17:06:16 <jamoluhrsen> #info wget to opensuse URLs is not working from our infra (inside a docker container). seems related to MTU size. maybe opensuse servers are sending back too large packets.
17:07:15 <zxiiro> #action zxiiro will rebuild the docker images with fixed mtus to 1458
17:10:54 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/c/68114/ <-- patch to change rpm spec to build different rpm depending on which host OS (opensuse or centos) it's running
17:14:48 <jamoluhrsen> #info deb pipeline fixes coming soon hopefully. mardim has read through the tooling and hopes to get some patches uploaded in the near term
17:15:12 <jamoluhrsen> #topic release
17:15:42 <jamoluhrsen> #info nitro RC is ready. CSIT jobs are done and we will need to vet them.
17:16:32 <jamoluhrsen> #info carbon SR3 has a new candidate. the OFP blocker patch was merged and autorelease finished
17:16:53 <jamoluhrsen> #info CSIT tests for carbon SR3 just started. results ready tomorrow
17:17:31 <jamoluhrsen> #info nitrogen autorelease is no longer running daily.
17:18:39 <jamoluhrsen> #info oxygen is still delayed, no autorelease successful, need to decide if we are fully kicking eman, faas, vtn out of the release
17:19:03 <jamoluhrsen> #info gvrangan says the version bump patch was merged just today. LuisGomez will add vtn back to int/dist
17:19:47 <jamoluhrsen> #action gvrangan to find someone to add vtn back to autorelease and int/dist
17:20:57 <jamoluhrsen> #info deadline for projects to get back in to the release will be the first RC we get
17:22:21 <jamoluhrsen> #info nic and unimgr are not in int/dist yet, but we expect nic to be there. no clue on unimgr
17:25:30 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/68169/ Monster BIER code dump, risk of breaking world after merge
17:26:18 <jamoluhrsen> #topic distribution
17:26:18 <zxiiro> what feature does it add?
17:26:24 <zxiiro> lol
17:26:48 <jamoluhrsen> zxiiro: it updates "bier codes"
17:26:52 <dfarrell07> zxiiro: the commit message tells you everything man;) "add bier codes"
17:27:18 <jamoluhrsen> #info we still see SFT failures, but seems we are using enough memory (4G).
17:28:55 <jamoluhrsen> #info now we are starting to comment out SFT on a per project basis, which means there are probably projects having serious bugs and not getting fixed. But, we do not have bandwidth/cycles to help these projects figure this out any more and they are delaying everyone else.
17:35:46 <jamoluhrsen> #topic builder
17:36:15 <jamoluhrsen> #info finally migrated the filesystems for nexus (hopefully no more inode exhaustion)
17:36:33 <jamoluhrsen> #info maven binaries are on their own partition and logs on another
17:36:45 <jamoluhrsen> #info old-logs are not done migrating yet, maybe another week
17:37:46 <jamoluhrsen> #info add in "old-logs" in front of the releng path, like this https://logs.opendaylight.org/old-logs/releng/vex-yul-odl-jenkins-1/netvirt-csit-1node-openstack-ocata-upstream-stateful-oxygen/882/
17:38:46 <jamoluhrsen> #info the merge job counters started over and with the log sync in progress there is a possibility that some job's logs will have problems until rsync is complete
17:39:34 <jamoluhrsen> #info new global-jjb release in place now.
17:39:40 <zxiiro> #link https://github.com/opendaylight/releng-builder/tree/master/jenkins-config
17:42:04 <jamoluhrsen> #info emergency maintenance of jenkins coming due to new CVE (anon access can execute code on the jenkins system). this will happen ASAP
17:42:42 <jamoluhrsen> #topic misc
17:43:49 <jamoluhrsen> #info gvrangan has a new approach to installing openstack and opendaylight via robot
17:44:00 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/c/63168/ <-- patch for robot install of openstack and opendaylight
17:46:43 <jamoluhrsen> #info some new images are needed to make this new work possible.
17:47:17 <jamoluhrsen> gvrangan: here is an example:  https://github.com/opendaylight/releng-builder/blob/master/packer/provision/mininet-ovs-2.8.yaml
17:49:40 <jamoluhrsen> #info vtn restconf seems broken after the version bump
17:51:42 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/distribution: Restore vtn to distribution  https://git.opendaylight.org/gerrit/68314
17:53:12 <jamoluhrsen> #info klou brings up the idea that all int/dist committers become committers to autorelease, since a lot of patches to int/dist require a patch in autorelease as well.
17:55:34 <jamoluhrsen> #action LuisGomez to send email to vote for int/dist and autorelease committers to be the same
17:57:57 <jamoluhrsen> #endmeeting