17:01:58 <jamoluhrsen> #startmeeting integration
17:01:58 <odl_meetbot> Meeting started Thu Feb 22 17:01:58 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:58 <odl_meetbot> The meeting name has been set to 'integration'
17:02:44 <jamoluhrsen> #topic packaging
17:03:26 <jamoluhrsen> #info deb packaging job is successful
17:04:48 <mardim> https://jenkins.opendaylight.org/releng/view/autorelease/job/packaging-build-deb-nitrogen/
17:04:59 <jamoluhrsen> #action dfarrell07_pto to figure out/explain when/why the deb packaging jobs are triggered
17:05:11 <jamoluhrsen> #info jamoluhrsen has manually triggered both carbon and oxygen deb jobs now
17:06:22 <jamoluhrsen> #info zxiiro explains that our packaging jobs are triggered by autorelease
17:07:11 <mbuil> #link https://git.opendaylight.org/gerrit/#/c/68201/
17:11:17 <zxiiro> #link look for conditional-step here https://docs.openstack.org/infra/jenkins-job-builder/builders.html
17:11:49 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: WIP: BGP RIB policies tests  https://git.opendaylight.org/gerrit/68288
17:16:28 <zxiiro> mbuil: use this `find jjb -name "*.yaml" | xargs grep test-karaf.expect`
17:16:43 <jamoluhrsen> #topic release
17:17:37 <mbuil> zxiiro: thanks!
17:18:33 <odp-gerritbot> Sam Hague proposed a change to integration/test: Cleanup ovsdb suites  https://git.opendaylight.org/gerrit/68427
17:24:07 <jamoluhrsen> #info carbon sr3 and nitro sr2 csit results only with a few jobs left to check
17:24:23 <jamoluhrsen> #info gvrangan asking if we can get VTN back in to oxygen, but this is now a decision for the TSC
17:25:04 <jamoluhrsen> #info oxygen still not getting a good build in autorelease
17:25:23 <jamoluhrsen> #info nic, vtn and unimgr are all now out of autorelease after they were removed from int/dist
17:26:21 <jamoluhrsen> #info LuisGomez thinks there is a leak in nitrogen, but maybe it's not a regression or blocker
17:28:22 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: WIP: BGP RIB policies tests  https://git.opendaylight.org/gerrit/68288
17:29:15 <jamoluhrsen> #action LuisGomez to dig up or create the jira for this openflowplugin leak (dealing with groups) and point out the patch that fixed this in carbon. This is still not fixed in nitrogen and probably could be there in oxygen
17:32:38 <jamoluhrsen> #info even if we get a good oxygen autorelease, we may want to wait until next week to do the branch cutting and locking since we hope to release carbon and nitrogen in the next few days
17:33:50 <jamoluhrsen> #topic distribution
17:34:13 <jamoluhrsen> #info new patch to update karaf maven plugin which reduces the time to build
17:35:02 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/c/68100/  <--- Use karaf-maven-plugin 4.1.5
17:35:27 <jamoluhrsen> #info when we upgrade to the new odlparent version, we will revert the int/dist patch because it will come from odlparent itself
17:35:44 <jamoluhrsen> #topic builder
17:37:44 <jamoluhrsen> #info questions around whether we should upgrade our controller VM from 2x8 to 4x4, since LuisGomez thinks we are fine with only 4GB RAM but less cores might be one bottleneck we are hitting from time to time
17:38:28 <jamoluhrsen> #info we can test with the new controller size and monitor the controller netconf and bgp jobs to see if there is any improvement
17:39:58 <jamoluhrsen> #info zxiiro says the cost difference between 2x8 and 4x4 systems is minimal
17:41:16 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/c/68483/ <--- new controller size patch is now merged
17:41:35 <zxiiro> #info Moving Packer Ansible roles into Ansible Galaxy and retiring lf-ansible repo
17:41:35 <zxiiro> #link lf-ansible migration https://jira.linuxfoundation.org/browse/RELENG-809
17:43:47 <jamoluhrsen> #topic misc
17:45:44 <jamoluhrsen> #action gvrangan to put his image shell script as a patch so that zxiiro can look at it and help break it out in to smaller ansible steps for that role
17:47:34 <jamoluhrsen> #action LuisGomez to email the TSC about the new committers that have been voted on for int/dist (to align autorelease and int/dist committers)
17:49:20 <jamoluhrsen> #endmeeting