16:02:23 <jamoluhrsen> #startmeeting integration
16:02:23 <odl_meetbot> Meeting started Thu Apr  5 16:02:23 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:23 <odl_meetbot> The meeting name has been set to 'integration'
16:02:37 <jamoluhrsen> LuisGomez: be here in a min. finishing internal meeting
16:03:03 <LuisGomez> sure jamoluhrsen
16:03:25 <zxiiro> LuisGomez: jamoluhrsen have another meeting now but i'll jump on integration once that's over
16:04:37 <mbuil> jamoluhrsen: can you paste the link please?
16:04:55 <jamoluhrsen> mbuil: https://www.google.com/url?q=https%3A%2F%2Fzoom.us%2Fj%2F770709266
16:05:02 <jamoluhrsen> https://zoom.us/j/770709266
16:08:11 <jamoluhrsen> #topic packaging
16:08:41 <jamoluhrsen> #info some debian test job work in progress
16:10:00 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/69424/ large puppet-odl feature about to go in, need review from tim
16:10:55 <jamoluhrsen> #info puppet not setup for fluorine yet.
16:12:25 <jamoluhrsen> #info fluorine support for opensuse there, so hopefully XCI testing can happen now
16:14:04 <jamoluhrsen> #info found race condition in nitrogen, but the problem is not there in oxygen because we are using genius auto-tunnels. jaime has a fix coming for nitrogren
16:15:21 <jamoluhrsen> #topic release
16:16:11 <jamoluhrsen> #info carbon SR4 is coming in like a week.
16:17:35 <jamoluhrsen> #info carbon autorelease has a problem with huge disk issues. but we don't understand why this happened all of a sudden.
16:20:13 <jamoluhrsen> #info we need to figure out the root cause of this sudden increase in disk usage, but one easy thing to do is make a profile per-project to let us disable creating the local project karaf distributions
16:22:40 <jamoluhrsen> #action zxiiro to give an example of how to disable karaf distros and we can load balance that work across all projects
16:23:23 <jamoluhrsen> #info Fluorine still has a few projects that need initial checkpoints.
16:24:21 <jamoluhrsen> #info Fluorine needs 2-3 more projects to be reviewed for managed release
16:25:01 <jamoluhrsen> #info TSDR still wants tobe a managed project, although we did take a TSC vote last week to not allow that.
16:32:55 <jamoluhrsen> #info we need to version bump odlparent and yangtools. drop dead timeline is 4/8, which is this weekend so maybe we can do it now.
16:34:42 <jamoluhrsen> skitt: you around?
16:34:52 <skitt> jamoluhrsen, yeah
16:34:59 <skitt> jamoluhrsen, hopping on the call
16:35:03 <jamoluhrsen> https://zoom.us/j/770709266
16:36:30 <jamoluhrsen> #action jamoluhrsen to resurrect the friday release management call to figure out what bits of work still need to be done for this managed release
16:37:35 <jamoluhrsen> #info abelur should probably be at this meeting
16:37:51 <jamoluhrsen> #action jamoluhrsen to figure out how to get abelur at this meeting
16:46:14 <jamoluhrsen> #info skitt thinks even though we dont have a good autorelease we should just merge our version bumps
16:48:13 <jamoluhrsen> #info oxygen needs their yangtools and odlparent versions bumped
16:50:24 <jamoluhrsen> #action zxiiro and releng team to merge these patches.
16:51:09 <skitt> #link https://git.opendaylight.org/gerrit/69996
16:51:12 <skitt> #undo
16:51:22 <skitt> #link good build in the first version bump in the chain: https://git.opendaylight.org/gerrit/69996
16:51:46 <skitt> #link Oxygen patches: https://git.opendaylight.org/gerrit/#/q/topic:odlparent-3.1.0-oxygen+(status:open+OR+status:merged)
16:53:39 <jamoluhrsen> #info actually oxygen is first on the 14th, then carbon on the 26th (of April) and then nitrogen on 5/7
16:54:36 <jamoluhrsen> #info Ariel is getting ramped up on the release manager stuff
16:55:27 <jamoluhrsen> #topic distribution
16:55:42 <jamoluhrsen> #info version feature is now removed in Fluorine
16:55:56 <jamoluhrsen> #info int/dist in Fluorine is now only using managed projects
16:56:22 <jamoluhrsen> #info work in progress to make unmanaged projects part of the distribution by "hidden" <scope>test<scope>
16:58:05 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/70314/ <--- new way to make distro
16:58:16 <jamoluhrsen> #topic builder
16:58:56 <jamoluhrsen> #info JJB update needed now .2.0.3 or highger, and rebase local releng/builder repo. emergency issue came from an upstream tox change
17:00:10 <jamoluhrsen> #info zxiiro looking in to automating the integration jobs running after the merge jobs.
17:03:07 <odp-gerritbot> Janki Chhatbar proposed a change to integration/test: CSIT test for ODL upgrade  https://git.opendaylight.org/gerrit/66295
17:17:03 <jaicaa> jamoluhrsen: hello! what would be the procedure to get sfc back in autorelease, is it just a matter of submitting the patch?
17:17:47 <jamoluhrsen> jaicaa: dlux is out now right?
17:18:08 <jaicaa> jamoluhrsen: yup
17:18:47 <jamoluhrsen> jaicaa: yeah, merge that patch (if not already) then put a patch back in autorelease and int/dist and shoot an email about it.
17:19:26 <jaicaa> jamoluhrsen: all right, will do
19:01:02 <jamoluhrsen> #endmeeting