16:02:42 <jamoluhrsen> #startmeeting integration
16:02:42 <odl_meetbot> Meeting started Thu Apr 12 16:02:42 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:42 <odl_meetbot> The meeting name has been set to 'integration'
16:02:54 <jamoluhrsen> tomasmarkovic: hi
16:04:00 <LuisGomez> welcome tomasmarkovic
16:05:14 <jamoluhrsen> #topic builder
16:05:24 <zxiiro> jamoluhrsen: omw
16:08:40 <jamoluhrsen> #info there are still some infra aborts happening because of some openstack troubles where over time some compute nodes are getting disabled and after enough of them get disabled we will fail to bring up our CSIT stacks.
16:09:53 <jamoluhrsen> #autorelease builds were dying and running out of space because we were GB large pax directories. That was a newer patch merged and that has been reverted
16:10:18 <jamoluhrsen> #info tox was downgraded last week, because of a new major release that broke all of our CI. We have to use the older versions for now to keep our tests passing
16:10:37 <zxiiro> #link Provide way for projects to self release https://jira.linuxfoundation.org/browse/RELENG-425
16:11:45 <jamoluhrsen> #topic release
16:12:11 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-oxygen/264/console
16:12:13 <jamoluhrsen> #topic oxygen likely to be delayed
16:13:23 <jamoluhrsen> #info jsonrpc was most recent problem in oxy autorelease, but that is fixed. version bumping is done. hoping next autorelease job will pass
16:15:16 <jamoluhrsen> #info there is a major problem in oxygen (believed that stops REST from coming up) and the belief is that it's coming from latest odlparent version bump
16:15:36 <jamoluhrsen> #action LuisGomez to open a block bug for this new problem with REST not coming up
16:17:25 <jamoluhrsen> skitt: do you know about this ^^^
16:17:35 <jamoluhrsen> skitt: https://jira.opendaylight.org/browse/RELENG-85?focusedCommentId=62351&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-62351
16:18:03 <skitt> jamoluhrsen, the Jersey thing?
16:18:13 <skitt> jamoluhrsen, it’s on my radar but I haven’t looked into it
16:18:28 <jamoluhrsen> skitt: this is a blocker for oxygen we now realize
16:18:31 <jamoluhrsen> just fyi
16:18:33 <skitt> yes
16:19:39 <zxiiro> NIC dependency on VTN [ERROR] Failed to execute goal on project vtn-renderer: Could not resolve dependencies for project org.opendaylight.nic:vtn-renderer:bundle:1.3.4-Carbon: Could not find artifact org.opendaylight.vtn:manager:jar:0.6.4-Carbon in opendaylight-mirror (https://nexus.opendaylight.org/content/repositories/public/) -> [Help 1]
16:19:58 <jamoluhrsen> #info Carbon is failing because we removed VTN and NIC depends on VTN
16:20:31 <jamoluhrsen> #info VTN really wanted to be out of the releases, but two options are to remove the VTN dependency or add VTN back to Carbon
16:20:51 <jamoluhrsen> #action LuisGomez to ask NIC PTL to remove VTN dependency
16:21:09 <jamoluhrsen> #info this problem of VTN <- NIC is there in nitrogen
16:21:59 <jamoluhrsen> #info zxiiro expects that carbon should be ok once we get this vtn/nic thing figured out
16:22:54 <jamoluhrsen> #info nitrogen coming soon too, but last failure was in an ovsdb failure
16:23:22 <jamoluhrsen> #info LuisGomez found out that nitrogen doesn't have the vtn<-nic dependency
16:23:49 <jamoluhrsen> #info Fluorine version bumping still not happening yet. We are behind by a week on this now
16:24:04 <zxiiro> skitt: fluorine version bump are we almost ready to start? I think we're behind at this point?
16:24:50 <jamoluhrsen> #topic packaging
16:25:07 <skitt> zxiiro, yeah we’re behind
16:25:22 <skitt> too many spinning plates
16:25:28 <skitt> I’ll check what AAA is like now
16:25:34 <mardim___> #link https://git.opendaylight.org/gerrit/#/c/69378/ #link https://git.opendaylight.org/gerrit/#/c/69494/ #link https://git.opendaylight.org/gerrit/#/c/70823/ #link https://jenkins.opendaylight.org/sandbox/view/packaging/job/packaging-build-deb-nitrogen/11/
16:26:23 <jamoluhrsen> #info debian packages in the nexus repository are bad. they are not able to start. seems a missing file
16:27:10 <odp-gerritbot> A change was merged to integration/packaging: Add missing opendaylight.service template file  https://git.opendaylight.org/gerrit/70823
16:27:40 <jamoluhrsen> #topic distribution
16:28:03 <jamoluhrsen> #info lots of cleanup removing unmanaged projects from int/dist
16:28:52 <jamoluhrsen> #info new job coming that will build distribution with all the unmanaged projects in a very thin manner. hoping to add some sort of very basic test
16:30:35 <jamoluhrsen> #info LuisGomez has the idea that umanaged projects should consume the managed release artifacts from the *previous* release
16:31:05 <jamoluhrsen> #action LuisGomez to email his proposal for unmanaged projects to consume the previous release from managed projects
16:31:47 <jamoluhrsen> #info the version feature is now fully removed from Fluorine. Infrautils has a JIRA feature request to implement the same thing
16:32:11 <jamoluhrsen> #topic misc
16:42:47 <jamoluhrsen> #action jamoluhrsen to reduce transaction rate value in controller clustering csit so we can hopefully narrow our focus on the more concrete (non performance) failures in the  controller 3node jobs
16:50:29 <jamoluhrsen> #info tomasmarkovic notes that bgpcep 3node jobs are also failing a lot and nobody really looks because nobody really is there to fix
16:54:46 <jamoluhrsen> #action jamoluhrsen to file one JIRA on the hard 500 Exception in controller 3node job and hopefully someone can look at it.
16:55:19 <jamoluhrsen> #endmeeting