16:01:17 <jamoluhrsen> #startmeeting integration
16:01:17 <odl_meetbot> Meeting started Thu Apr 26 16:01:17 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:17 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:17 <odl_meetbot> The meeting name has been set to 'integration'
16:03:28 <jamoluhrsen> #topic packaging
16:03:41 <jamoluhrsen> #info all jobs are blue :)
16:04:13 <jamoluhrsen> #info some puppet stuff going on....
16:04:18 <jamoluhrsen> dfarrell07: we lost you
16:05:01 <jamoluhrsen> #info puppet stuff/fixing coming from internal Red Hat testing
16:05:18 <jamoluhrsen> #info ansible consumption in XCI turning up some bugs and fixes.
16:06:01 <jamoluhrsen> #info oxygen SR1 needs to hit the release pipelines
16:06:18 <jamoluhrsen> #topic release
16:07:02 <jamoluhrsen> #info zxiiro and dfarrell07 think we need to have more sync calls with Ariel
16:07:54 <jamoluhrsen> #info oxygen SR1 is out. w00t!
16:08:44 <zxiiro> https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117
16:08:49 <zxiiro> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117
16:08:54 <jamoluhrsen> #info carbon SR4  was supposed to go out today, so we need all the CSIT results to be vetted
16:09:37 <anipbu> #link https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=558129117   <--- Carbon SR4 Pending Sign off from sfc, openflowplugin, ocpplugin, nic, l2switch, controller
16:10:35 <jamoluhrsen> #action dfarrell07 to ask TSC to pre-approve carbon SR4 pending CSIT is vetted
16:11:01 <jamoluhrsen> #action dfarrell07 to figure out if we need to maintain carbon for security fixes
16:13:22 <jamoluhrsen> #info LuisGomez saw a problem with openflowplugin in the latest carbon and only happens in autorelease, not the snapshot distributions. *only* in carbon SR4. Suggests that if nobody complains, we ignore it. maybe we can get a low sev bug.
16:13:56 <jamoluhrsen> #action LuisGomez to open a low sev bug for the ofp problem
16:14:42 <dfarrell07> #link https://wiki.opendaylight.org/view/Security:Vulnerability_Management#Security_supported_versions ODL security maintaince docs
16:15:04 <jamoluhrsen> #info jaicaa points out that sfc features has problems installing in carbon sr4 candidate. seems the problem is in genius.
16:15:58 <jamoluhrsen> #action jaicaa to file a blocker on carbon sr4 and double check carbon sr3 to see if it's also there.
16:16:24 <dfarrell07> #info "Backporting is only required for previous releases that are still maintained, according to the release engineering current maintenance strategy." so seems like last SR means no more security support
16:16:26 <jamoluhrsen> #info all standalone users of sfc will be affected, but not when consumers are using sfc integrated with openstack
16:19:02 <jamoluhrsen> #info nitrogen will be locked in three days (4/29) and there is some successful runs in a row of autorelease.
16:19:10 <jamoluhrsen> #info hoping to get nitro out the door next week
16:20:14 <dfarrell07> http://docs.opendaylight.org/en/stable-oxygen/release-process/release-schedule.html
16:21:33 <jamoluhrsen> #link  http://docs.opendaylight.org/en/latest/release-process/release-schedule.html  <-- release schedule
16:22:05 <jamoluhrsen> #info next fluorine date to consider is the date for CSIT to yell about rolling back odlparent and yangtools and we probably don't have a reason to do that.
16:22:40 <jamoluhrsen> #action jamoluhrsen  to go glance at MR projects CSIT for Fluorine to look for anything glaringly wrong
16:23:06 <anipbu> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10400    <--- Fluorine Tracking Dashboard
16:24:15 <jamoluhrsen> #topic distribution
16:24:29 <jamoluhrsen> #info patch is prepared for distro-check for Self Managed projects
16:24:58 <jamoluhrsen> vorburger: we'll get to it. just want to get the normal stuff out of the way.
16:25:25 <jamoluhrsen> #info LuisGomez has had to remove projects from the self managed distribution that are depending on dlux
16:26:08 <jamoluhrsen> #topic builder
16:26:57 <jamoluhrsen> #info volume issues seem to be resolved and CI has been quite stable since the storage change last week.
16:28:22 <jamoluhrsen> #info we are very appreciative to have Vexxhost and mnaser as our cloud provider.
16:29:19 <jamoluhrsen> #info distro-test job now has it's own jenkins builder so now it has it's own queue with queuesize of 1.
16:29:45 <jamoluhrsen> #info distro-test runs a TON of CSIT children jobs so it was really taxing on the jenkins environment when they were running in parallel.
16:30:34 <jamoluhrsen> #info robot slaves are now bumped up to 30 from 25 so we have more bandwidth.
16:30:55 <jamoluhrsen> #topic misc
16:31:57 <jamoluhrsen> #info jaicaa reports that the sfc problem is also there in SR3, so it's not a regression. maybe it's been there all along?
16:35:14 <jamoluhrsen> #info we are wondering how we can get a job that will give us confidence that many different projects' patches can be passed in such that we can gain confidence that they will all work together and not break autorelease
16:36:30 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: Bgp app peer xml change  https://git.opendaylight.org/gerrit/71424
16:41:34 <odp-gerritbot> Tomas Markovic proposed a change to integration/test: Adjust prefix counts  https://git.opendaylight.org/gerrit/70372
16:46:00 <jamoluhrsen> #info it seems like we really just need a new job that is based off of autorelease. so, for each project with a patch, download that repo, apply the patch, then run autorelease on that. Maybe run first with -Pq and if that passes, run it again.
16:50:29 <jamoluhrsen> #info as far as it goes with the upcoming weather items, the plan is to use multipatch job to manually verify the project patches for each weather item. We can run it once and then point out where the first failures are and then ask for the patches from other projects
16:52:00 <jamoluhrsen> #info ideally, when all the new jobs and fanciness is done we just have a single topic branch for projects to use and a fully automated autorelease-based job that will run in the background giving status.
16:56:09 <jamoluhrsen> #info jaicaa reports that the sfc issue is actually not there in carbon sr2, so it's a regression between sr2 and sr3.
16:56:42 <jaicaa> #info bug registered for SFC issue: GENIUS-127
16:57:06 <jamoluhrsen> thanks for the quick work jaicaa
16:57:22 <jamoluhrsen> #endmeeting