17:03:59 <jamoluhrsen> #startmeeting integration
17:03:59 <odl_meetbot> Meeting started Thu May 31 17:03:59 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:59 <odl_meetbot> The meeting name has been set to 'integration'
17:04:39 <jamoluhrsen> #topic builder
17:05:32 <jamoluhrsen> #action jamoluhrsen to make sure to close the bat signal jira
17:06:05 <jamoluhrsen> #topic packaging
17:07:02 <jamoluhrsen> #link https://github.com/shague/odltools <-- odltools repo on github (soon to be ODL project)
17:08:06 <jamoluhrsen> #info not sure if odltools wants .rpm kind of packaging or pypi
17:08:36 <jamoluhrsen> #info puppet opendaylight logging changing happening
17:09:50 <jamoluhrsen> #info original idea was to bump the ODL logs to 10G in size with a rollover of 2
17:11:59 <jamoluhrsen> #info zxiiro has seen some defaults in the 250-500MB range.
17:13:08 <jamoluhrsen> #info hoping some work soon around building .rpm distros on gerrit patches, which can then be shipped off to 3rd party CI (e.g. opnfv)
17:15:55 <jamoluhrsen> #topic distribution
17:16:14 <jamoluhrsen> #info odlparent pushing version bump patches because of a security issue in guava
17:18:04 <jamoluhrsen> #info odlparent 3.1.2 will be merged by releng so should be invisible to projects. 3.1.2 will be run on multipatch to check that it doesn't break other projects
17:18:33 <jamoluhrsen> #info we *may* have to bump to 3.2 in odlparent for the guava fix, but maybe not. likely 4.0 in neon
17:18:53 <jamoluhrsen> #topic release
17:19:17 <jamoluhrsen> #info we want to disable SFT in oxy and fluorine except for int/dist
17:20:04 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2018-May/012033.html <-- email for disabling SFT
17:24:09 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/72168 <-- vorburger's initial (probably not complete) attempt to disable SFT in autorel.
17:26:07 <jamoluhrsen> #info vorburger's patch is not skipping ALL of SFT, just the sft.diag.
17:26:29 <skitt> #info the patch needs -Dskip.karaf.featureTest=true
17:30:09 <jamoluhrsen> #info not quite sure how to keep SFT running just for int/dist yet. one idea is to add an additional builder step to re-run the build on just int/dist without that SFT skip set to true
17:32:34 <jamoluhrsen> #action LuisGomez to reply via email how we can add the extra tests in int/dist so that when it's built with SFT disabled, we will still get the expected coverage
17:33:43 <jamoluhrsen> #action jamoluhrsen to update vorburger's patch to fully disable SFT
17:37:10 <jamoluhrsen> #info skitt notes that we had a recent breakage in other projects from an mdsal patch, and maybe our multipatch job (fast version) can be added as a verify job to all projects.
17:43:51 <jamoluhrsen> #topic misc
17:44:23 <jamoluhrsen> #info anipbu wonders if self-managed projects can give a .zip for their release delivery
17:45:49 <jamoluhrsen> #info anipbu is worried that it is too complicated for self-managed projects to be included in the final distribution release, but LuisGomez is wondering what is missing that makes it so hard.
17:46:20 <zxiiro> #link project standalone release process http://docs.opendaylight.org/en/stable-oxygen/release-process/project-release.html
17:47:42 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/odlparent/odlparent.yaml
17:58:01 <jamoluhrsen> #link http://docs.opendaylight.org/en/latest/release-process/managed-release.html#added-to-final-distribution-pom <-- our deadline for selfmanaged projects to get in to the final distribution
17:58:52 <anipbu> https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=978062368
18:00:00 <anipbu> https://jira.opendaylight.org/issues/?filter=10303
18:01:07 <jamoluhrsen> #info interesting to learn that we *only* have 3 self-managed projects that are in the fluorine tracking sheet (https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=978062368), but that is only based on jiras here (https://jira.opendaylight.org/browse/TSC-91?filter=10303), however we don't require selfmanaged projects to have given those jiras
18:02:41 <jamoluhrsen> #info we will need to revisit this self-managed release process after we do Fluorine and understand the reality of things
18:09:24 <jamoluhrsen> #endmeeting