17:08:13 <jamoluhrsen> #startmeeting integration
17:08:13 <odl_meetbot> Meeting started Thu Sep 20 17:08:13 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:08:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:13 <odl_meetbot> The meeting name has been set to 'integration'
17:11:47 <jamoluhrsen> #topic distribution
17:12:09 <jamoluhrsen> #info release plan has been updated for distribution
17:12:36 <jamoluhrsen> #info neon distribution will give better verification for project versioning, and maybe automatically update versions
17:16:09 <jamoluhrsen> #info seems there is really no work with how we keep or remove managed projects from distribution
17:17:12 <jamoluhrsen> #info multipatch is not working for us in Neon for MRI projects because of how some projects are consuming mdsal.
17:18:35 <jamoluhrsen> #topic builder
17:18:37 <zxiiro> #info Sphinx 1.8.0 breaks docs builds, blacklist it from requirements files if you have one. `Sphinx!=1.8.0`
17:19:29 <zxiiro> #info If you want to use lftools or openstack in a job, call lf-infra-pre-build as the first item in the job builders and make sure your shell scripts start with `#!/bin/bash -l`
17:21:20 <zxiiro> #info If you want to upgrade pip and setuptools this is now handled by lf-infra-pre-build. Make sure your scripts start with `#!/bin/bash -l` and call `python -m pip install`
17:24:53 <jamoluhrsen> #info we are still waiting for the source code for the dcgw packages so we can host those rpms in nexus, but we are waiting for phillipe to finish.
17:25:33 <jamoluhrsen> #info in order to get things moving, we can tarball the packages to keep on nexus. Then we can pull those tarballs and build each time on the systems under test
17:35:38 <jamoluhrsen> #info there is going to be some job that will pull these tar balls, build the rpms and host them in nexus. then our csit jobs will just rpm install in the csit jobs
17:35:56 <jamoluhrsen> #tocpic docs
17:36:04 <zxiiro> #topic docs
17:36:13 <zxiiro> I'm not chair
17:36:15 <zxiiro> jamoluhrsen: ^ typo
17:36:24 <jamoluhrsen> me neither I guess
17:36:32 <jamoluhrsen> #info topic docs
17:36:41 <zxiiro> jamoluhrsen: no you can change topic you just had a typo
17:36:53 <jamoluhrsen> #topic docs
17:36:55 <jamoluhrsen> :)
17:37:09 <jamoluhrsen> #info anipbu asking Prateek to focus on project proposal migration.
17:37:26 <jamoluhrsen> #info anipbu has a bunch of docs patches he wants abandoned, but does not have permission
17:39:35 <anipbu> https://git.opendaylight.org/gerrit/#/c/73202/
17:39:55 <jamoluhrsen> #action jamoluhrsen to take a look at this again: https://git.opendaylight.org/gerrit/#/c/73202/
17:41:12 <jamoluhrsen> #info we still have projects that are dead and we need to delete their docs
17:45:03 <jamoluhrsen> #topic demos
17:45:53 <zxiiro> #link JJB Config https://docs.releng.linuxfoundation.org/en/latest/jenkins-sandbox.html#push-jobs-via-jjb-cli
17:50:06 <zxiiro> #link Reno notes example https://docs.releng.linuxfoundation.org/projects/lftools/en/latest/release-notes.html
17:57:33 <zxiiro> #link Reno docs https://docs.openstack.org/reno/latest/
17:59:30 <odp-gerritbot> Luis Gomez proposed a change to integration/test: Separate test data vs dashboard script  https://git.opendaylight.org/gerrit/76287
18:00:19 <jamoluhrsen> thanks for the demos zxiiro
18:03:35 <jamoluhrsen> #action jamoluhrsen to setup a doodle to find a better time for this meeting.
18:03:54 <jamoluhrsen> #endmeeting