#opendaylight-integration: integration

Meeting started by dfarrell07 at 21:00:29 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 21:02:03)
    1. wrapping up loose ends with some broken ansible jobs. more test coverage coming in for those (jamoluhrsen, 21:02:25)
    2. global-jjb patch came in to fix a packaging job, but we need a new release there to help. (jamoluhrsen, 21:02:55)
    3. global-jjb releases every two weeks. (actually all releng releases) (jamoluhrsen, 21:03:22)
    4. lf-releng mailing list https://lists.linuxfoundation.org/mailman/listinfo/lf-releng (zxiiro, 21:04:43)
    5. puppet jobs not yet done for Neon, but patch is broken. needs more work (jamoluhrsen, 21:05:46)

  2. docs (jamoluhrsen, 21:06:19)
    1. intersphinx linking docs https://docs.releng.linuxfoundation.org/en/latest/project-documentation.html?highlight=intersphinx#intersphinx-linking (zxiiro, 21:06:44)
    2. dfarrell07 trying to find a way to document which projects are in the managed release (jamoluhrsen, 21:07:03)
    3. there is a cross community docs meeting (3rd wed of every month) (jamoluhrsen, 21:07:42)
    4. cross project mailing list https://lists.linuxfoundation.org/mailman/listinfo/lf-docs (zxiiro, 21:08:00)
    5. cross project docs meeting https://lists.linuxfoundation.org/pipermail/lf-docs/2018-April/000011.html (zxiiro, 21:08:25)
    6. still looking good to getting a docs person to share with ONAP. hopefully we'll get approval (jamoluhrsen, 21:09:33)
    7. https://git.opendaylight.org/gerrit/#/c/76359/ (anipbu, 21:09:50)
    8. https://git.opendaylight.org/gerrit/#/c/76357/ (anipbu, 21:09:53)
    9. https://git.opendaylight.org/gerrit/#/c/76286/ (anipbu, 21:09:57)
    10. https://www.irccloud.com/pastebin/DbCuMx5G/ (jamoluhrsen, 21:10:26)
    11. hoping to close the project proposals main page this month (jamoluhrsen, 21:11:19)
    12. sodium release is not until 2019, but we should start thinking about that and the dates (jamoluhrsen, 21:12:28)
    13. Add Na docs here https://docs.opendaylight.org/en/latest/release-process/release-schedule.html (dfarrell07, 21:12:58)
    14. ACTION: jamoluhrsen to make a column for Sodium (and more?) in the release schedule RTD page (jamoluhrsen, 21:14:40)
    15. ACTION: or dfarrell07 can make the sodium column (jamoluhrsen, 21:15:05)
    16. several docs patches looking for abandonment (jamoluhrsen, 21:15:42)
    17. ACTION: anipbu to email list of possible patches to abandon in the docs project (jamoluhrsen, 21:16:02)

  3. distribution (jamoluhrsen, 21:16:21)
  4. builder (jamoluhrsen, 21:27:19)
    1. clm jobs are getting migrated to the shared nexus server. but needed new global-jjb code to make this happen. work will happen next week. (jamoluhrsen, 21:28:20)
    2. heat scripts being rewritten to make the more generic to be used in other projects. Need to transition odl heat "code" over. (jamoluhrsen, 21:29:28)
    3. https://gerrit.linuxfoundation.org/infra/#/c/12958/ (dfarrell07, 21:30:29)
    4. we need to migrate away from using lftools-install (jamoluhrsen, 21:31:13)
    5. new macro in jjb to get the lftools loaded in to the build vm (jamoluhrsen, 21:32:00)
    6. new macro for lftools magic is called "lf-infra-pre-build" (jamoluhrsen, 21:33:30)
    7. all jenkins view related code will now use view templates coming from global-jjb (jamoluhrsen, 21:36:19)

  5. misc (jamoluhrsen, 21:36:48)
    1. https://docs.opendaylight.org/en/latest/release-process/branch-cutting.html#manual-steps-to-version-bump-autorelease (anipbu, 21:37:40)
    2. in order for self managed projects to release on their own is 3 parts (jamoluhrsen, 21:37:47)
    3. https://docs.opendaylight.org/en/stable-fluorine/release-process/project-release.html (anipbu, 21:37:48)
    4. 1: https://docs.opendaylight.org/en/latest/release-process/branch-cutting.html#manual-steps-to-version-bump-autorelease (jamoluhrsen, 21:37:55)
    5. 2: https://docs.opendaylight.org/en/stable-fluorine/release-process/project-release.html (jamoluhrsen, 21:38:02)
    6. 3: produce rpms or debs, but we don't have an easy way to do that (at the moment) (jamoluhrsen, 21:38:36)
    7. dfarrell07 points out that it could be hard to get .rpm and .deb by themselves, but they can still release their own .zip (jamoluhrsen, 21:39:03)
    8. https://docs.opendaylight.org/en/latest/release-process/managed-release.html (anipbu, 21:39:39)
    9. we will need to update our release plan/process docs (https://docs.opendaylight.org/en/latest/release-process/managed-release.html) to help these self managed projects know all the steps. (jamoluhrsen, 21:40:47)
    10. each project can host their .zip on the downloads page and work with LF marketing to "advertise" their release (jamoluhrsen, 21:41:08)
    11. some new ideas around our checkpoints/dates in the release. a) we can fold the code freeze and final checkpoint in to one final "code freeze checkpoint". b) version bump checkpoint can be changed to MSI checkpoint (name change). (jamoluhrsen, 21:45:47)
    12. also to reduce the number of "deadlines" we don't really need the release integrated deadline and another checkpoint one day later with the version bump date. (jamoluhrsen, 21:46:58)
    13. collapse release start and initial checkpoint in to the same thing (jamoluhrsen, 21:47:39)


Meeting ended at 21:53:10 UTC (full logs).

Action items

  1. jamoluhrsen to make a column for Sodium (and more?) in the release schedule RTD page
  2. or dfarrell07 can make the sodium column
  3. anipbu to email list of possible patches to abandon in the docs project


Action items, by person

  1. anipbu
    1. anipbu to email list of possible patches to abandon in the docs project
  2. dfarrell07
    1. or dfarrell07 can make the sodium column
  3. jamoluhrsen
    1. jamoluhrsen to make a column for Sodium (and more?) in the release schedule RTD page


People present (lines said)

  1. jamoluhrsen (38)
  2. anipbu (6)
  3. odl_meetbot (5)
  4. dfarrell07 (4)
  5. zxiiro (4)
  6. abelur (0)


Generated by MeetBot 0.1.4.