17:07:20 <jamoluhrsen> #startmeeting new release model
17:07:20 <odl_meetbot> Meeting started Fri Feb  2 17:07:20 2018 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:07:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:20 <odl_meetbot> The meeting name has been set to 'new_release_model'
17:07:50 <jamoluhrsen> shague: klou anipbu notes here if you want to put any
17:09:30 <jamoluhrsen> #info new participation requirement idea that projects must attend some (maybe new) meeting 50% of the time in the last X (maybe 8) weeks of the release
17:10:10 <jamoluhrsen> #info meeting attendance requirement is to address the problem where projects completely disappear for an entire release
17:10:24 <jamoluhrsen> #info attendance is by a committer (or a proxy)
17:11:25 <jamoluhrsen> vishnoianil: we can hear you
17:11:55 <jamoluhrsen> #info probably it's better to require a committer (no proxy allowed)
17:12:43 <jamoluhrsen> #info the problem is still there that a project can still ignore this participation requirement
17:13:44 <jamoluhrsen> #info committer assignment can be a solution to projects ignoring the participation requirement.
17:14:20 <jamoluhrsen> #info suggestion is that TSC can (with a majority vote) assign a committer to a project that it deems not fulfilling the requiremts
17:17:02 <jamoluhrsen> #info if a dependent project were to decide that it did not want to follow these rules/requirements, the suggestion would be that we could fork said project and assign new committers
17:18:50 <jamoluhrsen> zxiiro: notes over here too
17:19:58 <jamoluhrsen> #info this idea to fork projects would only apply to projects that decide they don't want to be in the SR/Core projects
17:24:16 <zxiiro> right. from a technical perspective we essentially need to do a version bump if that happens (to update all pom files and java files to use the forked code).
17:25:19 <klou> it sounds like we should not do forking
17:32:21 <jamoluhrsen> klou: the problem, I think, is if some project rejects this new model and says they wont be part of it and fulfill the requirements
17:32:59 <jamoluhrsen> #action anipbu vishnoianil to add new slides with this proposal of tsc assignment of committers and how to trigger a tsc review process
18:02:35 <jamoluhrsen> #action jamoluhrsen to start email thread to nail down requirements
18:02:40 <jamoluhrsen> #endmeeting