03:02:12 <jamoluhrsen> #startmeeting integration
03:02:12 <odl_meetbot> Meeting started Thu May  2 03:02:12 2019 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:02:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:12 <odl_meetbot> The meeting name has been set to 'integration'
03:02:13 <abelur> LuisGomez: int/test meeting
03:03:06 <abelur> jamoluhrsen: welcome back! \o/
03:04:10 <jamoluhrsen> #info jamoluhrsen is back and able contribute more actively to opendaylight :)
03:05:41 <jamoluhrsen> #topic builder
03:06:33 <jamoluhrsen> #info migrating all images to ansible provisioners, and all mininet  and devstack images should be converted
03:07:01 <jamoluhrsen> #info we need some testing with our CSIT jobs for the netvirt images before we can use them in production
03:08:32 <abelur> #link https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013204.html
03:09:09 <jamoluhrsen> #info surefire reports are not being collected. abelur is looking in to those. possibly an update to lftools broke this.
03:09:41 <abelur> #link https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013209.html
03:10:36 <abelur> zxiiro: are you familar with the deploy-archive change?
03:10:54 <jamoluhrsen> #topic packaging
03:11:29 <jamoluhrsen> #info abelur is looking at some packaging issues, but dfarrell07 is still helping out when he can
03:12:03 <jamoluhrsen> #info abelur is pushing new releases to CBS repos
03:13:02 <jamoluhrsen> #info puppet and ansible repos are in packaging and wondering if we have any downstream users and if we can deprecate and remove the jobs if nobody is using it.
03:13:35 <jamoluhrsen> #topic distribution
03:14:00 <jamoluhrsen> #info distribution is good. no problems lateluy
03:15:00 <jamoluhrsen> #info the process for bringing in self-managed projects to the self-managed release has become smooth now. thanks Luis
03:15:20 <jamoluhrsen> #topic release
03:16:44 <jamoluhrsen> #info neon SR1 hoping to be released soon. we have a blue autorelease https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-neon-mvn35-openjdk8/108/ that we can potentially use for this
03:18:59 <jamoluhrsen> #link https://jira.opendaylight.org/browse/OPNFLWPLUG-1065 <-- blocker bug without a version
03:20:19 <jamoluhrsen> #action jamoluhrsen to ask on TSC call tomorrow if we can lock Neon and look to work on SR1 release
03:21:56 <jamoluhrsen> #info fluorine SR3 is planned to release soon, but we may try to push it back. discussion on TSC call tomorrow.
03:22:33 <jamoluhrsen> #topic docs
03:23:41 <jamoluhrsen> #info PTL coming from Lumina soon hopefully
03:23:58 <jamoluhrsen> #info LF may be hiring someone (maybe part time) to help with docs.
03:24:12 <jamoluhrsen> #info we have an intern interest on the mailing list that might help
03:25:15 <jamoluhrsen> #info otherwise docs is just in maintenance mode and only real activity is waiting on neon release notes
03:25:44 <jamoluhrsen> #topic test
03:25:57 <jamoluhrsen> https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon-mvn35-openjdk8/108/dependencies.log.gz
03:27:01 <LuisGomez> https://wiki.opendaylight.org/view/Project_list
03:29:08 <LuisGomez> https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-neon/240/
03:30:51 <jamoluhrsen> #info jaya can be an owner for netvirt csit, karthika can own genius
03:31:19 <jamoluhrsen> #info jamo can own aaa, netconf, ovsdb
03:31:36 <jamoluhrsen> #info LuisGomez can take bgpcep (if not venkat), openflow
03:32:35 <jamoluhrsen> #info karthika can try to keep an eye on COE or find someone else
03:33:05 <jamoluhrsen> #info LuisGomez and jamoluhrsen can handle the controller project
03:33:20 <jamoluhrsen> #info LuisGomez can watch distribution
03:33:48 <jamoluhrsen> #info we don't have anyone that can watch/own lisp, but it is stable.
03:36:06 <jamoluhrsen> #info jaya can passively watch odltools csit
03:36:41 <jamoluhrsen> #info need to know if sfc still matters to anyone
03:37:58 <jamoluhrsen> #info LuisGomez can see about getting yangtools to pass. it's failing for the same well known bug for a long time
03:38:48 <jamoluhrsen> #info zxiiro suggests we put these owners on a wiki
03:39:05 <jamoluhrsen> #action jamoluhrsen to convert these ownerships to a wiki page
03:40:10 <jamoluhrsen> #info jaya having trouble with the rocky upgrade.
03:40:33 <jamoluhrsen> #info abelur has a new devstack image made for rocky that she can test
03:40:42 <abelur> #info https://lists.opendaylight.org/pipermail/integration-dev/2019-May/013204.html
03:40:49 <jamoluhrsen> #link https://jenkins.opendaylight.org/sandbox/job/Jaya-netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-rocky-upstream-stateful-sodium/4/ <-- failing rocky job
03:43:08 <jamoluhrsen> #info looks like the robot vm does not have the openstack cli in this failing rocky job
03:43:12 <jamoluhrsen> #info 00:39:42 which: no openstack in (/tmp/v/robot/bin:/usr/local/bin:/usr/bin:/opt/puppetlabs/bin)
03:44:25 <abelur> #info ZZCI - CentOS 7 - robot - 20190430-080312.962
03:45:25 <LuisGomez> fyi i have to disconnect & reconnect 1 moment
03:47:53 <jamoluhrsen> netvirt-csit-1node-0cmb-1ctl-2cmp-openstack-rocky-upstream-stateful-sodium
03:48:38 <abelur> jjb/integration/integration-deploy-openstack-run-test.sh
03:54:26 <jamoluhrsen> dogpile.cache~=0.6.8  # Version 0.7.[01] seems to break openstackclient
03:56:08 <abelur> https://www.irccloud.com/pastebin/bR1BkyAo/
03:57:31 <zxiiro> #link https://git.opendaylight.org/gerrit/#/c/81522/
04:01:33 <jamoluhrsen> #endmeeting