03:02:08 <jamoluhrsen> #startmeeting integration
03:02:08 <odl_meetbot> Meeting started Thu May 23 03:02:08 2019 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:02:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:08 <odl_meetbot> The meeting name has been set to 'integration'
03:02:32 <jamoluhrsen> #topic release
03:03:35 <jamoluhrsen> #info fluorine autorelease was passing for 5 builds in a row since it's trouble last week, but we just saw two of the last three fail:
03:03:35 <jamoluhrsen> https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-fluorine-mvn35-openjdk8/
03:06:10 <jamoluhrsen> #info we are considering locking fluorine now and only allowing blocking bugs to merge patches
03:06:17 <LuisGomez> #link https://jira.opendaylight.org/browse/BGPCEP-873
03:06:17 <abelur> #info lock stable/fluorine branch for upcoming Fluorine SR3 release on 31/May
03:06:31 <LuisGomez> this is blocker bug for fluorine
03:07:18 <jamoluhrsen> #info fluorine SR3 has two blocker bugs. CONTROLLER-1879 and BGPCEP-873
03:08:23 <jamoluhrsen> #info the bgpcep bug is a regression and we know the patch that reintroduced it.
03:08:46 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/81929/ <-- bgpcep regression
03:09:18 <jamoluhrsen> #action LuisGomez to make a revert patch in fluorine
03:10:49 <jamoluhrsen> #action abelur will lock fluorine soon
03:12:14 <LuisGomez> https://git.opendaylight.org/gerrit/#/c/82178/
03:12:21 <LuisGomez> if someone can merge this
03:12:22 <jamoluhrsen> #info LuisGomez still needs a patch merged in order release neon SR1 for SM projects
03:14:50 <jamoluhrsen> #topic infra
03:15:05 <jamoluhrsen> #info no news on builder/infra side this week.
03:16:48 <jamoluhrsen> #info actually we do have a problem with stale stacks consuming ip addresses (in delete failed state) and we were unable to hand out new ip addresses
03:17:08 <LuisGomez> fyi, revert patch for BGPCEP-873: https://git.opendaylight.org/gerrit/#/c/82210
03:17:49 <faseelak> #info faseelak
03:18:40 <jamoluhrsen> #action abelur to update the integration list when the stale stacks are deleted and we can double check if we have the same problems with missing ips
03:23:13 <jamoluhrsen> #info our cleanup openstack job is failing and probably the root cause for our other failures, like failure to get ips
03:23:25 <abelur> jamoluhrsen: please link the console logs for netvirt job which shows the ip address conflict here
03:24:18 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-callhome-only-sodium/148/console <--- example job failing to get ips
03:24:31 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/builder/job/builder-openstack-cron/18686/console failing openstack cleanup job
03:24:54 <jamoluhrsen> #topic packaging
03:25:07 <jamoluhrsen> #info waiting on neon sr1 for SM before we can do the packaging work.
03:25:21 <jamoluhrsen> #topic test
03:28:25 <jamoluhrsen> #info just for historical record, Jaya is also noticing how painful it is to debug hard problems in infra without live access.
03:29:38 <jamoluhrsen> #topic docs
03:30:37 <jamoluhrsen> #info david is looking for direction on the docs side and plans to meet with LuisGomez and/or danieldelarosa
03:31:05 <jamoluhrsen> #info we should have a docs intern joining sooner or later.
03:32:52 <jamoluhrsen> #topic misc
03:33:34 <jamoluhrsen> #endmeeting