03:02:17 <jamoluhrsen> #startmeeting integration
03:02:17 <odl_meetbot> Meeting started Thu Jun  6 03:02:17 2019 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
03:02:17 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:17 <odl_meetbot> The meeting name has been set to 'integration'
03:02:29 <jamoluhrsen> #topic release
03:02:58 <jamoluhrsen> #info Fluorine SR3 still has some details to figure out like a perf regression in controller cluster job
03:03:57 <jamoluhrsen> #info the regression happened after the most recent kernel project updates
03:04:32 <jamoluhrsen> #info we need to wait for the discussion on the TSC
03:04:58 <jamoluhrsen> #info seems the regression is only on Fluorine, and not the other branches
03:07:51 <jamoluhrsen> #info seems this regression is the last thing to resolve for SR3
03:08:10 <jamoluhrsen> #topic infra
03:08:28 <jamoluhrsen> #info no major updates on infra
03:09:07 <jamoluhrsen> #info lftools fix coming to compress all logs, but still allow browsers to see those files without having to manually uncompress
03:09:20 <abelur> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/lf-infra-lftools-tox-verify-any/818/console.log.gz
03:09:58 <jamoluhrsen> unable to find release notes file associated with unique id u'766a7b05b4c31dbc', skipping
03:12:26 <jamoluhrsen> #info the stale ports were all cleaned out on infra so we should not see the problems with jobs failing because instances can't get IP addresses
03:13:04 <abelur> #link https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/builder-openstack-cron/19025/console.log.gz
03:14:26 <abelur> #info "ZZCI - Ubuntu 16.04 - mininet-ovs-26 - 20190507-011844.608"
03:14:27 <jamoluhrsen> #action abelur to investigate the openstack-cron job failure. that job is what helps clean up stale entites which can build up over time and cause job failures
03:15:00 <abelur> https://www.irccloud.com/pastebin/ByiO6YEw/
03:15:21 <abelur> #info openstack cron job deletes by name and not UUID.
03:18:54 <abelur> there is not image with the name its looking for
03:18:59 <abelur> https://www.irccloud.com/pastebin/xtZRpCA5/
03:22:34 <jamoluhrsen> like, run "openstack image show ZZCI - Ubuntu 16.04 - mininet-ovs-26 - 20190507-011844.608"
03:22:38 <jamoluhrsen> is that image there?
03:22:45 <jamoluhrsen> if it is, do a delete and see what error
03:22:59 <abelur> Could not find resource ZZCI - Ubuntu 16.04 - mininet-ovs-26 - 20190507-011844.608
03:23:05 <jamoluhrsen> ERROR: Unexpected exception: Error in deleting image. (409) Client Error for url: https://image-ca-ymq-1.vexxhost.net/v2/images/69eda83b-c571-460b-9942-10a210fefe12 Conflict
03:24:00 <jamoluhrsen> #topic docs
03:24:18 <jamoluhrsen> #info no news for docs yet.
03:24:29 <jamoluhrsen> #topic test
03:26:16 <abelur> I tried deleting the image with the uuid ....
03:26:19 <abelur> https://www.irccloud.com/pastebin/P1JwtMXK/
03:26:24 <jamoluhrsen> #info bgpcep is not active so there is nobody looking at the tests or fixing bugs so we can't expect a performance regression to be fixed
03:29:07 <jamoluhrsen> #action jamoluhrsen to look in to why jobs  are not getting auto updated in to the csit list that runs every autorelease or at least nightly
03:30:23 <jamoluhrsen> #info we need to upgrade robot, but we need a plan because it's not backwards compatible
03:33:32 <jamoluhrsen> #action LuisGomez to send a community wide email that explains the robot framework upgrades that need to happen
03:34:30 <jamoluhrsen> #info the problem is that upstream ODL will upgrade to RF 3.2 and modify test code to work with it. If downstream consumers of our robot code do not upgrade their test infra will be broken
03:36:49 <jamoluhrsen> #info zxiiro has a trick with pre-commit that will correct all of the files to be we need.
03:39:18 <jamoluhrsen> #info karthika is having trouble with the comparestream library. jamoluhrsen will review
03:39:41 <jamoluhrsen> #topic misc
03:42:36 <jamoluhrsen> https://jenkins.opendaylight.org/releng/job/builder-openstack-cron/19026/console
03:42:59 <jamoluhrsen> lftools openstack --os-cloud vex image cleanup --days=30
03:46:00 <jamoluhrsen> #endmeeting