04:02:29 <jamoluhrsen> #startmeeting integration
04:02:29 <odl_meetbot> Meeting started Thu Sep 12 04:02:29 2019 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
04:02:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:02:29 <odl_meetbot> The meeting name has been set to 'integration'
04:02:58 <rsrini_> #info rsrini
04:03:16 <jamoluhrsen> #topic release
04:04:02 <jamoluhrsen> #info LuisGomez had trouble with self release jobs, but abelur fixed a bug that should allow us to release.
04:06:55 <abelur> #info dist requires to be tagged, dist manage and dist self-managed
04:07:01 <abelur> #link https://github.com/lfit/releng-global-jjb/blob/master/shell/release-job.sh
04:10:06 <jamoluhrsen> #info abelur will release Neon SR2 manually.
04:11:30 <jamoluhrsen> #info Sodium still stuck on https://jira.opendaylight.org/browse/OPNFLWPLUG-1074
04:12:15 <abelur> LuisGomez: can you provide a stage job number to promte manually?
04:14:27 <LuisGomez> #link https://jenkins.opendaylight.org/releng/job/distribution-release-merge/2/parameters/
04:14:48 <jamoluhrsen> #info jamoluhrsen marked the openflow 1074 bug as highest priority and assigned to Somashekhar Javalagi who was giving feedback on the jjira issue
04:17:00 <zxiiro> abelur: shouldn't dry_run tag too? what's the point of a dry_run if it doesn't actually execute the steps?  The only step a dry run should skip imo is any "git push" steps.
04:18:09 <jamoluhrsen> #action jamoluhrsen to remove sodium jdk11 jobs
04:18:49 <jamoluhrsen> #info once sodium is released, fluorine jobs can be removed and finally jenkins can get back to a normal usage
04:19:34 <LuisGomez> #link https://jenkins.opendaylight.org/releng/job/distribution-release-merge/3/console
04:20:35 <jamoluhrsen> #action abelur to open helpdesk ticket about self release job problems
04:21:10 <LuisGomez> VERSION="${VERSION:-None}"
04:21:10 <LuisGomez> if [[ $VERSION == "None" ]]; then
04:21:11 <LuisGomez> VERSION="$(niet ".version" "$release_file")"
04:21:12 <LuisGomez> fi
04:21:18 <abelur> zxiiro: dry should not be pushing the tags to gerrit.
04:21:42 <abelur> https://www.irccloud.com/pastebin/zjejeAX9/
04:21:57 <odp-gerritbot> Jaya Priyadarshini proposed a change to integration/test: Test Patch , not for review  https://git.opendaylight.org/gerrit/c/integration/test/+/58486
04:22:04 <zxiiro> abelur: yes, but the command "git tag" only creates local tags. tags are not acgtually pushed to gerrit until you do "git push origin <tag>"
04:22:21 <zxiiro> abelur: so IMO we should run the "git tag" command in dry_run mode so that we can confirm that tagging works locally
04:22:49 * abelur nods in agreement
04:26:15 <abelur> zxiiro: LuisGomez: I noticed that release job has gone ahead and promoted the repo, although the job failed :-((
04:26:27 <LuisGomez> :)
04:26:33 <LuisGomez> job done
04:26:58 <jamoluhrsen> #topic builder/infra
04:27:45 <jamoluhrsen> #info working ongoing with nexus central to get smart proxy setup and it's enabled and resync has been triggered for our release repository.
04:28:44 <jamoluhrsen> #info abelur working on auto-update new packer images and done in global-jjb instead of in our integration/builder
04:29:27 <abelur> jamoluhrsen: its already on releng/builder, I am porting this with some improvements to global-jjb :-))
04:30:56 <jamoluhrsen> #topic misc
04:34:32 <jamoluhrsen> #endmeeting