#opendaylight-intern: better host tracker interns
Meeting started by colindixon at 19:59:29 UTC
(full logs).
Meeting summary
- 
  - talking about ingesting the address tracker
    model from l2switch to refer to from our host model (which should
    maybe be an endpoint model) (colindixon,
    20:03:22)
- evanz has been working on the model and is
    going to paste it into the google doc (colindixon,
    20:03:50)
- https://docs.google.com/a/colindixon.com/document/d/1_zyfXRYBxP5QERuEgfi1R8F7Sqj3safL8OUs-MUBxCw/edit
    (colindixon,
    20:04:02)
- https://github.com/nilok/betterhosttracker
    (colindixon,
    20:07:04)
- https://github.com/nilok/betterhosttracker
    setting up a github repo for us to collaborate in because getting
    patches merged in ODL is a pain and probably not the right thing to
    do (colindixon,
    20:10:40)
 
 
- next steps (colindixon, 20:10:48)
  - two sets of tasks that can be (reasonably
    parallelized): (colindixon,
    20:11:55)
- 1.) write code that subscribes to tracked
    addresses from the address tracker and processes them (colindixon,
    20:12:28)
- https://git.opendaylight.org/gerrit/#/c/8095/3/addresstracker/model/src/main/yang/address-tracker.yang
    (evanz,
    20:13:01)
- https://git.opendaylight.org/gerrit/#/c/8095/3/addresstracker/model/src/main/yang/address-tracker.yang
    the address tracker model/module (colindixon,
    20:13:05)
- https://git.opendaylight.org/gerrit/gitweb?p=l2switch.git;a=tree;f=addresstracker/implementation;h=bb1fcc8e5bcf3bd7e3c5999f0b38f0e46a09d48d;hb=HEAD
    (colindixon,
    20:16:50)
- 2.) model hosts in a way that we can take the
    output of processing the addresses as hosts that others can consume
    via the MD-SAL (colindixon,
    20:21:10)
- ACTION: evanz to try
    to get the code generation pom file stuff around the current host
    model (colindixon,
    20:23:17)
- I think the l2switch code in the controller
    (not the l2switch project) has an example of how to subscribe to
    find out nodes that have a certain augmentation (colindixon,
    20:23:55)
- ACTION: djx to try to
    get it so he can read addresses from the address tracker
    model (colindixon,
    20:24:18)
- if you start by looking at
    org.opendaylight.controller.sample.l2switch.md.util.createTablePath()
    that will show you how to query the MD-SAL for nodes with a certain
    augmentation (in that case it’s FlowCapableNode) in our case it will
    be AddressCapableNodeConnector I think (colindixon,
    20:26:20)
 
 
- next meeting (colindixon, 20:26:35)
  - http://www.timeanddate.com/worldclock/meetingtime.html?iso=20140627&p1=24&p2=133&p3=848
    the next meeting will be at the same time on Friday (colindixon,
    20:27:41)
 
Meeting ended at 20:30:29 UTC
(full logs).
Action items
  - evanz to try to get the code generation pom file stuff around the current host model
- djx to try to get it so he can read addresses from the address tracker model
Action items, by person
  -  djx 
    - djx to try to get it so he can read addresses from the address tracker model
 
-  evanz 
    - evanz to try to get the code generation pom file stuff around the current host model
 
People present (lines said)
  - colindixon (64)
- djx (25)
- evanz (18)
- odl_meetbot (3)
Generated by MeetBot 0.1.4.