#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:12:31 UTC (full logs).

Meeting summary

  1. status update (colindixon, 21:09:49)
    1. some impl is up on the github (evanz, 21:09:59)
    2. https://github.com/nilok/betterhosttracker/tree/master/opendaylight/md-sal/betterhosttracker/plugin/src/main/java/org/opendaylight/controller/betterhosttracker/plugin/internal (evanz, 21:10:17)
    3. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin::End_to_End_Inventory (colindixon, 21:21:11)
    4. the DataObject that comes back from the data changed notification should be an AddressCapableNodeConnector (colindixon, 21:35:29)
    5. AddressCapableNodeConnector extends AddressNodeConnector which has a method getAddresses() which returns a List of Addresses (colindixon, 21:35:37)
    6. Addresses have methods for getIp(), getMac(), etc. (colindixon, 21:35:42)
    7. ACTION: djx to work on setting things up to get the data changed notifications and pull out the the Addresses (or AddressCapableNodeConnector) and path to to generate an observation of a NodeConnector, IP and MAC (colindixon, 21:46:57)
    8. ACTION: evanz to work on how to write test cases, either by faking the data with RESTCONF or just writing good unit tests (colindixon, 21:47:18)
    9. internally, we should track a list of our modeled hosts (colindixon, 21:50:24)
    10. and eventually publish them into the data store (colindixon, 21:50:39)
    11. ACTION: djx will change the path of yang model previously created (djx, 21:50:49)


Meeting ended at 21:52:57 UTC (full logs).

Action items

  1. djx to work on setting things up to get the data changed notifications and pull out the the Addresses (or AddressCapableNodeConnector) and path to to generate an observation of a NodeConnector, IP and MAC
  2. evanz to work on how to write test cases, either by faking the data with RESTCONF or just writing good unit tests
  3. djx will change the path of yang model previously created


Action items, by person

  1. djx
    1. djx to work on setting things up to get the data changed notifications and pull out the the Addresses (or AddressCapableNodeConnector) and path to to generate an observation of a NodeConnector, IP and MAC
    2. djx will change the path of yang model previously created
  2. evanz
    1. evanz to work on how to write test cases, either by faking the data with RESTCONF or just writing good unit tests


People present (lines said)

  1. colindixon (112)
  2. djx (59)
  3. evanz (37)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.