20:03:12 <colindixon> #startmeeting better host tracker interns
20:03:12 <odl_meetbot> Meeting started Mon Jul  7 20:03:12 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:03:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:12 <odl_meetbot> The meeting name has been set to 'better_host_tracker_interns'
20:03:18 <colindixon> #topic status update
20:03:21 <colindixon> so, what’s up?
20:03:22 <colindixon> :p
20:03:32 <evanz_> updated the databroker stuff
20:03:34 <evanz_> from the deprecated
20:03:55 <evanz_> everything should import to eclipse
20:04:00 <evanz_> at least I get no errors on my laptop
20:04:17 <colindixon> #info we’ve moved to the new data broker interfaces
20:04:41 <djx> evanz_ I am not, so you shouldn't have a problem with that
20:04:51 <djx> on my side everything works as well
20:05:12 <evanz_> and colindixon: I put in an executor where you mentioned it, but do we need it now that the databroker can do async tx?
20:06:20 <colindixon> …so, yes, you can’t use a DataChangeNotification thread to then do a transaction
20:06:22 <colindixon> you’ll get a deadlock
20:06:24 <colindixon> as I learned
20:06:26 <colindixon> :p
20:07:19 <colindixon> interesting, so my mdhosttracker stuff is broken
20:07:39 <colindixon> so, I’ll just remove it from the root pom file
20:07:42 <evanz_> yeah it can't resolve a bunch of Task types
20:07:48 <colindixon> yeah
20:07:50 <colindixon> that’s my fault
20:08:16 <evanz_> btw if we need to share screen or whatever, I think I've fixed my microphone issues
20:08:35 <evanz_> there is one other person in the lab but I don't think it will bother him
20:09:02 <colindixon> I just pushed the change to the pom file
20:11:00 <colindixon> huh
20:11:04 <colindixon> I get errors...
20:11:13 <colindixon> in Eclipse
20:11:33 <evanz_> I only have errors for mdhosttracker
20:11:45 <evanz_> which btw should we change betterhosttracker to "mdhosttracker"
20:11:46 <colindixon> they’re all @override saying that they must override things
20:11:48 <colindixon> but they appare to be
20:11:48 <evanz_> probably a better name
20:12:39 <colindixon> ok deleting an reimporting fixed it
20:12:50 <colindixon> so, I think mdhosttracker is probably a better name
20:12:59 <evanz_> yeah :)
20:13:08 <colindixon> #action evanz_ or djx to rename betterhosttracker to mdhostracker (at somet point)
20:13:36 <colindixon> #link https://github.com/nilok/betterhosttracker/ the current code just for posterity
20:14:07 <colindixon> #topic next steps
20:14:36 <colindixon> we lost djx
20:14:37 <evanz_> uh oh
20:15:04 <colindixon> the good news is when he gets back the logs are here: https://meetings.opendaylight.org/opendaylight-intern/2014/better_host_tracker_interns/opendaylight-intern-better_host_tracker_interns.2014-07-07-20.03.log.txt
20:15:05 <djx> do you guys said anything afte "colindixon> that’s my fault"?
20:15:20 <colindixon> I never saw that :p
20:15:26 <colindixon> the logs so far are at that link
20:15:43 <djx> cool
20:15:46 <evanz_> basically just said at some point we will rename betterhosttracker to mdhosttracker
20:15:46 <colindixon> so, the next step I think is to actually wire this up so we can test things
20:16:03 <evanz_> yeah we need to cause a data change event
20:16:06 <evanz_> I think?
20:16:13 <colindixon> #info the next steps are basically to wire this up with something that will generate Addresses objects in the MD-SAL to cause our data change events
20:16:15 <colindixon> yes
20:16:32 <colindixon> the l2switch guys claim their addresstracker is working
20:16:55 <djx> ah right
20:17:04 <djx> ok, I was trying to build l2switch but didn't work
20:17:26 <colindixon> #info the l2switch project claims to have the address tracker working, I was just able to build the addresst tracker part at least
20:17:51 <djx> ah I tried to build the whole project
20:17:51 <evanz_> building l2switch right now
20:17:59 <colindixon> and then, as expected I get implementation/target/addresstracker-impl-0.1.0-SNAPSHOT.jar and model/target/addresstracker-model-0.1.0-SNAPSHOT.jar
20:18:03 <colindixon> I just build the address tracker
20:18:05 <colindixon> nothing else
20:18:15 <evanz_> okay
20:18:22 <djx> nop, it fails
20:18:41 <colindixon> djx: huh
20:18:43 <colindixon> error message?
20:18:46 <djx> l2switch/addresstracker/model/src/main/yang-gen-code/org/opendaylight/yang/gen/v1/urn/opendaylight/address/tracker/rev140617/address/node/connector/AddressesKey.java:[9,24] type argument org.opendaylight.yang.gen.v1.urn.opendaylight.address.tracker.rev140617.address.node.connector.Addresses is not within bounds of type-variable T
20:19:04 <colindixon> did you do a git pull?
20:19:13 <djx> yup
20:19:14 <djx> 29a220718daaf6ef03f205bfe6c9d918a787a436
20:19:29 <colindixon> ugh
20:19:31 <colindixon> I hadn’t :p
20:19:36 <colindixon> building now
20:19:44 <colindixon> it still built
20:19:46 <evanz_> Reactor Summary:
20:19:46 <evanz_> [INFO]
20:19:47 <evanz_> [INFO] addresstracker-model .............................. SUCCESS [4.284s]
20:19:47 <evanz_> [INFO] addresstracker-impl ............................... SUCCESS [0.305s]
20:19:47 <evanz_> [INFO] addresstracker.aggregator ......................... SUCCESS [0.106s]
20:20:06 <djx> what version do you have from git log?
20:20:21 <colindixon> spectre-2:addresstracker ckd$ git br
20:20:21 <colindixon> * master
20:20:23 <colindixon> spectre-2:addresstracker ckd$ git log -1 --pretty=oneline
20:20:24 <colindixon> 29a220718daaf6ef03f205bfe6c9d918a787a436 Fix a bug in flooding in sendPacketOut.
20:20:25 <colindixon> spectre-2:addresstracker ckd$ git st
20:20:26 <colindixon> spectre-2:addresstracker ckd$
20:20:42 <colindixon> do you have any unmerged changes
20:20:43 <colindixon> git status
20:20:53 <djx> Your branch is up-to-date with 'origin/master'
20:20:58 <djx> nothing to commit, working directory clean
20:21:06 <djx> git log -1 --pretty=oneline
20:21:06 <djx> 29a220718daaf6ef03f205bfe6c9d918a787a436 Fix a bug in flooding in sendPacketOut.
20:22:26 <evanz_> oh no I imported l2switch and it broke betterhosttracker
20:22:45 <colindixon>20:22:48 <colindixon> that’s no good
20:22:58 <evanz_> if I close the l2switch project it works
20:23:00 <djx> what if you change to l2switch/packethandler and try doing mvn claen install?
20:23:01 <evanz_> :/
20:23:22 <djx> that was for colin
20:23:35 <colindixon> djx: I didn’t change anything
20:23:38 <colindixon> totally clean
20:24:40 <djx> mvn clean install right?
20:25:35 <colindixon> yeah
20:26:18 <djx> I don't know what might be, I will pull the controller and build it
20:26:52 <colindixon> yeah… that’s weird
20:26:58 <djx> ok, I can rename the betterhosttracker to mdhosttracker
20:27:38 <djx> basically everything should work on the distribution build of l2switch, no?
20:28:05 <colindixon> #info if we import the l2switch, we get errors in betterhosttracker, I think this is because their pom file sucks and doesn’t list the yang generated source directories correclty
20:28:14 <colindixon> either I or one of you can try to take a stab at that
20:29:00 <colindixon> #info the l2switch project has a distribution, which should work for us, we’ll just need to copy in the two addresstracker jar files and the betterhosttracker jar files
20:29:05 <colindixon> djx: yes
20:30:03 <djx> the weirdest part is that I can build the distribution part
20:31:40 <djx> what are the TaskProvider.java?
20:31:43 <djx> stuff
20:31:52 <colindixon> just ignore it
20:32:02 <colindixon> use the betterhosttracker directories for now
20:32:13 <colindixon> I remvoed the mdhosttracker directory from the pom file so it doesn’t build
20:32:29 <colindixon> if you want to pull the most recent from github
20:33:13 <djx> ok, build success
20:33:26 <djx> I didn't get the errors evanz_ was talking earlier
20:33:36 <evanz_> which ones?
20:34:02 <colindixon> did you import the l2switch project?
20:34:13 <colindixon> I think he’s talking about the errors if you have both imported into Eclipse
20:34:22 <evanz_> I have imported l2switch and mdhosttracker
20:34:23 <djx> yeah I saw that know
20:34:26 <djx> now*
20:34:27 <djx> forget it
20:34:29 <evanz_> l2switch has no errors in addresstracker
20:34:33 <colindixon> yeah
20:34:42 <colindixon> it just causes errors in betterhosttracker
20:34:44 <evanz_> but betterhosttracker can't find "Addresses"
20:35:01 <djx> evanz_ I don't have that issu
20:35:01 <evanz_> and when I run maven in eclipse I get a bunch of dependency "must be unique" errors
20:35:02 <djx> e
20:35:26 <colindixon> yeah, and that’s just becaues it knows it *should* be able to find it in the imported bundle, but the bundle’s pom file doesn’t have the generated source directory set up right
20:35:27 <colindixon> I think
20:35:38 <evanz_> ok
20:35:49 <colindixon> I’ve built the l2switch distribution
20:35:53 <colindixon> and I’m now trying to run it
20:36:58 <colindixon> #info just as a heads up, when runnign run.sh, you probably want to add -Xmx2048m -XX:MaxPermSize=512m so “./run.sh -Xmx2048m -XX:MaxPermSize=512m” so that it doesn’t run out of memory
20:37:07 <colindixon> even 2048m is coming up short sometiems
20:37:24 <djx> I always used 1G
20:37:46 <colindixon> great
20:37:52 <colindixon> and I run and get a nullpointerexception
20:38:50 <djx> with our project?
20:39:00 <colindixon> no when I run the l2switch distribution
20:39:33 <djx> ah phew, you should pull from git our project btw
20:40:20 <djx> push now
20:41:45 <djx> colindixon see if the nullpointexception isn't from l2switch/addresstracker/model/src/main/yang-gen-code/org/opendaylight/yang/gen/v1/urn/opendaylight/address/tracker/rev140617/address/node/connector/AddressesKey.java:[9,24]
20:42:12 <colindixon> ….
20:42:14 <colindixon> let me look
20:42:32 <djx> because that's where I'm getting my error while compiling
20:43:14 <colindixon> https://gist.github.com/nilok/0005658677c71bb3a788
20:44:36 <djx> packethandler.decoders.EthernetDecoder.decode(EthernetDecoder.java:62)
20:44:56 <djx> yep I'm getting another compilation error on packethandler as well
20:45:55 <djx> l2switch/packethandler/implementation/src/main/java/org/opendaylight/l2switch/packethandler/decoders/EthernetDecoder.java:[131,16] cannot find symbol
20:48:58 <colindixon> huh
20:49:02 <colindixon> that’s really weird
20:49:18 <colindixon> so you did cd l2switch; git pull; mvn clean install;
20:49:32 <djx> yups
20:50:15 <colindixon> I’m doing that now
20:50:47 <colindixon> trying to build everything not just the address tracker
20:51:08 <djx> you're saying that to me?
20:51:15 <colindixon> yeah
20:51:22 <colindixon> yeah
20:51:25 <djx> that's what I'm trying to do in the last half an hour
20:51:27 <colindixon> I get a failure on main-impl
20:51:39 <djx> [INFO] l2switch-parent ................................... SUCCESS [0.178s]
20:51:39 <djx> [INFO] packethandler-model ............................... SUCCESS [8.045s]
20:51:39 <djx> [INFO] packethandler-impl ................................ FAILURE [0.289s]
20:51:39 <djx> [INFO] packethandler.aggregator .......................... SKIPPED
20:51:39 <djx> [INFO] addresstracker-model .............................. SKIPPED
20:51:40 <djx> [INFO] main-impl ......................................... SKIPPED
20:51:42 <djx> [INFO] Opendaylight L2 Switch Base Edition ............... SKIPPED
20:51:44 <djx> [INFO] addresstracker-impl ............................... SKIPPED
20:51:46 <djx> [INFO] addresstracker.aggregator ......................... SKIPPED
20:51:48 <djx> [INFO] l2switch-controller-config ........................ SKIPPED
20:51:50 <djx> [INFO] l2switch .......................................... SKIPPED
20:51:51 <colindixon> [INFO] l2switch-parent .................................... SUCCESS [  0.258 s]
20:51:52 <colindixon> [INFO] packethandler-model ................................ SUCCESS [ 14.559 s]
20:51:54 <colindixon> [INFO] packethandler-impl ................................. SUCCESS [  2.809 s]
20:51:55 <colindixon> [INFO] packethandler.aggregator ........................... SUCCESS [  0.109 s]
20:51:57 <colindixon> [INFO] addresstracker-model ............................... SUCCESS [  1.307 s]
20:51:58 <colindixon> [INFO] main-impl .......................................... FAILURE [  0.622 s]
20:52:00 <colindixon> [INFO] Opendaylight L2 Switch Base Edition ................ SKIPPED
20:52:00 <evanz_> lol
20:52:01 <colindixon> [INFO] addresstracker-impl ................................ SKIPPED
20:52:03 <colindixon> [INFO] addresstracker.aggregator .......................... SKIPPED
20:52:04 <colindixon> [INFO] l2switch-controller-config ......................... SKIPPED
20:52:05 <colindixon> [INFO] l2switch ........................................... SKIPPED
20:52:06 <colindixon> that’s what I get
20:52:07 <colindixon> so, I make it further
20:52:16 <djx> that's not fair
20:53:03 <evanz_> uh
20:53:11 <evanz_> [INFO] Reactor Summary:
20:53:12 <evanz_> [INFO]
20:53:12 <evanz_> [INFO] l2switch-parent ................................... SUCCESS [0.244s]
20:53:12 <evanz_> [INFO] packethandler-model ............................... SUCCESS [9.541s]
20:53:12 <evanz_> [INFO] packethandler-impl ................................ SUCCESS [2.047s]
20:53:13 <evanz_> [INFO] packethandler.aggregator .......................... SUCCESS [0.081s]
20:53:14 <evanz_> [INFO] addresstracker-model .............................. SUCCESS [0.724s]
20:53:16 <evanz_> [INFO] main-impl ......................................... SUCCESS [0.728s]
20:53:18 <evanz_> [INFO] Opendaylight L2 Switch Base Edition ............... SUCCESS [18.822s]
20:53:20 <evanz_> [INFO] addresstracker-impl ............................... SUCCESS [0.363s]
20:53:22 <evanz_> [INFO] addresstracker.aggregator ......................... SUCCESS [0.004s]
20:53:26 <evanz_> [INFO] l2switch-controller-config ........................ SUCCESS [1.204s]
20:53:27 <colindixon> evanz
20:53:28 <djx> lol
20:53:28 <evanz_> [INFO] l2switch .......................................... SUCCESS [0.004s]
20:53:30 <evanz_> [INFO] ------------------------------------------------------------------------
20:53:32 <evanz_> [INFO] BUILD SUCCESS
20:53:33 <djx> you won
20:53:59 <evanz_> why is maven so strange
20:54:04 <evanz_> sheesh
20:54:08 <colindixon> I just did an rm -rf ~/.m2/
20:54:10 <djx> should I delete the folder and pull everything?
20:54:13 <colindixon> and I’m trying to rebuild
20:54:16 <colindixon> and see what happens
20:54:16 <djx> omg...
20:54:16 <evanz_> yeah rm .m2 is a good idea
20:54:23 <colindixon> well, it’s a shitty idea
20:54:27 <colindixon> but sometimes it’s the only one that works
20:54:32 <evanz_> lol o
20:54:35 <djx> rm .m2 is like reinstalling the OS
20:54:42 <evanz_> maybe mine only builds because theres something it needs sitting in .m2
20:54:45 <evanz_> that will be gone if I delete it
20:55:48 <evanz_> P.S. they still don't play nicely in eclipse
20:55:51 <djx> colin tell me if that works because I don't like deleting .m2
20:56:30 <colindixon> yeah
20:56:42 <colindixon> I’m working on it
20:56:49 <colindixon> no
20:56:54 <colindixon> mine fails in the same place
20:57:40 <evanz_> running distribution
20:58:58 <djx> thanks colin for sending that email
21:00:04 <colindixon> yeah
21:02:09 <evanz_> well the controller didn't exactly work
21:02:34 <djx> evanz_ what happen?
21:03:20 <evanz_> not sure
21:03:43 <colindixon> do you get exceptions
21:03:51 <colindixon> I wonder how it is that you can build it evan
21:03:54 <colindixon> are you on Linux?
21:03:57 <colindixon> isn’t djx also Linux
21:03:58 <evanz_> indeed
21:04:05 <djx> I'm on linux
21:04:10 <evanz_> djx is on fedora?
21:04:12 <evanz_> is that right?
21:04:18 <djx> yup
21:04:26 <colindixon> #info we’re running into problems building and/or running the l2switch project
21:04:37 <djx> just to be clear
21:04:43 <djx> mvn --version
21:04:44 <djx> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 13:51:28+0000)
21:04:44 <djx> Maven home: /usr/share/maven
21:04:44 <djx> Java version: 1.7.0_51, vendor: Oracle Corporation
21:04:48 <djx> Java home: /usr/java/jdk1.7.0_51/jre
21:04:52 <djx> Default locale: en_US, platform encoding: UTF-8
21:04:56 <djx> OS name: "linux", version: "3.14.9-200.fc20.x86_64", arch: "amd64", family: "unix"
21:05:01 <colindixon> mvn -v
21:05:01 * djx should update it's java version
21:05:02 <colindixon> Apache Maven 3.2.2 (45f7c06d68e745d05611f7fd14efb6594181933e; 2014-06-17T08:51:42-05:00)
21:05:03 <colindixon> Maven home: /usr/local/Cellar/maven/3.2.2/libexec
21:05:05 <colindixon> Java version: 1.7.0_51, vendor: Oracle Corporation
21:05:06 <colindixon> Java home: /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre
21:05:07 <colindixon> Default locale: en_US, platform encoding: UTF-8
21:05:08 <colindixon> OS name: "mac os x", version: "10.9.4", arch: "x86_64", family: "mac"
21:05:11 <evanz_> evan@evan-ThinkPad ~/git_reps/l2switch/distribution/base/target/distributions-l2switch-base-0.1.0-SNAPSHOT-osgipackage/opendaylight $ mvn --version
21:05:12 <evanz_> Apache Maven 3.0.4
21:05:12 <evanz_> Maven home: /usr/share/maven
21:05:12 <evanz_> Java version: 1.7.0_25, vendor: Oracle Corporation
21:05:12 <evanz_> Java home: /usr/lib/jvm/java-7-openjdk-amd64/jre
21:05:13 <evanz_> Default locale: en_US, platform encoding: UTF-8
21:05:15 <evanz_> OS name: "linux", version: "3.8.0-35-generic", arch: "amd64", family: "unix"
21:05:44 <colindixon> well, we have different java versions, and different maven versions
21:06:00 <djx> worst
21:06:22 <djx> evanz_ I would advice you to work with proprietary java
21:07:30 <djx> colin but this shouldn't be a problem
21:08:10 <evanz_> should I rm .m2
21:08:15 <colindixon> nope
21:08:16 <colindixon> well
21:08:33 <colindixon> mv ~/.m2 ~/old.m2
21:08:36 <colindixon> or something
21:08:40 <colindixon> so you can move it back
21:09:09 <colindixon> #info colindixon e-mailed the l2swtich team to ask for help with the fact that things aren’t compiling
21:09:17 <colindixon> ok, I’m going to have to call it a day for this
21:09:21 <colindixon> :-/
21:10:05 <colindixon> does the addresstracker depend on anything that’s not building
21:10:06 <colindixon> ?
21:10:10 <colindixon> #topic fallback plans
21:10:40 <colindixon> #info so, while we wait for them to fix the l2switch stuff, we could take the base distribution from openflowplugin and use it
21:10:59 <colindixon> #info we’ll then need to copy in the address tracker jars, their dependencies and the host tracker jars
21:11:05 <djx> I can't build the addresstracker too
21:11:30 <colindixon> #info and see if we can get that to work and generate data change events
21:11:44 <djx> yes
21:12:14 <colindixon> #info I recommend using log.error() or system.out.println() messages to figure out if you’re code is hitting because the logging is often configured to only print error messages and above
21:12:59 <colindixon> ugh I have no idea why stuff isn’t building
21:13:01 <djx> the logger is there ;)
21:13:12 <colindixon> ok, well lets touch base with things again tomorrow morning
21:13:20 <colindixon> maybe djx will wake up having a fix
21:13:24 <colindixon> :-)
21:13:27 <colindixon> #endmeeting