#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:09:29 UTC (full logs).

Meeting summary

  1. status update (colindixon, 20:09:33)
    1. evanz and djx are getting data changes about addresses! woot! (colindixon, 20:09:49)

  2. next steps (colindixon, 20:09:58)
    1. eventually I think we want to do the following: Addresses (from Address Tracker) => our logic => Hosts in MD-SAL (colindixon, 20:11:59)
    2. the idea has been that the hostracker_new code (from BSN) would be “our logic” above (colindixon, 20:12:19)
    3. for now, I’d like to keep things as simple as possible and basically make “our logic” just the minimal transform to directly turn an Addresses into a host (colindixon, 20:12:41)
    4. it seems like the best thing we could do here would be to write some kind of test which injects Addresses on the one side and looks to make sure a matching host comes out on the other site (colindixon, 20:21:35)
    5. so, after thinking a bit, it seems easier (for now) to just use mininet to test things (colindixon, 20:25:35)
    6. https://meetings.opendaylight.org/opendaylight-intern/2014/better_host_tracker_interns/opendaylight-intern-better_host_tracker_interns.2014-07-14-20.09.log.txt (colindixon, 20:31:32)
    7. ACTION: djx and evanz to get it so that they produce actual hosts in teh MD-SAL with a simple mininet setup (colindixon, 20:34:23)
    8. we decided to be operational data since it's data that we read from the network, we never write anything on the nodes (djx, 20:37:34)
    9. to access hosts inventory is need to go http://127.0.0.1:8080/restconf/operational/host-tracker-service:hosts/ (djx, 21:03:19)


Meeting ended at 21:27:11 UTC (full logs).

Action items

  1. djx and evanz to get it so that they produce actual hosts in teh MD-SAL with a simple mininet setup


Action items, by person

  1. djx
    1. djx and evanz to get it so that they produce actual hosts in teh MD-SAL with a simple mininet setup
  2. evanz
    1. djx and evanz to get it so that they produce actual hosts in teh MD-SAL with a simple mininet setup


People present (lines said)

  1. colindixon (96)
  2. djx (78)
  3. evanz (73)
  4. odl_meetbot (4)


Generated by MeetBot 0.1.4.