19:05:43 <colindixon> #startmeeting better host tracker interns
19:05:43 <odl_meetbot> Meeting started Thu Jul 24 19:05:43 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:05:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:43 <odl_meetbot> The meeting name has been set to 'better_host_tracker_interns'
19:05:49 <colindixon> #topic status update
19:06:07 <evanz_> so I hope it's okay to use NodeConnector there
19:06:16 <evanz_> I figured DataObject was there because it's generic or whatever
19:06:23 <colindixon> #info evanz_ posted a change to deal with the new, better typed read operations
19:06:46 <colindixon> so the basic thing is that the instance identifier could only ever point to a node connector
19:06:51 <colindixon> so it typed it as a node connector
19:07:29 <colindixon> #link https://wiki.opendaylight.org/view/MdHostTracker evanz_ started on a wiki page to show how to get up and play with the MDHostTracker
19:08:06 <evanz_> so i think today we should nail down the model and respond to the l2switch guys
19:08:20 <colindixon> yeah
19:08:28 <evanz_> you think we should be part of l2switch?
19:08:41 <colindixon> evanz_: um, I don’t think it hurts us much
19:08:44 <evanz_> the good thing is our structure fits with theres and only need to change package names
19:08:46 <evanz_> yeah
19:08:56 <colindixon> #topic participating in helium
19:09:06 <colindixon> I’m assuming you want to ship this in helium
19:09:07 <colindixon> is that right?
19:09:17 <colindixon> it shouldn’t be too terribly painful, I hope
19:09:52 <djx> hey guys sorry I'm late
19:10:03 <evanz_> hi djx
19:10:19 <evanz_> colindixon: yeah  that would be good
19:10:25 <evanz_> as long as we can get everything running :)
19:10:28 <evanz_> releases make me nervous
19:10:30 <djx> the meeting?
19:10:58 <djx> evanz_ pressure makes diamonds
19:11:04 <djx> and dust :P
19:11:16 <evanz_> djx: talking about putting our code in l2switch and shipping in helium
19:11:16 <colindixon> #info to participate in helium we probably need to: (1) finish our model by 8/4, (2) provide some rudimentary documentation, (3) provide a description of ourselves as a karaf feature, (4) provide a “component” that we can export from l2switch, (5) provide a sanitized list of hosts, e.g., no hosts in the middle of the network
19:11:28 <djx> yes thank you
19:11:36 <djx> I don't think that is a good idea
19:11:47 <colindixon> #info evanz_ and djx want to go for it :-)
19:11:57 <colindixon> oh Isee
19:12:00 <colindixon> djx: says “don’t"
19:12:01 <evanz_> haha
19:12:04 <colindixon> lol
19:13:30 <colindixon> evanz_, did the l2switch people ask us for something that I missed
19:13:41 <colindixon> djx: is there a reason why not? just lots of work?
19:13:50 <djx> I don't remember but I think one of the projects that had a sort-of-"flow" installer (I think it was the old l2switch project) and they split the hosttracker from their project
19:14:09 <evanz_> there was an email
19:14:17 <evanz_> "Host-tracker in l2switch"
19:14:17 <colindixon> am I on it?
19:14:20 <evanz_> yeah
19:14:36 <colindixon> yes
19:14:36 <colindixon> ok
19:15:22 <djx> why they want to do this "As we would have to build some enhancements over address tracking that can track hosts/ endpoints. "?
19:15:35 <colindixon> #link https://lists.opendaylight.org/pipermail/l2switch-dev/2014-July/000012.html this is the mail
19:15:45 <colindixon> djx: so here’s the deal
19:15:59 <colindixon> edwarnicke: wants to provide the same functionality we had with IfIptoHost in AD-SAL
19:16:05 <colindixon> and they’re happy to take it from us
19:16:14 <colindixon> otherwise, they’re going to do it themselves
19:17:09 <djx> yes I understand, but that does not makes sense on the l2switch project
19:17:23 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html I think edwarnicke wants to provide this functionality from the MD-SAL in Helium (both via this interface for compatibility and via the MD-SAL directly)
19:17:55 <colindixon> djx: I would tend to agree, but it needs to live somewhere
19:18:18 <colindixon> and apparently our release tools don’t handle cyclic dependencies between projects
19:18:28 <colindixon> and l2switch depends on controller
19:18:45 <colindixon> and we depend on l2switch
19:18:55 <colindixon> so, we can be in the controller
19:19:25 <colindixon> I guess, technically, we could petition to have the address tracker model be moved into the controller and then we could be in the controller, but it seems wrong
19:19:32 <colindixon> does that make sense?
19:19:41 <djx> right, I don't understand the cyclic dependencies part
19:19:47 <djx> where is the cycle?
19:20:00 <colindixon> (just a s heads up I have a hard stop at the top of the hour)
19:20:06 <colindixon> let’s use a hangout really quickly
19:20:09 <colindixon> i think it’ll be faster
19:20:14 <djx> okay fine by me ;)
19:20:37 <colindixon> https://plus.google.com/hangouts/_/g2xain4atypgbhpka326z6tncua
19:20:43 <evanz_> let me hunt down a quiet corner, they're having a cisco class in my lab
19:20:52 <colindixon> ah, sure
19:27:37 <colindixon> https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations
19:37:00 <colindixon> #info the other thing I left from helium release is picking which java interfaces, e.g., IfIptoHost, we want to export and getting that done
19:37:10 <colindixon> #info we might be able to foist that off onto the l2switch team
19:37:29 <colindixon> #agreed we will participate in helium as part of the l2switch project, but as our own component
19:37:34 <colindixon> #topic next steps
19:38:08 <colindixon> #action evanz_ will refactor the mdhosttracker project appropriately and get it into l2switch
19:38:37 <colindixon> #info evanz_ make sure to have the l2swtich guys hit merge, not us
19:38:51 <evanz_> #link https://gist.github.com/evanzeller/b39c7603fc6d0d91e7fd
19:38:54 <evanz_> current model
19:38:58 <evanz_> I think just some naming issues
19:39:24 <evanz_> (host == array right now which is not quite clear)
19:39:56 <colindixon> in the documentation, we need say that the id is an opaque, unique value and should not be assumed to be the mac address
19:40:56 <colindixon> this is the way that Nodes work
19:41:04 <colindixon> nodes:node[“id”]
19:41:18 <colindixon> in Java it’s a Host
19:41:22 <colindixon> and a HostBuilder
19:42:13 <colindixon> the only thing I might change would be to maybe make host an augmentation of Node
19:42:41 <colindixon> there’s no nodeconnector in hosts, is that right?
19:42:42 <colindixon> we need that
19:42:57 <evanz_> the nodeconnector was supposed to be like
19:43:00 <evanz_> taken from the path?
19:43:03 <evanz_> in the listener
19:43:04 <evanz_> or something like that
19:43:13 <colindixon> #link https://github.com/nilok/betterhosttracker/blob/master/mdhosttracker/mdhosttracker/model/src/main/yang/host-tracker-service.yang the model
19:44:13 <colindixon> https://gist.github.com/anonymous/5a59f031d19ad3c734ba
19:44:56 <colindixon> #info we need a node connector ref in the host
19:44:59 <colindixon> or a list of them
19:45:03 <colindixon> #info or a list of them
19:46:06 <colindixon> https://gist.github.com/anonymous/7ee9c9029653bf361d64
19:51:56 <evanz_> yessir
19:52:07 <colindixon> #info colin mades some edits to our model to add node connectors
19:55:19 <colindixon> #topic finishing up
19:55:31 <colindixon> #action colindixon to send out e-mail with tasks for helium and deadlines
19:55:45 <colindixon> somebody needs to respond to the l2switch guys
19:55:47 <evanz_> I can do it
19:55:50 <colindixon> OK
19:56:00 <colindixon> #action evanz_ to respond to the l2switch guys
19:56:10 <djx> when are you thinking to merge the two project?
19:56:26 <evanz_> will work on it today and will respond to them with the gerrit link
19:56:27 <evanz_> is my plan
19:57:56 <colindixon> git clone https://git.opendaylight.org/gerrit/l2switch
19:58:07 <colindixon> #info to get the l2switch project just do this: https://git.opendaylight.org/gerrit/controller
19:58:19 <colindixon> #info to submit a patch you can commit, then go “git review"
19:58:46 <colindixon> #link https://wiki.opendaylight.org/view/Git-review_Workflow git review works really, really well
19:59:57 <colindixon> #info we need to start the discussion of what Java interfaces we will provide as services and start getting that working as well as filtering node connectors for attachment points
20:00:20 <colindixon> #endmeeting