#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:22:35 UTC (full logs).

Meeting summary

  1. models (colindixon, 20:22:40)
    1. there’s a question of where the model should go: (1) it’s own thing, i.e., host-tracker/hosts, (2) in inventory, i.e., opendaylight-inventory:hosts, (3) as something that dangles off of node connectors, (4) as an augmentation of node (colindixon, 20:24:58)
    2. ed points out that hosts might be better living in the topology space, rather than inventory space (colindixon, 20:25:14)
    3. http://tools.ietf.org/html/rfc6020#page-107 (edwarnicke, 20:25:34)
    4. colin says what we really want is for some nodes to be unmanaged and to have some unmanaged nodes be hosts, but that’s hard-ish to do in yang (colindixon, 20:26:52)
    5. ed responsds that maybe using the when clause would help get you there (colindixon, 20:27:11)
    6. https://github.com/nilok/betterhosttracker/blob/master/mdhosttracker/mdhosttracker/implementation/src/main/java/org/opendaylight/mdhosttracker/plugin/internal/MdHostTrackerImpl.java (djx, 21:04:07)
    7. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html (colindixon, 21:10:59)
    8. ACTION: colindixon to propose a set of APIs in IfIptoHost that we will support and to try to find out if people are using the others (colindixon, 21:15:28)
    9. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html (colindixon, 21:15:37)
    10. https://git.opendaylight.org/gerrit/#/c/9412/ (colindixon, 21:35:47)

  2. conclusions (colindixon, 21:58:54)
    1. the current plan is to make hosts an augmentation of the node in topology (colindixon, 21:59:12)
    2. the other current plan is to support (at least some of) the IfIptoHost interface (colindixon, 21:59:31)
    3. we are not going support the IHostFinder interface (which is really an interface to ArpHandler) (colindixon, 22:01:07)


Meeting ended at 22:01:37 UTC (full logs).

Action items

  1. colindixon to propose a set of APIs in IfIptoHost that we will support and to try to find out if people are using the others


Action items, by person

  1. colindixon
    1. colindixon to propose a set of APIs in IfIptoHost that we will support and to try to find out if people are using the others


People present (lines said)

  1. colindixon (77)
  2. djx (37)
  3. edwarnicke (28)
  4. evanz (20)
  5. evanz_ (6)
  6. odl_meetbot (3)


Generated by MeetBot 0.1.4.