#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:00:57 UTC (full logs).

Meeting summary

  1. status update (colindixon, 20:01:10)
    1. Amit sent out an e-mail asking us if this is our final design and asking us to confirm what seems like a correct understanding of our approach (colindixon, 20:03:03)
    2. ACTION: evanz will respond to Amit saying (i) yes, this is our planned final design, (ii) yes, there will just be extra nodes in the topology that will have host augmentations, and (iii) while most hosts will likely have one attachment point, it is by no means guranteed. (colindixon, 20:08:32)

  2. non-model stuff (colindixon, 20:12:01)
    1. there’s two things we want to work on beyond the model: (1) providing the legacy APIs, e.g., IfIptoHost and (2) writing the actual code which translates Addresses from the address-tracker to HostNodes in the topology (colindixon, 20:14:26)
    2. djx says #2 is done (colindixon, 20:14:33)
    3. ACTION: colindixon to look over the current Addresses => HostNode code later today (colindixon, 20:15:01)
    4. https://wiki.opendaylight.org/view/L2_Switch:HostTracker (djx, 20:16:23)
    5. ACTION: djx and/or evanz to enahnce the current code to push a Node (with the right termination points) and approprate links in addition to the HostNode (colindixon, 20:20:48)
    6. to be clear, the thing you pass to NodeBuilder.setTerminationPoints() shold be *exactly* the same as the thing you pass to HostNodeBuilder.setAttachmentPoints() (colindixon, 20:21:35)
    7. djx asks what happens when a node (that has the HostNode agumentation) is removed (colindixon, 20:26:58)
    8. https://wiki.opendaylight.org/view/L2_Switch:HostTracker (colindixon, 20:33:21)

  3. IfIptoHost (colindixon, 20:39:30)
    1. my take is that we write a second bundle which implements IfIptoHost independently of our hosttracker (colindixon, 20:40:06)
    2. to do this, we are going to basically make a copy of the HostTrackerConsumer calling it HostTrackerAdaptor or something (colindixon, 20:42:44)
    3. whenever anyone calls one of the IfIptoHost methods on it, we’ll try to look up the information they want in the MD-SAL directly (colindixon, 20:43:19)
    4. we can have some of the methods throw UnsupportedOperationExceptions unti we get them implemented or decide that we won’t support them (colindixon, 20:43:53)
    5. as djx points out, it might be a good time to come up with blank interface called IHostTrackerService or HostTrackerService that extends IfIptoHost so that we arent’ stuck with that horrible name (colindixon, 20:45:00)

  4. stretch goals (colindixon, 20:47:07)
    1. we could actually wire up Addresses to the hosttracker_new code to handle some corner cases (like overlapping address spaces) better (colindixon, 20:47:30)
    2. but this isn’t needed (colindixon, 20:47:34)

  5. demos and future meetings (colindixon, 20:48:41)
    1. we should probably give a demo to both the people who already asked (Abhijit and Chris Price) as well as the dLux people (colindixon, 20:49:46)
    2. ACTION: colindixon to reach out to Abhijit and Chris Price and propose our normal meeting time if it works for them on Tuesday or Wednesday (colindixon, 20:50:12)
    3. ACTION: colindixon to reach out to the dLux people to ask if they want a demo (colindixon, 20:50:22)
    4. https://wiki.opendaylight.org/view/Developer_Best_Practices#New_Files this is the answer to djx’s question about copyright/license headers (colindixon, 21:01:19)


Meeting ended at 21:02:02 UTC (full logs).

Action items

  1. evanz will respond to Amit saying (i) yes, this is our planned final design, (ii) yes, there will just be extra nodes in the topology that will have host augmentations, and (iii) while most hosts will likely have one attachment point, it is by no means guranteed.
  2. colindixon to look over the current Addresses => HostNode code later today
  3. djx and/or evanz to enahnce the current code to push a Node (with the right termination points) and approprate links in addition to the HostNode
  4. colindixon to reach out to Abhijit and Chris Price and propose our normal meeting time if it works for them on Tuesday or Wednesday
  5. colindixon to reach out to the dLux people to ask if they want a demo


Action items, by person

  1. colindixon
    1. colindixon to look over the current Addresses => HostNode code later today
    2. colindixon to reach out to Abhijit and Chris Price and propose our normal meeting time if it works for them on Tuesday or Wednesday
    3. colindixon to reach out to the dLux people to ask if they want a demo
  2. djx
    1. djx and/or evanz to enahnce the current code to push a Node (with the right termination points) and approprate links in addition to the HostNode
  3. evanz
    1. evanz will respond to Amit saying (i) yes, this is our planned final design, (ii) yes, there will just be extra nodes in the topology that will have host augmentations, and (iii) while most hosts will likely have one attachment point, it is by no means guranteed.
    2. djx and/or evanz to enahnce the current code to push a Node (with the right termination points) and approprate links in addition to the HostNode


People present (lines said)

  1. colindixon (157)
  2. djx (59)
  3. evanz (27)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.