#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:34:01 UTC (full logs).

Meeting summary

  1. status update (colindixon, 20:34:10)
    1. https://git.opendaylight.org/gerrit/#/c/9796/ (djx, 20:34:10)
    2. we presented to some folks from Ericsson and the SFC project this morning (colindixon, 20:34:25)
    3. https://git.opendaylight.org/gerrit/#/c/9796/ the current code (colindixon, 20:34:36)

  2. current work (colindixon, 20:34:49)
    1. we have 4 (or 5) things on our plate: 0.) fix l2switch, 1.) Merge the two topology nodes for a host into one, 2.) Add links into the topology for attachment points, 3.) Make sure there's a karaf feature that disables any *active* control, but gives host tracker, 4.) IfIptoHost API (colindixon, 20:40:12)

  3. fixing the l2switch (colindixon, 20:40:26)
    1. https://git.opendaylight.org/gerrit/#/c/9766/ djx says he hasn’t been able to get data change messages after this commit was merged (colindixon, 20:41:21)
    2. amit_mandke says he does see host nodes after it (colindixon, 20:41:44)
    3. ACTION: djx, evanz and colindixon to look into this more later if it’s not fixed (colindixon, 20:41:56)

  4. merging the two topology nodes for each host into one (colindixon, 20:42:10)
    1. as of this morning we were adding two nodes for each host, one which had the augmentation (and thus the host-tracer-service:id and the attachment points) and another that had the termination points (colindixon, 20:43:37)
    2. http://paste.fedoraproject.org/124004/43967140 djx says if you push the two nodes with the same ID, they don’t get merged, the second just replaces the first (colindixon, 20:44:45)
    3. this is the expected behavior (colindixon, 20:44:51)
    4. in addition to put, there should be a merge operation that will merge the two nodes (colindixon, 20:47:04)
    5. alternately, you can build them as a single node by using NodeBuilder and HostNodeBuilder and then calling addAugmentation on the NodeBuilder with the built node (colindixon, 20:48:22)
    6. https://plus.google.com/hangouts/_/g2zp6d7w73hcb5mmlhcweetlx4a (colindixon, 20:53:54)
    7. problem fixed (colindixon, 21:08:00)

  5. back to fixing l2switch (colindixon, 21:12:45)
    1. evanz says that he eventually sees host nodes, but it takes a while (colindixon, 21:12:56)
    2. because the change makes so we only get Addresses from ARP packets, the hypothesis is that we’re missing the creation of the first few Addresses (colindixon, 21:13:26)
    3. we would fix this by querying for all Addresses after we subscribe and calling the relevant functions (colindixon, 21:14:06)
    4. colindixon suggests running mininet with --arp will pre populate the ARP tables and thus will cause no ARPs to be sent and would verity this (colindixon, 21:16:15)

  6. adding links (colindixon, 21:18:21)
    1. ACTION: djx to write code to add links (colindixon, 21:18:52)
    2. you have to add two links one in each direction (colindixon, 21:19:10)
    3. djx asks how we can get the node ID for the switch we’re connected to, very long discussion leads to an answer (colindixon, 21:46:44)
    4. InstanceIdentifier<Node> iin = iinc.firstIdentifierOf(Node.class); (colindixon, 21:46:54)
    5. ListenableFuture<Optional<Node>> nodeFuture = readTx.read(LogicalDatastoreType.OPERATIONAL, iin); (colindixon, 21:47:00)
    6. Node n = nodeFuture.get().get(); (colindixon, 21:47:10)
    7. all in the the onDataChanged() (colindixon, 21:47:16)
    8. then we can assume that the inventory node ID is the same as the topology node ID (colindixon, 21:47:39)
    9. ACTION: djx to make it so that when a NodeConnector goes away, we remove the link and the attachment point (colindixon, 21:50:29)

  7. karaf feature (colindixon, 21:51:09)
    1. this is a task for later, but we need to make sure there's a karaf feature that disables any *active* control, but gives host tracker (colindixon, 21:51:48)
    2. if we don’t use karaf in l2swich, instead, this needs to be a list of the bundles to get only hostracker with no rule programming (colindixon, 21:52:24)

  8. IfIptoHost API (colindixon, 21:52:55)
    1. the only hard part is generate all the AD-SAL types (colindixon, 21:56:16)
    2. the things you want to make this easy are in the the TopologyMapping class in org.opendaylight.controller.md.compatibility.topology in the controller (colindixon, 22:02:38)
    3. you want toAdTopologyNode(), toAdTopologyNodeConnector() (colindixon, 22:02:59)
    4. https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/sal/compatibility/topology/TopologyMapping.html here (colindixon, 22:03:29)
    5. once you get this working you might want to make a toADHost() method and find a place for it in the controller compatibility (colindixon, 22:04:38)


Meeting ended at 22:15:28 UTC (full logs).

Action items

  1. djx, evanz and colindixon to look into this more later if it’s not fixed
  2. djx to write code to add links
  3. djx to make it so that when a NodeConnector goes away, we remove the link and the attachment point


Action items, by person

  1. colindixon
    1. djx, evanz and colindixon to look into this more later if it’s not fixed
  2. djx
    1. djx, evanz and colindixon to look into this more later if it’s not fixed
    2. djx to write code to add links
    3. djx to make it so that when a NodeConnector goes away, we remove the link and the attachment point
  3. evanz
    1. djx, evanz and colindixon to look into this more later if it’s not fixed


People present (lines said)

  1. colindixon (80)
  2. djx (17)
  3. odl_meetbot (10)
  4. evanz (9)


Generated by MeetBot 0.1.4.