20:48:46 <colindixon> #startmeeting better host tracker interns
20:48:46 <odl_meetbot> Meeting started Mon Aug 11 20:48:46 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:48:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:48:46 <odl_meetbot> The meeting name has been set to 'better_host_tracker_interns'
20:49:04 <colindixon> #topic karaf and splitting l2switch address tracker
20:49:24 <colindixon> #info we need a bundle which proves addresses but *does not* push rules
20:49:34 <colindixon> #info or depend on any bundles that automatically push rules
20:50:10 <colindixon> #info after that, we can make a karaf feature which just includes the bundles we need
20:50:25 <colindixon> #topic AD-SAL APIs
20:50:56 <colindixon> #info colindixon sent mail listing the four APIs and who uses them
20:51:20 <colindixon> IfIptoHost
20:51:20 <colindixon> controller
20:51:22 <colindixon> sdninterfaceapp
20:51:23 <colindixon> vtn
20:51:25 <colindixon> IHostFinder
20:51:26 <colindixon> controller
20:51:28 <colindixon> vtn
20:51:29 <colindixon> IfHostListener
20:51:31 <colindixon> controller
20:51:32 <colindixon> toolkit (DnsGuard)
20:51:34 <colindixon> vtn
20:51:35 <colindixon> IfNewHostNotify
20:51:36 <colindixon> controller
20:51:37 <colindixon> #info see the log for the list
20:52:26 <colindixon> #action evanz_ will go through VTN, controller, toolkit, sdninterfaceapp and see what subsets of the API they’re using
20:53:15 <colindixon> #info one thing you could do would be to edit the interface to remove the functions you don’t want to implement, then build the other project with -nsu and see if you get compile errors
20:54:24 <djx> don't forget to use grep too
20:54:38 <colindixon> #info toolkit might be a pain in the ass because it’s embedded in an archetype
20:55:06 <colindixon> #info djx points out to also trust/use grep to start your search
20:55:25 <colindixon> #info we’re planning to ignore affinity because they’re not participating in helium
20:56:40 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfIptoHost.html
20:56:58 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/hostAware/IHostFinder.html
20:57:14 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfHostListener.html
20:57:32 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/index.html?org/opendaylight/controller/hosttracker/IfIptoHost.html
21:00:18 <colindixon> #info IHostFinder is to send probes actively into the network, we should probably not implement that
21:01:06 <colindixon> #info IfHostListener was implemented by HostTracker and called by ArpHanlder (this is analogous to the address tracker today, skip it)
21:01:46 <colindixon> #undo
21:01:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2484510>
21:01:48 <colindixon> #undo
21:01:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24841d0>
21:01:49 <colindixon> #undo
21:01:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2484910>
21:02:14 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/hosttracker/IfNewHostNotify.html
21:02:20 <colindixon> #info IHostFinder is to send probes actively into the network, we should probably not implement that
21:02:27 <colindixon> #info IfHostListener was implemented by HostTracker and called by ArpHanlder (this is analogous to the address tracker today, skip it)
21:03:08 <colindixon> #info IfNewHostNotify is the interface apps can implement to be notified when host show up or go away (we want to implement this)
21:08:42 <colindixon> #info to implement it right, we need to figure out who implements that, but I don’t know how to do that from a bundle that doesn’t have the AD-SAL style activator
21:09:13 <colindixon> #action colindixon to ask devinavery about getting services from an MD-SAL app and connect you guys with him
21:10:15 <colindixon> #topic keep working on the code we have
21:10:25 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/9798/
21:47:36 <colindixon> #endmeeting
21:47:50 <colindixon> #endmeeting