#opendaylight-intern: better host tracker interns

Meeting started by colindixon at 20:03:56 UTC (full logs).

Meeting summary

  1. status update (colindixon, 20:04:05)
    1. everyone welcome devinavery :-) (colindixon, 20:04:14)
    2. https://meetings.opendaylight.org/opendaylight-intern/2014/better_host_tracker_interns/opendaylight-intern-better_host_tracker_interns.2014-08-07-20.34.html this is the big list of things we’re trying to get done with some good notes about them (colindixon, 20:05:34)
    3. https://meetings.opendaylight.org/opendaylight-intern/2014/better_host_tracker_interns/opendaylight-intern-better_host_tracker_interns.2014-08-11-20.48.html we talked about AD-SAL adapters in more depth now (colindixon, 20:06:11)
    4. right now, for me, the l2switch isn’t forwarding traffic, but I *am* seeing hosts (colindixon, 20:13:16)
    5. evanz doesn’t quite have getAllHosts() working yet, but he’s pretty sure he can bang it out pretty easily (colindixon, 20:22:08)
    6. colindixon was able to pull draft 9923 and it produces host that look good although l2switch still seems to not forward traffic for him with a linear,2 topology (colindixon, 20:25:12)

  2. stuff we’re working on (colindixon, 20:29:06)
    1. djx has provided a simple address tracker of our own (colindixon, 20:33:43)
    2. evanz asks how we should convert our hosts, which can have multiple MACs, IPs and attachment points (colindixon, 21:03:24)
    3. the answer is for 99% of the time, there will only be one MAC, one IP and one attachemnt point, so we just return it (colindixon, 21:06:12)
    4. some other workarounds would be to factor out a single host into multiple hosts for the AD-SAL, get the latest observation, get the first observation (colindixon, 21:10:49)
    5. the *right* solution for all of this would be to make there to be one AD-SAL host per attachment point, per addresses structure that we have (colindixon, 21:11:57)

  3. address observer (colindixon, 21:12:02)
    1. djx wants to know what to do with our own address observer (colindixon, 21:14:52)
    2. right now the master is working and giving us Addresses and thus hosts (abeit not sending traffic) (colindixon, 21:32:21)
    3. as a consequence, I think that the the simple address observer should be moved into it’s own class and disabled for now (colindixon, 21:32:44)
    4. let’s call that class SimpleAddressObserver (colindixon, 21:33:00)
    5. if we want to keep it, my take was to write the data to the MD-SAL and use a ReadWriteTranscation to figure out if there is an already existing addresses that has the same MAC, IP, VLAN triple and use it’s ID then, if there’s none, then we make up our own Addresses (colindixon, 21:39:02)
    6. but I think for now we should hope their stuff works and/or fix it so it does work for us (colindixon, 21:39:18)

  4. what’s left to do (colindixon, 21:39:25)
    1. evanz is working on AD-SAL APIs, he’ll have to figure out how to publish and susbscribe for OSGi services (colindixon, 21:41:58)
    2. djx wants a way to track node connector status so he can tell when it’s down so that he can remove those attachment points (colindixon, 21:45:39)
    3. for now, we’re going to leave the hard coding “flow:1”, hard-coding the fact nodeIDs are the same in both inventory and topology, and hard coding the fact that node-connector-id and tp-id are the same (colindixon, 21:56:36)
    4. for now we’re also going to leave alone handling portup and portdown messges (colindixon, 21:56:51)
    5. although those are good things to come back to if we have time (colindixon, 21:57:04)
    6. one next thing to work on would be karaf, but for that it likely make sense to reach out to amit and alex as well so that we can define our features and make it work across the project (colindixon, 21:57:58)
    7. https://plus.google.com/hangouts/_/g5dxohkjx7tt6btr33xendwqima (colindixon, 22:09:34)
    8. André fixed and added the getCreatedData so we can see hosts now (djx, 00:55:46)
    9. ACTION: next thing djx will look at karaf (djx, 01:08:18)


Meeting ended at 01:08:30 UTC (full logs).

Action items

  1. next thing djx will look at karaf


Action items, by person

  1. djx
    1. next thing djx will look at karaf


People present (lines said)

  1. colindixon (110)
  2. djx (65)
  3. evanz (37)
  4. devinavery (8)
  5. odl_meetbot (4)


Generated by MeetBot 0.1.4.