13:06:40 <regXboi> #startmeeting jquery_07_09
13:06:40 <odl_meetbot> Meeting started Wed Jul  9 13:06:40 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:06:40 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:06:40 <odl_meetbot> The meeting name has been set to 'jquery_07_09'
13:06:49 <regXboi> #chair devinavery
13:06:49 <odl_meetbot> Current chairs: devinavery regXboi
13:07:59 <regXboi> #link https://github.com/neel1438/Opendaylight latest code
13:08:19 <regXboi> #info all tests passing now
13:09:21 <devinavery> Neel - not sure if you are aware of dynamic length arguments - but it is a really power tool and a nice way to avoid having to create intermidate arrays. :) - check it out when you have a minute and try applying it to the “setChildren” method. http://www.deitel.com/articles/java_tutorials/20060106/VariableLengthArgumentLists.html
13:09:58 <regXboi> so, given that the tests are passing (and therefore we are building XML on the fly in a way Xpath likes)
13:10:27 <Neel_B> regXboi: present issue is that i cannot generate archetype from "mvn archetype:generate -DarchetypeGroupId=org.opendaylight.toolkit  -DarchetypeArtifactId=md-sal-app-simple "
13:10:35 <Neel_B> yeah
13:10:42 <Neel_B> i will change it now then
13:11:08 <regXboi> #info next issue is failure to generate md-sal-app-simple archetype
13:11:28 <regXboi> Neel_B: you are trying to do this mvn from where?
13:11:40 <Neel_B> i tried from empty folder
13:11:55 <Neel_B> also tried from controller/opendaylight/md-sal
13:12:11 <devinavery> I am trying to reproduce the issue on one of my empty systems - I think the issue is that he isn’t finding the right repo… not positive though
13:12:16 <regXboi> ok, let me take a shot at it
13:12:20 <regXboi> as well
13:12:50 <devinavery> regXboi: If you can, run it first from outside any opendaylight maven repository
13:13:00 <devinavery> See if it downloads the archetype for you or not
13:13:30 <devinavery> Neel_B - can you go to your ~/.m2/repository/org/opendaylight/toolkit/
13:14:08 <devinavery> Sorry, go to here: ~/.m2/repository/org/opendaylight/toolkit/md-sal-app-simple
13:14:20 <devinavery> and see if that “md-sal-app-simple” folder exists in your maven repository?>
13:14:26 <Neel_B> wait
13:14:40 <regXboi> works for me
13:15:09 <regXboi> [INFO] BUILD SUCCESS
13:15:16 <Neel_B> folder doesn't exist
13:15:33 <regXboi> that was running it outside of any thing
13:15:38 <devinavery> Ok. So it is definetly not able to download the jar to your local REpo
13:15:52 <regXboi> do we have a paste bin of the error messages?
13:15:59 <Neel_B> ~/.m2/repository/org/opendaylight/ has odlparent and yangtools
13:16:07 <Neel_B> there is no error
13:16:16 <devinavery> Ok. I actually think I am seeing the same issue that Neel is seeing on another window
13:16:36 <Neel_B> i am defaultly  installing sample maven application
13:16:54 <Neel_B> which has app.java with hello world in it
13:16:54 <devinavery> Sorry - I am seeing the same issue in a VM that I have.
13:17:00 <devinavery> I can paste it to paste bin in a second
13:19:08 <devinavery> pastebin.com/W64h4zYV
13:19:26 <devinavery> Basically it is saying it can’t find the archetype. Which I think is because it doesn’t know to look to the ODL repository for it
13:19:47 <Neel_B> same issue
13:19:55 <regXboi> #link http://pastebin.com/W64h4zYV is the issue being faced
13:20:00 <Neel_B> exactlyl
13:21:29 <regXboi> um hold on
13:21:37 <regXboi> devinavery
13:21:41 <regXboi> in that VM
13:21:46 <regXboi> where you get to the 438 prompt
13:21:56 <regXboi> do me a favor - just hit return
13:22:18 <Neel_B> thats what i have done
13:22:53 <Neel_B> 438 in that list refers to
13:22:54 <Neel_B> 438: remote -> org.apache.maven.archetypes:maven-archetype-quickstart (An archetype which contains a sample Maven project.)
13:23:14 <regXboi> yeah, that's not going to work
13:23:25 <devinavery> Just accepting defaults through that created a different project
13:23:50 <Neel_B> it has app.java in src with hello world code
13:24:09 <devinavery> 438 points to a maven archetype quickstart
13:24:21 <regXboi> ok, so let's try something else
13:24:31 <devinavery> I think what we need to do is tell maven to look to ODLnexus repos
13:25:13 * regXboi pads off to find someone who might have a clue
13:25:55 <devinavery> Think I found something. Trying...
13:30:00 <devinavery> Got it
13:31:01 <devinavery> Neel - please try running this command
13:31:03 <devinavery> mvn archetype:generate -DarchetypeCatalog=http://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/archetype-catalog.xml -DarchetypeGroupId=org.opendaylight.toolkit  -DarchetypeArtifactId=md-sal-app-simple
13:32:21 <regXboi> interesting - I get a failure on that one
13:32:27 <Neel_B> okay 1 min
13:33:48 <devinavery> regXboi - try https: instead of http…
13:34:15 <devinavery> regXboi - also if you can paste the error please (was going to update the wiki with this… so want to understand what you are seeing). :)
13:34:17 <Neel_B> http://pastebin.com/Mz5KpCVv
13:34:42 <regXboi> Neel_B beat me to it - that's what I'm seeing
13:34:51 <regXboi> https and http don't matter
13:35:34 <devinavery> THats weird… peer not authenticateD?
13:35:41 <devinavery> I didn’t do anything special (that I know of)…
13:35:44 <Neel_B> The desired archetype does not exist
13:35:50 <Neel_B> thats the line i saw
13:36:09 <Neel_B> first line of error in that paste
13:36:40 <regXboi> the question is, what is your trust store in the JRE
13:36:46 <regXboi> and is it different from ours?
13:37:44 <devinavery> regXboi: do you know how to check that? I am using hte techtorial VM, so it is likely set to allow ODL..
13:38:03 <regXboi> devinavery: not off the top of my head
13:38:15 <regXboi> I'm chasing down how to do that now
13:40:17 <devinavery_> Sorry - got kicked out.
13:45:30 <devinavery_> Can anyone see this? Just make sure I am still connected
13:46:07 <regXboi> devinavery_: yes I can
13:46:16 <regXboi> sorry, I'm chasing down where my keystore is
13:46:16 <devinavery_> Thanks
13:46:21 <devinavery_> yup
13:46:31 <regXboi> but it looks like we have to add the nexus cert to the keystore
13:50:52 <regXboi> ok I see the problem
13:51:46 <regXboi> on my system, the CA that signed the LF certificate is not trusted because of a claimed certificate chaining error
13:51:57 <regXboi> so I don't think I'm going to be all that helpful
13:52:29 <devinavery> Yeah. Ok. I am seeing the same error on my side as well.
13:54:01 <devinavery> My question is why does it kick of to HTTPS? :)
13:55:20 <regXboi> #info problem with archetypes appears to be first, needing the proper catalog location
13:55:37 <regXboi> #info and second the proper certificate to be able to download the archetype catalog
13:56:06 <devinavery> We can get around this issue for now by having Neel_B download the toolkit project and just build the archetype mannually for now
13:56:14 <regXboi> yeah, I guess so
13:56:24 <regXboi> because this is going to take others to look at and help with
13:57:08 <devinavery> Yeah. I can reproduce the issue now on my system when I force the path. So I think at this point we should just get Neel_B moving.
13:57:33 <Neel_B> sorry some thing happened i don't know why i got disconnected
13:57:34 <devinavery> Neel_B: can you download the “toolkit” project and run a mvn clean install from the root directory please?
13:57:53 <Neel_B> one min
13:57:57 <devinavery> git clone https://git.opendaylight.org:29418/toolkit.git
13:59:27 <Neel_B> sone
13:59:35 <Neel_B> running mvn clean install
14:02:49 <devinavery> After that, please go back and try to run the original command again
14:03:05 <Neel_B> okay sure
14:05:44 <Neel_B> sontinue on next please
14:05:58 <Neel_B> its going take a minute or 2
14:06:03 <devinavery> Yup
14:13:41 <Neel_B> got it
14:16:54 <Neel_B> i completed build
14:18:07 <devinavery> Ok Great. So you finished the build
14:18:13 <Neel_B> yeah
14:18:37 <devinavery> Great. And you followed the rest of the steps in the archetype page?
14:18:39 <Neel_B> generator and then followed by mvn clean install
14:18:41 <Neel_B> yeah
14:19:10 <regXboi> very good
14:19:23 <regXboi> so, can we put in some next steps to the meeting minutes?
14:19:25 <devinavery> Awesome. So we are going to use the provider for now to get access to the MD-SAL datastores
14:19:34 <devinavery> Sure.
14:19:39 <regXboi> devinavery - you are chair - throw those in as #action
14:19:54 <devinavery> Will do.
14:20:01 <devinavery> Need to collect my thoughts here quickly.. :)
14:21:33 <devinavery> Ok.. I am going to list out what I think the next steps are here, and then if we agree we can throw them into the #action
14:22:23 <Neel_B> okay
14:22:36 <devinavery> So, I think the next thing is to get ahold of the DOMDataBroker class. We can do that hopefully by getting from the config subsystem / or from the “SalServices” in the Module class that was generated
14:23:52 <devinavery> The DOMDataBroker is the generic API into the MD-SAL. Once we have the DOMDataBroker, we then need to create a read transaction, and then perform reads to data nodes, wrapping those nodes with what we learned about Element interface etc
14:23:54 <regXboi> devinavery: that sounds good to me
14:24:30 <devinavery> There are definetly some complications with regards to the read transactions and how we get the “root” of the tree if you will.
14:25:06 <devinavery> So, I think for tomorrow Neel - I would make this your goal:  Get access to the DOMDataBroker object, and try and do a quick read to the API.
14:25:23 <Neel_B> okay
14:26:13 <devinavery> #action For tomorrow Neel_B will attempt to modify the generated class (TaskModule) to gain access to the DOMDataBroker.
14:26:43 <regXboi> yeah, I think that's enough
14:26:57 <regXboi> that's likely going to be *interesting*
14:27:08 <devinavery> #action Once we have the DOMDataBroker, we want to create a read transaction, and consider how we might map what we learned about the Element interface onto the NormalizedNode
14:27:24 <devinavery> regXboi: agree - just getting the DOMDataBroker will be a challange.
14:27:34 <Neel_B> okay i am following
14:27:54 <regXboi> I think that's good enough
14:27:57 <devinavery> Neel_B: Do you think you have an idea of how you might go about getting hte DOM DataBroker? Or do you need some pointers?
14:28:11 <regXboi> I need to go bug helpdesk about the cert issue we hit
14:28:35 <devinavery> regXboi: ok great. If you need anything from me please let me know. Also please let me know if they resolve it so I can update the wiki accordingly
14:28:37 <Neel_B> where is the TaskModule
14:28:38 <Neel_B> ?
14:29:23 <devinavery> Sorry “TaskProviderModule” is the name. It should be under the Provider project. org.opendaylight.controller.config.yang.config.task_provider.impl
14:29:26 <Neel_B> found it
14:30:47 <Neel_B> some pointers would be great
14:31:09 <Neel_B> actually we have a new app so the dataBroker isnot empty ?
14:31:38 <devinavery> Ok. So this will be slightly confusing
14:31:57 <Neel_B> okay go on
14:32:39 <devinavery> 90% of the time, folks will want to use the “DataBroker”, which has strong typing (meaning you need to pass in and expect to get back specific java classes).
14:33:09 <devinavery> This cover’s most peoples uses cases. Problem is, we want to interact with the databroker in a generic way, not a specific (or strongly typed way).
14:33:46 <Neel_B> okay makes some sense
14:34:07 <devinavery> SO, what the archetype provides access to is the the strongly typed data broker (called “DataBroker”). We need access to the generic interface which is called “DOMDataBroker”. So we are going to have to modify a few things to get access to that
14:34:31 <devinavery> We you planning on continue work in the next hour or two? If not I can summerize in an e-mail and send it out
14:35:00 <Neel_B> summarize it in an email
14:35:17 <Neel_B> i have to eat and i can continue in the nigjt
14:35:36 <Neel_B> like i will continue after an hour or so
14:35:40 <devinavery> Ok. Let me summerize via e-mail the next steps. I can have that done in about 30 minutes.
14:35:48 <Neel_B> okay
14:36:01 <Neel_B> thanks a lot for spending so much time on me :D
14:36:13 <devinavery> #action devinavery to summerize a few specifics of how to get access to the DOMDataBroker and will send e-mail to Neel_B.
14:36:23 <devinavery> No problem. This is exciting stuff so I want to see it work.
14:36:33 <devinavery> Alright, I think that wraps it up for today then.
14:36:50 <Neel_B> have a good day
14:37:03 <devinavery> #endmeeting