15:22:55 <colindixon> #startmeeting jQuery/XPath for MD-SAL
15:22:55 <odl_meetbot> Meeting started Thu Jul 24 15:22:55 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:22:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:22:55 <odl_meetbot> The meeting name has been set to 'jquery_xpath_for_md_sal'
15:23:04 <colindixon> #topic status update
15:23:19 <colindixon> #Info I think that Neel_B is still having issues with connection refused in the toaster-it
15:23:39 <regXboi> sounds like it
15:25:36 <colindixon> Neel_B: am I understanding that you tested this on another computer?
15:25:43 <regXboi> I'm not sure how to address this without doing flushing iptables
15:26:15 <Neel_B> i put another os paralley in my system
15:26:28 <Neel_B> now ubuntu 14.04
15:26:37 <Neel_B> before it was debian
15:27:15 <colindixon> can you give us your ipatables config
15:29:46 <Neel_B> just a min
15:29:46 <colindixon> ?
15:29:48 <colindixon> sure
15:30:26 <Neel_B> it is a new os i did not touch iptables at all so i guess it should be empty
15:30:56 <regXboi> don't necessarily assume that
15:31:05 <regXboi> if it's a VM that's not always true
15:32:09 <Neel_B> http://pastebin.com/v9X8fwu1
15:32:21 <Neel_B> result of iptables -L
15:32:23 * regXboi looks
15:32:42 <regXboi> ok, that *look* pretty clean
15:33:44 <colindixon> ok
15:33:57 <colindixon> so, I really have no idea what’s going on here
15:34:06 <colindixon> I e-mailed the controller-dev list
15:35:55 <regXboi> so... we've verified that when toaster-it fails, there *is* something listening on that port?
15:36:07 <regXboi> because my next thought is the SUT isn't starting properly
15:38:43 <colindixon> ok
15:39:01 <colindixon> Neel_B: I’d like to put this issue on the back burner and try to make progress without needing pax-exam
15:39:35 <regXboi> *agreed*
15:40:12 <Neel_B> okay i've tried to add one more rpc call  to call out testcases.java
15:40:46 <colindixon> ok
15:40:51 <Neel_B> i got struck writing the  function ...
15:41:24 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2014-July/005616.html I sent that e-mail to controller-dev 10 days ago and it’s gotten now response :-/
15:42:02 <colindixon> #info correction, no response
15:42:17 <colindixon> so Neel_B what test case are you having trouble with?
15:43:59 * regXboi summons a leaner
15:44:57 <regXboi> note: I have a phone call at the top of the hour that I can't ignore
15:45:18 <regXboi> colindixon: I'm trying to pull edwarnicke over to help with that email that fell on deaf ears
15:45:39 <edwarnicke> regXboi: I didn't do it, nobody saw me, you can't prove anything
15:46:03 <regXboi> edwarnicke... look up a few lines - colin sent email to controller dev about toaster-it problems - no response
15:46:38 * regXboi looks to edwarnicke to exercise his "phenominal, cosmic power" of encouragement :)
15:47:05 <colindixon> my Brocade folks are telling me that the issue seems to be that the integration test is going out to Nexus
15:47:06 * edwarnicke wonders where to direct his sudden feelings of being encouraged
15:47:20 <colindixon> and that’s failing
15:47:59 <regXboi> edwarnicke: more encouraging people to help answer
15:48:48 <colindixon> Neel_B: this is failing with the stock, vanilla toaster-it still
15:48:49 <colindixon> ?
15:49:20 <Neel_B> i didn't get you
15:50:28 <colindixon> so, if you did a “git clone https://git.opendaylight.org/gerrit/controller && cd controller/opendaylight/md-sal/samples/toaster-it && mvn clean install”
15:50:34 <Neel_B> i am trying the toaster it in md-sal/samples/toaster-it
15:50:34 <colindixon> so, a fresh, clean version
15:50:43 <colindixon> that works?
15:50:46 <Neel_B> no
15:51:14 <Neel_B> that says connection refused
15:51:25 <colindixon> ok
15:51:44 <colindixon> and somebody else says try “mvn test --debug” to get some more output
15:52:04 <colindixon> and he’s curious if it also fails if you run it from eclipse
15:52:18 <Neel_B> yeah it falis from eclipse too
15:52:28 <Neel_B> with same connection error
15:52:37 <colindixon> ok
15:53:04 <colindixon> can you try the debug flag to see if that helps to produce more output
15:56:58 <colindixon> #info some suggestions from people at Brocade (see the full IRC logs)
15:57:58 <colindixon> Neel_B: any luck with running “mvn test --debug"
15:58:06 <Neel_B> copying
15:58:09 <Neel_B> to pastebin
15:59:32 <Neel_B> can you check the mail please
15:59:37 <colindixon> sure
15:59:49 <colindixon> did you send something?
16:00:47 <Neel_B> text file with redirected out put filr
16:00:56 <colindixon> got it now
16:03:35 <colindixon> Neel_B: can you debug the test in eclipse and try to set a breakpoint here: org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:601)
16:03:38 <colindixon> and figure out what the URL is
16:03:40 <colindixon> that’s failing
16:03:58 <Neel_B> just a min
16:04:01 <colindixon> sure
16:06:39 <colindixon> #info one suggestion is to debug the toaster-it from Eclipse to look at what the parameters are that being passed to org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61) by setting a debug breakpoint at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:601)
16:06:43 <colindixon> #topic next steps
16:06:58 <colindixon> Neel_B: are you around tomorrow? I’m going to be really busy, but I can try to find time
16:07:08 <colindixon> we should set up a meeting for Monday if not tomorrow to keep pushing
16:14:12 <Neel_B> sure
16:14:19 <Neel_B> when ever you feel free
16:14:24 <Neel_B> i will contact through mails
16:15:04 <colindixon> #action colindixon to coordinate with Neel_B via mail about next steps and the next meeting
16:15:07 <colindixon> #endmeeting