#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 13:01:18 UTC (full logs).

Meeting summary

  1. status update (colindixon, 13:01:41)
    1. Neel uploaded his most recent changes to his git repo (devinavery, 13:04:09)
    2. https://github.com/neel1438/Opendaylight/tree/master/jquery/src/jquery the changes are here (colindixon, 13:04:16)
    3. http://pastebin.com/tt8gh1Z3 (Neel_B, 13:07:08)
    4. hardcoding a DOM tree turns out to be more complext than you’d hope, among other things we’re going to to need to look at implementing our own version of NamedNodeMap if we want to use XPath (colindixon, 13:07:09)
    5. http://pastebin.com/3gmmARkh (Neel_B, 13:12:15)

  2. review and next steps (colindixon, 13:17:11)
    1. devinavery notes that at least in the MD-SAL as it gets serialized to XML via RESTCONF, there are no attributes, which may allow us to avoid implementing a NamedNodeMap (colindixon, 13:27:10)
    2. devinavery points out that we should really keep the query semantics for XPath to be such that the query behaves as though it were run on the XML that RESTCONF returns so that people can figure out how to craft queries and what to expect back (colindixon, 13:28:39)

  3. concrete next steps (colindixon, 13:29:53)
    1. ACTION: Implement a new Node implementation, that throws "MethodNotSupportted" exceptions (or something) in every method. Then modify the dummy hardcodded nodes to extend that class. (colindixon, 13:31:19)
    2. ACTION: Modify the test xml document (and hardcoded nodes) to remove the attributes, and just use child tags. For example <a><b><id>b_id</id><c><id>c_id</id></c></b></a> (colindixon, 13:31:29)
    3. ACTION: Implemnt the remaining missing methods when you run it (presently that is getNodeType() method) (colindixon, 13:31:39)
    4. Part of modifying the test document is to modify the test as well. Instead of @id on line 115 of the test, we should just use 'id' (i.e. remove the @ symbol so you reference a child node instead of an attribute) (colindixon, 13:33:50)
    5. there was a lot of discussion back and forth (with code examples) about exactly what to do next (colindixon, 13:51:48)
    6. Neel_B to work on the action items and e-mail progress, we’ll decide whether to meet at this time tomorrow: http://www.timeanddate.com/worldclock/meetingdetails.html?year=2014&month=7&day=1&hour=15&min=0&sec=0&p1=24&p2=43&p3=505 (colindixon, 13:57:45)


Meeting ended at 13:57:56 UTC (full logs).

Action items

  1. Implement a new Node implementation, that throws "MethodNotSupportted" exceptions (or something) in every method. Then modify the dummy hardcodded nodes to extend that class.
  2. Modify the test xml document (and hardcoded nodes) to remove the attributes, and just use child tags. For example <a><b><id>b_id</id><c><id>c_id</id></c></b></a>
  3. Implemnt the remaining missing methods when you run it (presently that is getNodeType() method)


People present (lines said)

  1. colindixon (57)
  2. devinavery (55)
  3. Neel_B (40)
  4. regXboi (28)
  5. odl_meetbot (3)


Generated by MeetBot 0.1.4.