#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 15:10:07 UTC (full logs).

Meeting summary

    1. https://github.com/neel1438/Opendaylight/ Neel_B has updated the github with his latest code (colindixon, 15:10:27)
    2. it seems as thoguh the sample code for the new node is behaving oddly, but it’s hard to tell if it’s right or not (colindixon, 15:17:27)
    3. the next step woudl be to build a unit test (or a few) which make parallel calls to a real Document and to a Node that we think should behave the same (colindixon, 15:17:57)
    4. ACTION: Neel_B to create unit tests where he compares the result of XPath queries to his Node implementations to a Document which we believe should be the same (colindixon, 15:32:20)
    5. colindixon showed Neel_B a bit of how to use the Eclipse interactive debugger (which will hopefully help a bit) and talked about next steps a bit (colindixon, 15:41:25)
    6. the 3 test queries that seem to make sense to start with for unit tests are “/“, “/*” and “//a/b/c1”, but Neel_B should use his judgement if those queries either don’t work or he thinks there are more tests that make sense (colindixon, 15:43:25)
    7. http://pastebin.com/LKTKrsyL (Neel_B, 15:43:58)


Meeting ended at 15:51:04 UTC (full logs).

Action items

  1. Neel_B to create unit tests where he compares the result of XPath queries to his Node implementations to a Document which we believe should be the same


Action items, by person

  1. Neel_B
    1. Neel_B to create unit tests where he compares the result of XPath queries to his Node implementations to a Document which we believe should be the same


People present (lines said)

  1. colindixon (63)
  2. Neel_B (50)
  3. devinavery (15)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.